]> git.pld-linux.org Git - packages/firefox.git/commitdiff
unbreak geckodriver by avoiding perl class auto/th/firefox-78.0-1
authorJan Palus <atler@pld-linux.org>
Wed, 1 Jul 2020 09:52:45 +0000 (11:52 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 1 Jul 2020 09:52:45 +0000 (11:52 +0200)
see https://bugzilla.mozilla.org/show_bug.cgi?id=1649508

firefox.spec
geckodriver-regex.patch [new file with mode: 0644]

index 6f850791cead6ab9968779752ef1bf8faeb91d4d..b36bde614b61a2f6979ed5925c6985577f049f7d 100644 (file)
@@ -244,6 +244,7 @@ Source191:  http://releases.mozilla.org/pub/firefox/releases/%{version}/linux-i68
 Source192:     http://releases.mozilla.org/pub/firefox/releases/%{version}/linux-i686/xpi/zh-TW.xpi
 # Source192-md5:       3837f29330593e310a87a9daa36157d5
 
+Patch0:                geckodriver-regex.patch
 Patch4:                %{name}-prefs.patch
 Patch5:                %{name}-pld-bookmarks.patch
 Patch6:                %{name}-no-subshell.patch
@@ -2020,6 +2021,7 @@ unpack() {
 %define __unzip unpack
 %setup -q %(seq -f '-a %g' 100 192 | xargs)
 
+%patch0 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p2
diff --git a/geckodriver-regex.patch b/geckodriver-regex.patch
new file mode 100644 (file)
index 0000000..0b92e1d
--- /dev/null
@@ -0,0 +1,11 @@
+--- firefox-78.0/testing/geckodriver/src/capabilities.rs.orig  2020-07-01 11:46:43.489401648 +0200
++++ firefox-78.0/testing/geckodriver/src/capabilities.rs       2020-07-01 11:47:03.525900589 +0200
+@@ -79,7 +79,7 @@
+     fn version_from_binary(&self, binary: &PathBuf) -> Option<String> {
+         let version_regexp =
+-            Regex::new(r#"\d+\.\d+(?:[a-z]\d+)?"#).expect("Error parsing version regexp");
++            Regex::new(r#"[0-9]+\.[0-9]+(?:[a-z][0-9]+)?"#).expect("Error parsing version regexp");
+         let output = Command::new(binary)
+             .args(&["-version"])
+             .stdout(Stdio::piped())
This page took 0.049837 seconds and 4 git commands to generate.