]> git.pld-linux.org Git - packages/firefox.git/commitdiff
upstream fix for new geckodriver regression; rel 2 auto/th/firefox-80.0-2
authorJan Palus <atler@pld-linux.org>
Wed, 26 Aug 2020 11:39:18 +0000 (13:39 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 26 Aug 2020 11:39:18 +0000 (13:39 +0200)
see https://bugzilla.mozilla.org/show_bug.cgi?id=1658870

firefox.spec
geckodriver-version-check.patch [new file with mode: 0644]

index d1155a617350b51406c1ab5816c6f3ef07a060c0..0f80337213c4be51f4808b28e4d2cd65b8865f5f 100644 (file)
@@ -48,7 +48,7 @@ Summary(hu.UTF-8):    Firefox web böngésző
 Summary(pl.UTF-8):     Firefox - przeglądarka WWW
 Name:          firefox
 Version:       80.0
-Release:       1
+Release:       2
 License:       MPL v2.0
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/firefox/releases/%{version}/source/firefox-%{version}.source.tar.xz
@@ -244,6 +244,7 @@ Source191:  http://releases.mozilla.org/pub/firefox/releases/%{version}/linux-i68
 Source192:     http://releases.mozilla.org/pub/firefox/releases/%{version}/linux-i686/xpi/zh-TW.xpi
 # Source192-md5:       4b084ac47b0106ae4a751ea35f4ad413
 
+Patch0:                geckodriver-version-check.patch
 Patch4:                %{name}-prefs.patch
 Patch5:                %{name}-pld-bookmarks.patch
 Patch6:                %{name}-no-subshell.patch
@@ -2020,6 +2021,7 @@ unpack() {
 %define __unzip unpack
 %setup -q %(seq -f '-a %g' 100 192 | xargs)
 
+%patch0 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p2
diff --git a/geckodriver-version-check.patch b/geckodriver-version-check.patch
new file mode 100644 (file)
index 0000000..a5d10d8
--- /dev/null
@@ -0,0 +1,42 @@
+
+# HG changeset patch
+# User Henrik Skupin <mail@hskupin.info>
+# Date 1597313122 0
+# Node ID 46b078983080ca4d87e2305d781855b080fc1643
+# Parent  082de8244278d76f9d6d216a7fd5da772b5152d3
+Bug 1658870 - [geckodriver] Remove Firefox version check for acceptInsecureCerts. r=webdriver-reviewers,jgraham
+
+Differential Revision: https://phabricator.services.mozilla.com/D86917
+
+diff --git a/testing/geckodriver/src/capabilities.rs b/testing/geckodriver/src/capabilities.rs
+--- a/testing/geckodriver/src/capabilities.rs
++++ b/testing/geckodriver/src/capabilities.rs
+@@ -127,26 +127,17 @@ impl<'a> BrowserCapabilities for Firefox
+         } else if cfg!(target_os = "linux") {
+             Some("linux".into())
+         } else {
+             None
+         })
+     }
+     fn accept_insecure_certs(&mut self, _: &Capabilities) -> WebDriverResult<bool> {
+-        let binary = self.chosen_binary.clone();
+-        let version_str = self.version(binary.as_ref().map(|x| x.as_ref()));
+-        if let Some(x) = version_str {
+-            Ok(Version::from_str(&*x)
+-                .or_else(|x| Err(convert_version_error(x)))?
+-                .major
+-                >= 52)
+-        } else {
+-            Ok(false)
+-        }
++        Ok(true)
+     }
+     fn set_window_rect(&mut self, _: &Capabilities) -> WebDriverResult<bool> {
+         Ok(true)
+     }
+     fn compare_browser_version(
+         &mut self,
+
This page took 0.727685 seconds and 4 git commands to generate.