]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- copied from mozilla-firebird.spec
[packages/firefox.git] / mozilla-firefox.spec
1 Summary:        Mozilla Firefox web browser
2 Summary(pl):    Mozilla Firefox - przegl±darka WWW
3 Name:           mozilla-firefox
4 Version:        0.8
5 Release:        0.1
6 License:        MPL/LGPL
7 Group:          Applications/Networking
8 Source0:        http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/firefox-source-%{version}.tar.bz2
9 # Source0-md5:  cdc85152f4219bf3e3f1a8dc46e04654
10 Source1:        %{name}.desktop
11 Patch0:         %{name}-alpha-gcc3.patch
12 URL:            http://www.mozilla.org/projects/firebird/
13 BuildRequires:  gtk+2-devel >= 2.0.0
14 BuildRequires:  libIDL-devel >= 0.8.0
15 BuildRequires:  libjpeg-devel >= 6b
16 BuildRequires:  libpng-devel >= 1.2.0
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  pango-devel >= 1.1.0
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Mozilla Firefox is an open-source web browser, designed for standards
23 compliance, performance and portability.
24
25 %description -l pl
26 Mozilla Firefox jest open sourcow± przegl±dark± sieci www, stworzon± z
27 my¶l± o zgodno¶ci ze standartami, wydajno¶ci± i przeno¶no¶ci±.
28
29 %prep
30 %setup -q -n mozilla
31 %patch0 -p1
32
33 ### FIXME: Shouldn't the default firebird config be part of original source ?
34 cat <<EOF >.mozconfig
35 export MOZ_PHOENIX="1"
36 mk_add_options MOZ_PHOENIX="1"
37 ac_add_options --with-system-jpeg
38 ac_add_options --with-system-zlib
39 ac_add_options --with-system-png
40 ac_add_options --with-system-mng
41 ac_add_options --with-pthreads
42 ac_add_options --disable-tests
43 ac_add_options --disable-debug
44 ac_add_options --disable-debug-modules
45 ac_add_options --disable-xprint
46 ac_add_options --disable-mailnews
47 ac_add_options --disable-composer
48 ac_add_options --disable-ldap
49 ac_add_options --disable-jsd
50 ac_add_options --disable-dtd-debug
51 ac_add_options --disable-gtktest
52 ac_add_options --disable-freetypetest
53 ac_add_options --disable-installer
54 ac_add_options --enable-plaintext-editor-only
55 ac_add_options --enable-optimize="%{optflags}"
56 ac_add_options --enable-crypto
57 ac_add_options --enable-strip
58 ac_add_options --enable-strip-libs
59 ac_add_options --enable-reorder
60 ac_add_options --enable-mathml
61 ac_add_options --enable-xinerama
62 ac_add_options --enable-extensions="pref,cookie,wallet"
63 ac_add_options --enable-freetype2
64 ac_add_options --enable-xft
65 ac_add_options --enable-default-toolkit="gtk2"
66 EOF
67
68 %build
69 #export MOZ_PHOENIX="1"
70 #configure
71 #{__make} %{?_smp_mflags}
72
73 export CFLAGS="%{optflags}"
74 export CXXFLAGS="%{optflags}"
75 export MOZ_PHOENIX="1"
76
77 %{__make} -f client.mk build
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}}
82
83 %{__make} -C xpinstall/packager \
84         MOZ_PKG_APPNAME="mozilla-firebird" \
85         MOZILLA_BIN="\$(DIST)/bin/MozillaFirefox-bin"
86
87 #install -m0755 %{name}.sh $RPM_BUILD_ROOT%{_bindir}/mozilla-firebird
88 ln -sf %{_libdir}/mozilla-firebird/MozillaFirefox $RPM_BUILD_ROOT%{_bindir}/mozilla-firebird
89
90 tar -xvz -C $RPM_BUILD_ROOT%{_libdir} -f dist/mozilla-firebird-*-linux-gnu.tar.gz
91
92 install browser/base/skin/Throbber.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firebird.png
93 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_libdir}/mozilla-firebird/defaults/profile/
94 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_libdir}/mozilla-firebird/defaults/profile/US/
95
96 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_bindir}/*
104 ## TODO:  %{_libdir}/mozilla-firebird/MozillaFirefox* powinny miec +x 
105 ##         ale niewiem jak to prosto zorbic.
106 %dir %{_libdir}/mozilla-firebird
107 %{_libdir}/mozilla-firebird/res
108 %{_libdir}/mozilla-firebird/chrome
109 %{_libdir}/mozilla-firebird/components
110 %{_libdir}/mozilla-firebird/plugins
111 %{_libdir}/mozilla-firebird/searchplugins
112 %{_libdir}/mozilla-firebird/icons
113 %{_libdir}/mozilla-firebird/defaults
114 %{_libdir}/mozilla-firebird/ipc
115 %attr(755,root,root) %{_libdir}/mozilla-firebird/*.so
116 %attr(755,root,root) %{_libdir}/mozilla-firebird/*.sh
117 %attr(755,root,root) %{_libdir}/mozilla-firebird/m*
118 %attr(755,root,root) %{_libdir}/mozilla-firebird/M*
119 %attr(755,root,root) %{_libdir}/mozilla-firebird/reg*
120 %attr(755,root,root) %{_libdir}/mozilla-firebird/x*
121 %attr(755,root,root) %{_libdir}/mozilla-firebird/t*
122 %attr(755,root,root) %{_libdir}/mozilla-firebird/T*
123 %ifarch %{ix86}
124 %attr(755,root,root) %{_libdir}/mozilla-firebird/elf-dynstr-gc
125 %endif
126 %attr(755,root,root) %{_libdir}/mozilla-firebird/libsoftokn3.chk
127 %attr(755,root,root) %{_libdir}/mozilla-firebird/shlibsign
128 %{_libdir}/mozilla-firebird/bloaturls.txt
129 %{_pixmapsdir}/*
130 %{_desktopdir}/*
This page took 0.116525 seconds and 4 git commands to generate.