]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- release 1.3: use normal ./configure invocation [ untested ]
[packages/firefox.git] / mozilla-firefox.spec
1 %bcond_with tests       # enable tests (whatever they check)
2 #
3 Summary:        Mozilla Firefox web browser
4 Summary(pl):    Mozilla Firefox - przegl±darka WWW
5 Name:           mozilla-firefox
6 Version:        0.8
7 Release:        1.3
8 License:        MPL/LGPL
9 Group:          X11/Applications/Networking
10 Source0:        http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/firefox-source-%{version}.tar.bz2
11 # Source0-md5:  cdc85152f4219bf3e3f1a8dc46e04654
12 Source1:        %{name}.desktop
13 Patch0:         %{name}-alpha-gcc3.patch
14 URL:            http://www.mozilla.org/projects/firefox/
15 BuildRequires:  gtk+2-devel >= 2.0.0
16 BuildRequires:  libIDL-devel >= 0.8.0
17 BuildRequires:  libjpeg-devel >= 6b
18 BuildRequires:  libpng-devel >= 1.2.0
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  pango-devel >= 1.1.0
21 BuildRequires:  zip
22 Obsoletes:      mozilla-firebird
23 Requires:       %{name}-lang-resources
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define _firefoxdir     %{_libdir}/%{name}
27
28 %description
29 Mozilla Firefox is an open-source web browser, designed for standards
30 compliance, performance and portability.
31
32 %description -l pl
33 Mozilla Firefox jest open sourcow± przegl±dark± sieci www, stworzon± z
34 my¶l± o zgodno¶ci ze standartami, wydajno¶ci± i przeno¶no¶ci±.
35
36 %package lang-en
37 Summary:        English resources for Mozilla-firefox
38 Summary(pl):    Anglojêzyczne zasoby dla Mozilla-FireFox
39 Group:  X11/Applications/Networking
40 Requires(post,postun):  mozilla-firefox >= %{version}-1.1
41 Requires(post,postun):  textutils
42 Requires:       mozilla-firefox >= %{version}-1.1
43 Provides:       %{name}-lang-resources
44 Obsoletes:      %{name}-lang-resources
45
46 %description lang-en
47 English resources for Mozilla-firefox
48
49 %description lang-en -l pl
50 Anglojêzyczne zasoby dla Mozilla-FireFox
51
52 %prep
53 %setup -q -n mozilla
54 %patch0 -p1
55
56 %build
57 export CFLAGS="%{optflags}"
58 export CXXFLAGS="%{optflags}"
59 export MOZ_PHOENIX="1"
60
61 ./configure \
62         --with-system-jpeg \
63         --with-system-zlib \
64         --with-system-png \
65         --with-system-mng \
66         --with-pthreads \
67 %if %{with debug}
68         --enable-debug \
69         --enable-debug-modules \
70 %else
71         --disable-debug \
72         --disable-debug-modules \
73 %endif
74         --disable-xprint \
75         --disable-mailnews \
76         --disable-composer \
77         --disable-ldap \
78         --disable-jsd \
79         --disable-dtd-debug \
80 %if %{with tests}
81         --enable-tests \
82 %else
83         --disable-tests \
84 %endif
85         --disable-installer \
86         --enable-plaintext-editor-only \
87         --enable-optimize="%{optflags}" \
88         --enable-crypto \
89         --enable-strip \
90         --enable-strip-libs \
91         --enable-reorder \
92         --enable-mathml \
93         --enable-xinerama \
94         --enable-freetype2 \
95         --enable-xft \
96         --enable-default-toolkit="gtk2"
97
98 #{__make} %{?_smp_mflags}
99 %{__make} -f client.mk build
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}}
104
105 %{__make} -C xpinstall/packager \
106         MOZ_PKG_APPNAME="mozilla-firefox" \
107         MOZILLA_BIN="\$(DIST)/bin/firefox-bin"
108
109 #install -m0755 %{name}.sh $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
110 ln -sf %{_firefoxdir}/firefox $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
111
112 tar -xvz -C $RPM_BUILD_ROOT%{_libdir} -f dist/mozilla-firefox-*-linux-gnu.tar.gz
113
114 install browser/base/skin/Throbber.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
115 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/
116 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/US/
117
118 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
119
120 grep locale $RPM_BUILD_ROOT%{_firefoxdir}/chrome/installed-chrome.txt > $RPM_BUILD_ROOT%{_firefoxdir}/chrome/%{name}-en-US-installed-chrome.txt
121 grep -v locale $RPM_BUILD_ROOT%{_firefoxdir}/chrome/installed-chrome.txt > $RPM_BUILD_ROOT%{_firefoxdir}/chrome/%{name}-misc-installed-chrome.txt
122
123 rm -rf US classic comm embed-sample en-{US,mac,unix,win} modern pipnss pippki toolkit
124 rm -f en-win.jar en-mac.jar embed-sample.jar modern.jar
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post
130 umask 022
131 cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installed-chrome.txt
132
133 %post lang-en
134 umask 022
135 cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installed-chrome.txt
136
137 %postun lang-en
138 umask 022
139 cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installed-chrome.txt
140
141 %files
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/*
144 %dir %{_firefoxdir}
145 %{_firefoxdir}/res
146 %{_firefoxdir}/components
147 %{_firefoxdir}/plugins
148 %{_firefoxdir}/searchplugins
149 %{_firefoxdir}/icons
150 %{_firefoxdir}/defaults
151 %{_firefoxdir}/ipc
152 %attr(755,root,root) %{_firefoxdir}/*.so
153 %attr(755,root,root) %{_firefoxdir}/*.sh
154 %attr(755,root,root) %{_firefoxdir}/m*
155 %attr(755,root,root) %{_firefoxdir}/f*
156 %attr(755,root,root) %{_firefoxdir}/reg*
157 %attr(755,root,root) %{_firefoxdir}/x*
158 %attr(755,root,root) %{_firefoxdir}/T*
159 %ifarch %{ix86}
160 %attr(755,root,root) %{_firefoxdir}/elf-dynstr-gc
161 %endif
162 %attr(755,root,root) %{_firefoxdir}/libsoftokn3.chk
163 %attr(755,root,root) %{_firefoxdir}/shlibsign
164 %{_firefoxdir}/bloaturls.txt
165 %{_pixmapsdir}/*
166 %{_desktopdir}/*
167
168 %dir %{_firefoxdir}/chrome
169 %{_firefoxdir}/chrome/browser.jar
170 %{_firefoxdir}/chrome/classic.jar
171 %{_firefoxdir}/chrome/comm.jar
172 %{_firefoxdir}/chrome/pip*.jar
173 %{_firefoxdir}/chrome/toolkit.jar
174 %{_firefoxdir}/chrome/mozilla-firefox-misc-installed-chrome.txt
175
176 %files lang-en
177 %defattr(644,root,root,755)
178 %{_firefoxdir}/chrome/en-US.jar
179 %{_firefoxdir}/chrome/en-unix.jar
180 %{_firefoxdir}/chrome/US.jar
181 %{_firefoxdir}/chrome/mozilla-firefox-en-US-installed-chrome.txt
This page took 0.054863 seconds and 3 git commands to generate.