]> git.pld-linux.org Git - packages/file-roller.git/blob - file-roller.spec
- updated to 43.1
[packages/file-roller.git] / file-roller.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # API documentation (API not packaged, so disabled for now)
4 %bcond_without  libportal       # native app chooser via libportal
5 %bcond_without  nautilus        # Nautilus extension
6 #
7 Summary:        An archive manager for GNOME
8 Summary(pl.UTF-8):      Zarządca archiwów dla GNOME
9 Summary(pt_BR.UTF-8):   Gerenciador de arquivos compactados para o GNOME
10 Name:           file-roller
11 Version:        43.1
12 Release:        1
13 License:        GPL v2+
14 Group:          X11/Applications
15 Source0:        https://download.gnome.org/sources/file-roller/43/%{name}-%{version}.tar.xz
16 # Source0-md5:  a36e8f27b0793e044652c5bfa187851d
17 Patch0:         %{name}-packages.patch
18 URL:            https://wiki.gnome.org/Apps/FileRoller
19 BuildRequires:  cpio
20 BuildRequires:  desktop-file-utils
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  gettext-tools
23 %{?with_apidocs:BuildRequires:  gi-docgen >= 2021.1}
24 BuildRequires:  glib2-devel >= 1:2.38
25 BuildRequires:  gobject-introspection-devel
26 BuildRequires:  gtk+3-devel >= 3.22.0
27 BuildRequires:  json-glib-devel >= 0.14.0
28 BuildRequires:  libarchive-devel >= 3.2.0
29 BuildRequires:  libhandy1-devel >= 1.5.0
30 %{?with_libportal:BuildRequires:        libportal-devel >= 0.5}
31 %{?with_libportal:BuildRequires:        libportal-gtk3-devel >= 0.5}
32 BuildRequires:  meson >= 0.59
33 %{?with_nautilus:BuildRequires: nautilus-devel >= 43}
34 BuildRequires:  ninja >= 1.5
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(find_lang) >= 1.23
37 BuildRequires:  rpmbuild(macros) >= 1.736
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  xz
40 BuildRequires:  yelp-tools
41 Requires(post,postun):  desktop-file-utils
42 Requires(post,postun):  glib2 >= 1:2.38
43 Requires(post,postun):  gtk-update-icon-cache
44 Requires:       glib2 >= 1:2.38
45 Requires:       gtk+3 >= 3.22.0
46 Requires:       hicolor-icon-theme
47 Requires:       json-glib >= 0.14.0
48 Requires:       libarchive >= 3.2.0
49 Requires:       libhandy1 >= 1.5.0
50 Suggests:       bzip2
51 Suggests:       cpio
52 Suggests:       gzip
53 Suggests:       p7zip
54 %ifarch %{ix86}
55 Suggests:       rar
56 %else
57 Suggests:       unrar
58 %endif
59 Suggests:       tar
60 Suggests:       zip
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 File Roller is an archive manager for the GNOME environment. With File
65 Roller you can: create and modify archives; view the content of an
66 archive; view a file contained in the archive; extract files from the
67 archive. File Roller is only a front-end (a graphical interface) to
68 various archiving programs. The supported file types are:
69 - Tar archives uncompressed (.tar) or compressed with
70  - gzip (.tar.gz , .tgz)
71  - bzip (.tar.bz , .tbz)
72  - bzip2 (.tar.bz2 , .tbz2)
73  - compress (.tar.Z , .taz)
74  - lzop (.tar.lzo , .tzo)
75 - Zip archives (.zip)
76 - Jar archives (.jar , .ear , .war)
77 - Lha archives (.lzh)
78 - Rar archives (.rar)
79 - Single files compressed with gzip, bzip, bzip2, compress, lzop.
80
81 %description -l pl.UTF-8
82 File Roller to zarządca archiwów dla środowiska GNOME. Przy jego
83 pomocy można: tworzyć i modyfikować archiwa, oglądać ich zawartość,
84 oglądać poszczególne pliki zawarte w archiwum oraz rozpakowywać pliki
85 z archiwów. File Roller jest tylko interfejsem graficznym do
86 właściwych programów archiwizujących. Obsługiwane typy plików to:
87 - archiwa tar nieskompresowane (.tar) lub skompresowane programami:
88  - gzip (.tar.gz, .tgz)
89  - bzip (.tar.bz, .tbz)
90  - bzip2 (.tar.bz2, .tbz2)
91  - compress (.tar.Z, .taz)
92  - lzop (.tar.lzo, .tzo)
93 - archiwa zip (.zip)
94 - archiwa jar (.jar, .ear, .war)
95 - archiwa lha (.lzh)
96 - archiwa rar (.rar)
97 - pojedyncze pliki skompresowane programami gzip, bzip, bzip2,
98   compress, lzop.
99
100 %description -l pt_BR.UTF-8
101 File Roller é um gerenciador de pacotes de arquivos compactados para o
102 ambiente GNOME. Com ele é possível criar arquivos, visualizar o
103 conteúdo de arquivos existentes, visualizar um arquivo contido em um
104 pacote e extrair os arquivos de um pacote.
105
106 %package -n nautilus-extension-file-roller
107 Summary:        File Roller (archive manager) extension for Nautilus (GNOME file manager)
108 Summary(pl.UTF-8):      Rozszerzenie File Roller (zarządca archiwów) Nautilusa (zarządcy plików GNOME)
109 Group:          X11/Applications
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       nautilus >= 43
112
113 %description -n nautilus-extension-file-roller
114 File Roller (archive manager) extension for Nautilus (GNOME file
115 manager).
116
117 %description -n nautilus-extension-file-roller -l pl.UTF-8
118 Rozszerzenie File Roller (zarządca archiwów) Nautilusa (zarządcy
119 plików GNOME).
120
121 %prep
122 %setup -q
123 %patch0 -p1
124
125 %build
126 %meson build \
127         %{?with_apidocs:-Dapi_docs=enabled} \
128         -Dintrospection=enabled \
129         %{!?with_nautilus:-Dnautilus-actions=disabled} \
130         %{!?with_libportal:-Duse_native_appchooser=false}
131
132 %ninja_build -C build
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %ninja_install -C build
138
139 # unify name
140 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr@ije,sr@ijekavian}
141 # not supported by glibc (as of 2.38)
142 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
143
144 %find_lang %{name} --with-gnome
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 %update_desktop_database_post
151 %update_icon_cache hicolor
152 %glib_compile_schemas
153
154 %postun
155 %update_desktop_database_postun
156 %update_icon_cache hicolor
157 %glib_compile_schemas
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 %doc AUTHORS MAINTAINERS NEWS README.md README_COMMANDLINE
162 %attr(755,root,root) %{_bindir}/file-roller
163 %dir %{_libexecdir}/file-roller
164 %attr(755,root,root) %{_libexecdir}/file-roller/isoinfo.sh
165 %attr(755,root,root) %{_libexecdir}/file-roller/rpm2cpio
166 %{_datadir}/dbus-1/services/org.gnome.ArchiveManager1.service
167 %{_datadir}/dbus-1/services/org.gnome.FileRoller.service
168 %{_datadir}/file-roller
169 %{_datadir}/glib-2.0/schemas/org.gnome.FileRoller.gschema.xml
170 %{_datadir}/metainfo/org.gnome.FileRoller.appdata.xml
171 %{_desktopdir}/org.gnome.FileRoller.desktop
172 %{_iconsdir}/hicolor/scalable/apps/org.gnome.FileRoller.svg
173 %{_iconsdir}/hicolor/scalable/apps/org.gnome.FileRoller.Devel.svg
174 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.FileRoller-symbolic.svg
175
176 %if %{with nautilus}
177 %files -n nautilus-extension-file-roller
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/nautilus/extensions-4/libnautilus-fileroller.so
180 %endif
This page took 0.095041 seconds and 4 git commands to generate.