]> git.pld-linux.org Git - packages/fife.git/blob - fife.spec
- release 7 (boost 1.73)
[packages/fife.git] / fife.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Flexible Isometric Free Engine
6 Summary(pl.UTF-8):      Flexible Isometric Free Engine - elastyczny, wolnodostępny silnik izometryczny
7 Name:           fife
8 Version:        0.3.5
9 Release:        7
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/fife/%{name}_%{version}.tar.gz
13 # Source0-md5:  11ba50b34239535a270d442466632ef7
14 Patch0:         %{name}-extra_libs.patch
15 Patch1:         %{name}-glee.patch
16 URL:            http://fifengine.net/
17 BuildRequires:  OpenAL-devel
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  SDL-devel
20 BuildRequires:  SDL_image-devel
21 BuildRequires:  SDL_ttf-devel
22 BuildRequires:  boost-devel
23 BuildRequires:  guichan-devel >= 0.8.2
24 BuildRequires:  guichan-opengl-devel >= 0.8.2
25 BuildRequires:  guichan-sdl-devel >= 0.8.2
26 BuildRequires:  libpng-devel
27 BuildRequires:  libvorbis-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  python-devel >= 1:2.7
30 BuildRequires:  scons >= 2.0
31 BuildRequires:  swig-python
32 BuildRequires:  tinyxml-devel
33 BuildRequires:  xorg-lib-libX11-devel
34 BuildRequires:  xorg-lib-libXcursor-devel
35 BuildRequires:  zlib-devel
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 FIFE is a cross platform 2D game creation framework written in C++
40 with Python bindings. It's designed to be flexible enough to support a
41 wide variety of 2D game types but specializes in 2D isometric type
42 views.
43
44 %description -l pl.UTF-8
45 FIFE to wieloplatformowy szkielet do tworzenia gier 2D napisany w C++
46 z wiązaniami do Pythona. Jest zaprojektowany jako wystarczająco
47 elastyczny do obsługi wielu rodzajów gier 2D, ale specjalizuje się w
48 widokach 2D typu izometrycznego.
49
50 %package devel
51 Summary:        Header files for FIFE library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FIFE
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description devel
57 Header files for FIFE library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki FIFE.
61
62 %package static
63 Summary:        Static FIFE library
64 Summary(pl.UTF-8):      Statyczna biblioteka FIFE
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static FIFE library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka FIFE.
73
74 %package -n python-%{name}
75 Summary:        Flexible Isometric Free Engine Python Module
76 Summary(pl.UTF-8):      Moduł Pythona do silnika FIFE (Flexible Isometric Free Engine)
77 Group:          Development/Languages/Python
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       python-modules
80
81 %description -n python-%{name}
82 FIFE is a cross platform 2D game creation framework written in C++
83 with Python bindings. It's designed to be flexible enough to support a
84 wide variety of 2D game types but specializes in 2D isometric type
85 views.
86
87 This package contains Python module.
88
89 %description -n python-%{name} -l pl.UTF-8
90 FIFE to wieloplatformowy szkielet do tworzenia gier 2D napisany w C++
91 z wiązaniami do Pythona. Jest zaprojektowany jako wystarczająco
92 elastyczny do obsługi wielu rodzajów gier 2D, ale specjalizuje się w
93 widokach 2D typu izometrycznego.
94
95 Ten pakiet zawiera moduł Pythona.
96
97 %prep
98 %setup -qn %{name}_%{version}
99 %patch0 -p1
100 %patch1 -p1
101
102 %build
103 # force pre C++11 standard, code uses std::make_pair in a way incompatible with rvalue refs
104 CXXFLAGS="%{rpmcxxflags} -std=c++03"
105 %scons -j1 fife-shared fife-python \
106         %{?with_static_libs:fife-static} \
107         --lib-dir=%{_libdir} \
108         --prefix=%{_prefix} \
109         --python-prefix=%{py_sitedir}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 CXXFLAGS="%{rpmcxxflags} -std=c++03"
115 %scons -j1 install-shared install-python install-dev \
116         %{?with_static_libs:install-static} \
117         --lib-dir=%{_libdir} \
118         --prefix=%{_prefix} \
119         --python-prefix=%{py_sitedir} \
120         --install-sandbox=$RPM_BUILD_ROOT
121
122 SAVED_PWD=$PWD
123 cd $RPM_BUILD_ROOT%{_libdir}
124 ln -s libfife.so.0.?.? libfife.so.0
125 ln -s libfife.so.0.?.? libfife.so
126 cd $SAVED_PWD
127
128 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
129 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
130 %py_postclean
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS CHANGES README
141 %attr(755,root,root) %{_libdir}/libfife.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libfife.so.0
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/libfife.so
147 %{_includedir}/%{name}
148
149 %if %{with static_libs}
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libfife.a
153 %endif
154
155 %files -n python-%{name}
156 %defattr(644,root,root,755)
157 %dir %{py_sitedir}/%{name}
158 %attr(755,root,root) %{py_sitedir}/%{name}/_fife.so
159 %{py_sitedir}/%{name}/*.py[co]
160 %{py_sitedir}/%{name}/extensions
This page took 0.041456 seconds and 4 git commands to generate.