]> git.pld-linux.org Git - packages/ffmpegthumbnailer.git/blob - ffmpegthumbnailer.spec
- add updates from upstream repository, rel 2
[packages/ffmpegthumbnailer.git] / ffmpegthumbnailer.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Lightweight video thumbnailer
6 Summary(pl.UTF-8):      Lekki program do wykonywania miniaturek dla filmów
7 Name:           ffmpegthumbnailer
8 Version:        2.2.2
9 Release:        2
10 License:        GPL v2
11 Group:          Applications/Graphics
12 #Source0Download: https://github.com/dirkvdb/ffmpegthumbnailer/releases
13 Source0:        https://github.com/dirkvdb/ffmpegthumbnailer/releases/download/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  ef466e64df666ba006c0b071eb48018e
15 Patch0:         %{name}-pc.patch
16 Patch1:         git.patch
17 URL:            https://github.com/dirkvdb/ffmpegthumbnailer
18 BuildRequires:  cmake >= 3.5
19 # libavcodec >= 52.26.0 libavformat libavutil libswscale
20 BuildRequires:  ffmpeg-devel >= 0.6
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libpng-devel
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  pkgconfig
25 BuildRequires:  sed >= 4.0
26 # dlopens libglib-2.0.so.0 libgobject-2.0.so.0 libgio-2.0.so.0
27 Requires:       glib2 >= 2.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 ffmpegthumbnailer can be used by file managers to create thumbnails
32 for your video files. It uses ffmpeg to decode frames from the video
33 files.
34
35 %description -l pl.UTF-8
36 ffmpegthumbnailer może być używany przez zarządców plików do tworzenia
37 miniaturek dla plików filmów. Wykorzystuje ffmpeg do dekodowania
38 klatek.
39
40 %package devel
41 Summary:        Header files for libffmpegthumbnailer library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libffmpegthumbnailer
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       ffmpeg-devel
46 Requires:       libjpeg-devel
47 Requires:       libpng-devel
48
49 %description devel
50 Header files for libffmpegthumbnailer library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki libffmpegthumbnailer.
54
55 %package static
56 Summary:        Static libffmpegthumbnailer library
57 Summary(pl.UTF-8):      Statyczna biblioteka libffmpegthumbnailer
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static libffmpegthumbnailer library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka libffmpegthumbnailer.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70 %patch1 -p1
71
72 %build
73 mkdir build
74 cd build
75 %cmake .. \
76         -DENABLE_GIO=ON \
77         -DENABLE_TESTS=ON \
78         %{?with_static_libs:-DENABLE_STATIC=ON} \
79         -DENABLE_THUMBNAILER=ON
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} -C build install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS ChangeLog README TODO
98 %attr(755,root,root) %{_bindir}/ffmpegthumbnailer
99 %attr(755,root,root) %{_libdir}/libffmpegthumbnailer.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libffmpegthumbnailer.so.4
101 %{_datadir}/thumbnailers/ffmpegthumbnailer.thumbnailer
102 %{_mandir}/man1/ffmpegthumbnailer.1*
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libffmpegthumbnailer.so
107 %{_includedir}/libffmpegthumbnailer
108 %{_pkgconfigdir}/libffmpegthumbnailer.pc
109
110 %if %{with static_libs}
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libffmpegthumbnailer.a
114 %endif
This page took 0.108295 seconds and 4 git commands to generate.