]> git.pld-linux.org Git - packages/evolution-data-server.git/blob - evolution-data-server.spec
- added kerberos5 and ldap bconds
[packages/evolution-data-server.git] / evolution-data-server.spec
1 #
2 # todo:
3 # - system libical
4 #
5 %define         mver            1.2
6 %bcond_without  kerberos5       # build without kerberos5 support
7 %bcond_without  ldap            # build without ldap support
8
9 Summary:        Evolution data server
10 Summary(pl):    Serwer danych Evolution
11 Name:           evolution-data-server
12 Version:        1.2.1
13 Release:        2.1
14 License:        GPL
15 Group:          Libraries
16 Source0:        http://ftp.gnome.org/pub/gnome/sources/evolution-data-server/1.2/%{name}-%{version}.tar.bz2
17 # Source0-md5:  c86cc41c1563f552015aebb563018936
18 Patch0:         %{name}-system_db.patch
19 Patch1:         %{name}-GG-IM.patch
20 Patch2:         %{name}-workaround-cal-backend-leak.patch
21 Patch3:         %{name}-bonobo.patch
22 URL:            http://www.ximian.com/products/ximian_evolution/
23 BuildRequires:  ORBit2-devel >= 1:2.12.1
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 BuildRequires:  db-devel
27 BuildRequires:  gnome-common >= 2.8.0
28 BuildRequires:  howl-devel >= 0.9.10
29 BuildRequires:  intltool
30 BuildRequires:  libglade2-devel >= 1:2.5.0
31 BuildRequires:  libgnomeui-devel >= 2.10.0
32 BuildRequires:  libsoup-devel >= 2.2.2
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtool
35 BuildRequires:  nspr-devel
36 Buildrequires:  nss-devel
37 BuildRequires:  pkgconfig
38 %{?with_kerberos5:BuildRequires:        heimdal-devel}
39 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.0}
40 Requires(post,postun):  /sbin/ldconfig
41 Requires(post,postun):  /usr/bin/scrollkeeper-update
42 Requires(post):         GConf2
43 Requires:       libsoup >= 2.2.2
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 The Evolution data server for the calendar and addressbook.
48
49 %description -l pl
50 Serwer danych Evolution dla kalendarza i ksi±¿ki adresowej.
51
52 %package devel
53 Summary:        Evolution data server development files
54 Summary(pl):    Pliki programistyczne serwera danych evolution
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 # for all but libegroupwise
58 Requires:       GConf2-devel >= 2.10.0
59 Requires:       ORBit2-devel >= 1:2.12.1
60 Requires:       glib2-devel >= 1:2.6.2
61 Requires:       libbonobo-devel >= 2.8.1
62 Requires:       libgnome-devel >= 2.10.0
63 Requires:       libxml2-devel
64 # for libegroupwise
65 Requires:       libsoup-devel >= 2.2.2
66
67 %description devel
68 This package contains the files necessary to develop applications
69 using Evolution's data server libraries.
70
71 %description devel -l pl
72 Ten pakiet zawiera pliki potrzebne do tworzenia aplikacji
73 korzystaj±cych z bibliotek serwera danych Evolution.
74
75 %package static
76 Summary:        Evolution data server static libraries
77 Summary(pl):    Statyczne biblioteki serwera danych Evolution
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Evolution data server static libraries.
83
84 %description static -l pl
85 Statyczne biblioteki serwera danych Evolution.
86
87 %prep
88 %setup -q 
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92 %patch3 -p1
93
94 rm -rf libdb
95
96 %build
97 glib-gettextize --copy --force
98 intltoolize --copy --force
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoheader}
102 %{__autoconf}
103 %{__automake}
104
105 cd calendar/libical
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoheader}
109 %{__autoconf}
110 %{__automake}
111 cd ../..
112
113 %configure \
114         %{?with_kerberos5:--with-krb5=%{_prefix}} \
115         %{!?with_kerberos5:--with-krb5=no} \
116         %{?with_ldap:--with-openldap=yes} \
117         %{!?with_ldap:--with-openldap=no} \
118         --enable-gtk-doc \
119         --enable-static \
120         --with-nspr-includes=%{_includedir}/nspr \
121         --with-nspr-libs=%{_libdir} \
122         --with-nss-includes=%{_includedir}/nss \
123         --with-nss-libs=%{_libdir}
124 %{__make} \
125         HTML_DIR=%{_gtkdocdir} \
126         GTKHTML_DATADIR=%{_datadir}/idl 
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT \
133         GTKHTML_DATADIR=%{_datadir}/idl \
134         HTML_DIR=%{_gtkdocdir} \
135         pkgconfigdir=%{_pkgconfigdir}
136
137 rm $RPM_BUILD_ROOT%{_libdir}/%{name}-%{mver}/{camel-providers,extensions}/*.{,l}a
138
139 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
140
141 %find_lang %{name} --all-name
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post
147 /sbin/ldconfig
148 /usr/bin/scrollkeeper-update
149 %gconf_schema_install
150
151 %postun
152 /sbin/ldconfig
153 /usr/bin/scrollkeeper-update
154
155 %files -f %{name}.lang
156 %defattr(644,root,root,755)
157 %doc AUTHORS ChangeLog NEWS* README
158 %attr(755,root,root) %{_libdir}/camel-index-control-%{mver}
159 %attr(755,root,root) %{_libdir}/camel-lock-helper-%{mver}
160 %attr(755,root,root) %{_libdir}/*.so.*.*
161 %dir %{_libdir}/%{name}-%{mver}
162 %attr(755,root,root) %{_libdir}/%{name}-%{mver}/%{name}
163 %dir %{_libdir}/%{name}-%{mver}/camel-providers
164 %attr(755,root,root) %{_libdir}/%{name}-%{mver}/camel-providers/*.so
165 %{_libdir}/%{name}-%{mver}/camel-providers/*.urls
166 %dir %{_libdir}/%{name}-%{mver}/extensions
167 %attr(755,root,root) %{_libdir}/%{name}-%{mver}/extensions/*.so
168 %{_libdir}/bonobo/servers/*
169 %{_datadir}/idl/*
170 %dir %{_datadir}/%{name}-%{mver}
171 %{_datadir}/%{name}-%{mver}/glade
172 %{_datadir}/%{name}-%{mver}/weather
173 %{_datadir}/%{name}-%{mver}/zoneinfo
174 %{_datadir}/%{name}-%{mver}/*.schema
175 %{_pixmapsdir}/%{name}-%{mver}
176
177 %files devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/*.so
180 %{_libdir}/*.la
181 %{_includedir}/*
182 %{_pkgconfigdir}/*
183 %{_gtkdocdir}/*
184
185 %files static
186 %defattr(644,root,root,755)
187 %{_libdir}/*.a
This page took 0.062387 seconds and 4 git commands to generate.