]> git.pld-linux.org Git - packages/evolution-data-server.git/blob - evolution-data-server.spec
- unified
[packages/evolution-data-server.git] / evolution-data-server.spec
1 #
2 # todo:
3 # - system libical
4 #
5 # Conditional build:
6 %bcond_without  kerberos5       # build without kerberos5 support
7 %bcond_without  ldap            # build without ldap support
8 #
9 %define         mver            1.2
10 Summary:        Evolution data server
11 Summary(pl):    Serwer danych Evolution
12 Name:           evolution-data-server
13 Version:        1.2.1
14 Release:        2.1
15 License:        GPL
16 Group:          Libraries
17 Source0:        http://ftp.gnome.org/pub/gnome/sources/evolution-data-server/1.2/%{name}-%{version}.tar.bz2
18 # Source0-md5:  c86cc41c1563f552015aebb563018936
19 Patch0:         %{name}-system_db.patch
20 Patch1:         %{name}-GG-IM.patch
21 Patch2:         %{name}-workaround-cal-backend-leak.patch
22 Patch3:         %{name}-bonobo.patch
23 URL:            http://www.ximian.com/products/ximian_evolution/
24 BuildRequires:  ORBit2-devel >= 1:2.12.1
25 BuildRequires:  autoconf >= 2.52
26 BuildRequires:  automake
27 BuildRequires:  db-devel
28 BuildRequires:  gnome-common >= 2.8.0
29 BuildRequires:  howl-devel >= 0.9.10
30 BuildRequires:  intltool
31 BuildRequires:  libglade2-devel >= 1:2.5.0
32 BuildRequires:  libgnomeui-devel >= 2.10.0
33 BuildRequires:  libsoup-devel >= 2.2.2
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  libtool
36 BuildRequires:  nspr-devel
37 Buildrequires:  nss-devel
38 BuildRequires:  pkgconfig
39 %{?with_kerberos5:BuildRequires:        heimdal-devel}
40 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.0}
41 Requires(post,postun):  /sbin/ldconfig
42 Requires(post,postun):  /usr/bin/scrollkeeper-update
43 Requires(post):         GConf2
44 Requires:       libsoup >= 2.2.2
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 The Evolution data server for the calendar and addressbook.
49
50 %description -l pl
51 Serwer danych Evolution dla kalendarza i ksi±¿ki adresowej.
52
53 %package devel
54 Summary:        Evolution data server development files
55 Summary(pl):    Pliki programistyczne serwera danych evolution
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 # for all but libegroupwise
59 Requires:       GConf2-devel >= 2.10.0
60 Requires:       ORBit2-devel >= 1:2.12.1
61 Requires:       glib2-devel >= 1:2.6.2
62 Requires:       libbonobo-devel >= 2.8.1
63 Requires:       libgnome-devel >= 2.10.0
64 Requires:       libxml2-devel
65 # for libegroupwise
66 Requires:       libsoup-devel >= 2.2.2
67
68 %description devel
69 This package contains the files necessary to develop applications
70 using Evolution's data server libraries.
71
72 %description devel -l pl
73 Ten pakiet zawiera pliki potrzebne do tworzenia aplikacji
74 korzystaj±cych z bibliotek serwera danych Evolution.
75
76 %package static
77 Summary:        Evolution data server static libraries
78 Summary(pl):    Statyczne biblioteki serwera danych Evolution
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Evolution data server static libraries.
84
85 %description static -l pl
86 Statyczne biblioteki serwera danych Evolution.
87
88 %prep
89 %setup -q 
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93 %patch3 -p1
94
95 rm -rf libdb
96
97 %build
98 glib-gettextize --copy --force
99 intltoolize --copy --force
100 %{__libtoolize}
101 %{__aclocal}
102 %{__autoheader}
103 %{__autoconf}
104 %{__automake}
105
106 cd calendar/libical
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoheader}
110 %{__autoconf}
111 %{__automake}
112 cd ../..
113
114 %configure \
115         %{?with_kerberos5:--with-krb5=%{_prefix}} \
116         %{!?with_kerberos5:--with-krb5=no} \
117         %{?with_ldap:--with-openldap=yes} \
118         %{!?with_ldap:--with-openldap=no} \
119         --enable-gtk-doc \
120         --enable-static \
121         --with-nspr-includes=%{_includedir}/nspr \
122         --with-nspr-libs=%{_libdir} \
123         --with-nss-includes=%{_includedir}/nss \
124         --with-nss-libs=%{_libdir}
125 %{__make} \
126         HTML_DIR=%{_gtkdocdir} \
127         GTKHTML_DATADIR=%{_datadir}/idl 
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT \
134         GTKHTML_DATADIR=%{_datadir}/idl \
135         HTML_DIR=%{_gtkdocdir} \
136         pkgconfigdir=%{_pkgconfigdir}
137
138 rm $RPM_BUILD_ROOT%{_libdir}/%{name}-%{mver}/{camel-providers,extensions}/*.{la,a}
139
140 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
141
142 %find_lang %{name} --all-name
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 /sbin/ldconfig
149 /usr/bin/scrollkeeper-update
150 %gconf_schema_install
151
152 %postun
153 /sbin/ldconfig
154 /usr/bin/scrollkeeper-update
155
156 %files -f %{name}.lang
157 %defattr(644,root,root,755)
158 %doc AUTHORS ChangeLog NEWS* README
159 %attr(755,root,root) %{_libdir}/camel-index-control-%{mver}
160 %attr(755,root,root) %{_libdir}/camel-lock-helper-%{mver}
161 %attr(755,root,root) %{_libdir}/*.so.*.*
162 %dir %{_libdir}/%{name}-%{mver}
163 %attr(755,root,root) %{_libdir}/%{name}-%{mver}/%{name}
164 %dir %{_libdir}/%{name}-%{mver}/camel-providers
165 %attr(755,root,root) %{_libdir}/%{name}-%{mver}/camel-providers/*.so
166 %{_libdir}/%{name}-%{mver}/camel-providers/*.urls
167 %dir %{_libdir}/%{name}-%{mver}/extensions
168 %attr(755,root,root) %{_libdir}/%{name}-%{mver}/extensions/*.so
169 %{_libdir}/bonobo/servers/*
170 %{_datadir}/idl/*
171 %dir %{_datadir}/%{name}-%{mver}
172 %{_datadir}/%{name}-%{mver}/glade
173 %{_datadir}/%{name}-%{mver}/weather
174 %{_datadir}/%{name}-%{mver}/zoneinfo
175 %{_datadir}/%{name}-%{mver}/*.schema
176 %{_pixmapsdir}/%{name}-%{mver}
177
178 %files devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/*.so
181 %{_libdir}/*.la
182 %{_includedir}/*
183 %{_pkgconfigdir}/*
184 %{_gtkdocdir}/*
185
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/*.a
This page took 0.036791 seconds and 3 git commands to generate.