]> git.pld-linux.org Git - packages/evolution-data-server.git/blame_incremental - evolution-data-server.spec
- build evolution data server with system db
[packages/evolution-data-server.git] / evolution-data-server.spec
... / ...
CommitLineData
1
2#
3# todo:
4# - system libical
5#
6
7%define mver 1.0
8
9Summary: Evolution data server
10Name: evolution-data-server
11Version: 0.0.3
12Release: 0.10
13License: GPL
14Group: Libraries
15Source0: http://ftp.gnome.org/pub/gnome/sources/%{name}/0.0/%{name}-%{version}.tar.gz
16# Source0-md5: bcacfd623db973a100deb67f0b7d8a38
17Patch0: %{name}-system_db.patch
18URL: http://www.ximian.com/products/ximian_evolution/
19BuildRequires: libsoup-devel >= 2.1.2
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21Requires(post,postun): /sbin/ldconfig
22Requires(post,postun): /usr/bin/scrollkeeper-update
23Requires(post): GConf2
24
25%description
26Evolution data server.
27
28%package devel
29Summary: Evolution data server development files
30Group: Development/Libraries
31Requires: %{name} >= %{version}
32
33%description devel
34This package contains the files necessary to develop applications
35using Evolution's data server libraries.
36
37%package static
38Summary: Evolution data server static libraries
39Group: Development/Libraries
40Requires: %{name}-devel >= %{version}
41
42%description static
43Evolution data server static libraries.
44
45%prep
46%setup -q
47%patch0 -p1
48rm -rf libdb/
49
50%build
51glib-gettextize --copy --force
52intltoolize --copy --force
53%{__libtoolize}
54%{__aclocal} -I %{_aclocaldir}/gnome2-macros
55%{__autoheader}
56%{__autoconf}
57%{__automake}
58%configure \
59 --enable-gtk-doc \
60 --enable-static \
61 --with-openldap=yes
62
63%{__make} \
64 HTML_DIR=%{_gtkdocdir} \
65 GTKHTML_DATADIR=%{_datadir}/idl
66
67%install
68rm -rf $RPM_BUILD_ROOT
69
70%{__make} install \
71 DESTDIR=$RPM_BUILD_ROOT \
72 GTKHTML_DATADIR=%{_datadir}/idl \
73 HTML_DIR=%{_gtkdocdir} \
74 pkgconfigdir=%{_pkgconfigdir}
75
76%find_lang %{name} --all-name
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post
82/sbin/ldconfig
83/usr/bin/scrollkeeper-update
84%gconf_schema_install
85
86%postun
87/sbin/ldconfig
88/usr/bin/scrollkeeper-update
89
90%files -f %{name}.lang
91%defattr(644,root,root,755)
92%doc AUTHORS ChangeLog NEWS* README
93%attr(755,root,root) %{_libdir}/%{name}-1.0
94%attr(755,root,root) %{_libdir}/*.so.*.*
95%{_libdir}/bonobo/servers/*
96%{_datadir}/idl/*
97%dir %{_datadir}/%{name}-%{mver}
98%{_datadir}/%{name}-%{mver}/zoneinfo
99%{_datadir}/%{name}-%{mver}/*.schema
100
101%files devel
102%defattr(644,root,root,755)
103%attr(755,root,root) %{_libdir}/*.so
104%{_libdir}/*.la
105%{_includedir}/*
106%{_pkgconfigdir}/*
107%{_gtkdocdir}/*
108
109%files static
110%defattr(644,root,root,755)
111%{_libdir}/*.a
This page took 0.027527 seconds and 4 git commands to generate.