- added kerberos5 and ldap bconds
[packages/evolution-data-server.git] / evolution-data-server.spec
CommitLineData
8a5a422a 1#
2# todo:
b7c830de 3# - system libical
b7c830de 4#
94fa296c 5%define mver 1.2
51160b41 6%bcond_without kerberos5 # build without kerberos5 support
7%bcond_without ldap # build without ldap support
46c4d742 8
11b4e6b5 9Summary: Evolution data server
353eadf1 10Summary(pl): Serwer danych Evolution
11b4e6b5 11Name: evolution-data-server
c4d408b6 12Version: 1.2.1
51160b41 13Release: 2.1
11b4e6b5 14License: GPL
15Group: Libraries
94fa296c 16Source0: http://ftp.gnome.org/pub/gnome/sources/evolution-data-server/1.2/%{name}-%{version}.tar.bz2
c4d408b6 17# Source0-md5: c86cc41c1563f552015aebb563018936
8a5a422a 18Patch0: %{name}-system_db.patch
26a0d0ba 19Patch1: %{name}-GG-IM.patch
966c73dd 20Patch2: %{name}-workaround-cal-backend-leak.patch
94fa296c 21Patch3: %{name}-bonobo.patch
46c4d742 22URL: http://www.ximian.com/products/ximian_evolution/
94fa296c 23BuildRequires: ORBit2-devel >= 1:2.12.1
353eadf1
JB
24BuildRequires: autoconf >= 2.52
25BuildRequires: automake
26BuildRequires: db-devel
9179bf1f 27BuildRequires: gnome-common >= 2.8.0
729ae61a 28BuildRequires: howl-devel >= 0.9.10
353eadf1 29BuildRequires: intltool
94fa296c 30BuildRequires: libglade2-devel >= 1:2.5.0
31BuildRequires: libgnomeui-devel >= 2.10.0
e2c48f95 32BuildRequires: libsoup-devel >= 2.2.2
33BuildRequires: libstdc++-devel
353eadf1 34BuildRequires: libtool
94fa296c 35BuildRequires: nspr-devel
36Buildrequires: nss-devel
353eadf1 37BuildRequires: pkgconfig
51160b41 38%{?with_kerberos5:BuildRequires: heimdal-devel}
39%{?with_ldap:BuildRequires: openldap-devel >= 2.0.0}
46c4d742 40Requires(post,postun): /sbin/ldconfig
41Requires(post,postun): /usr/bin/scrollkeeper-update
42Requires(post): GConf2
e2c48f95 43Requires: libsoup >= 2.2.2
353eadf1 44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11b4e6b5 45
46%description
353eadf1
JB
47The Evolution data server for the calendar and addressbook.
48
49%description -l pl
50