]> git.pld-linux.org Git - packages/erlang-sd_notify.git/blob - erlang-sd_notify.spec
- fix linking for systemd 232
[packages/erlang-sd_notify.git] / erlang-sd_notify.spec
1
2 %bcond_without  tests           # build without tests
3
4 Summary:        Erlang bindings for systemd-notify subsystem
5 Name:           erlang-sd_notify
6 Version:        0.1
7 Release:        3
8 License:        MIT
9 Group:          Development/Languages
10 Source0:        https://github.com/lemenkov/erlang-sd_notify/tarball/%{version}/%{name}-%{version}.tar.bz2
11 # Source0-md5:  c271c733a9ff626932961ba69fe6b0c6
12 URL:            https://support.process-one.net/doc/display/EXMPP/exmpp+home
13 BuildRequires:  erlang-rebar
14 BuildRequires:  systemd-devel
15 Requires:       erlang
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Erlang bindings for systemd-notify subsystem.
20
21 %prep
22 %setup -qc
23 mv lemenkov-erlang-sd_notify-*/* .
24 %{__rm} -r lemenkov-erlang-sd_notify-*
25
26 %build
27 %{__make} \
28         CFLAGS="%{rpmcflags}" \
29         LDFLAGS="%{rpmldflags} -lsystemd" \
30         REBAR=%{_bindir}/rebar \
31         REBAR_FLAGS="-v"
32
33 %if %{with tests}
34 %{__make} test
35 %endif
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_libdir}/erlang/lib/sd_notify-%{version}/{priv,ebin}
40 cp -p ebin/* $RPM_BUILD_ROOT%{_libdir}/erlang/lib/sd_notify-%{version}/ebin
41 cp -p priv/* $RPM_BUILD_ROOT%{_libdir}/erlang/lib/sd_notify-%{version}/priv
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %dir %{_libdir}/erlang/lib/sd_notify-%{version}
49 %dir %{_libdir}/erlang/lib/sd_notify-%{version}/ebin
50 %{_libdir}/erlang/lib/sd_notify-%{version}/ebin/sd_notify.app
51 %{_libdir}/erlang/lib/sd_notify-%{version}/ebin/sd_notify.beam
52 %dir %{_libdir}/erlang/lib/sd_notify-%{version}/priv
53 %attr(755,root,root) %{_libdir}/erlang/lib/sd_notify-%{version}/priv/sd_notify_drv.so
This page took 0.070987 seconds and 4 git commands to generate.