]> git.pld-linux.org Git - packages/eclipse-plugin-cdt.git/blobdiff - eclipse-plugin-cdt.spec
- updated to 2.1.0.
[packages/eclipse-plugin-cdt.git] / eclipse-plugin-cdt.spec
index ebfeb95d49a4b4e60730df090fdd5826cf4dfcbb..e5e910b889cde9075d1c43f1854107d3eeb8932b 100644 (file)
@@ -1,42 +1,51 @@
 Summary:       CDT - a set of plugins for Eclipse that implement a C/C++ IDE
+Summary(pl):   CDT - zestaw wtyczek do ¶rodowiska Eclipse implementuj±cy IDE C/C++
 Name:          eclipse-plugin-cdt
-%define                _ver_major      2.0
+%define                _ver_major      2.1
 %define                _ver_minor      0
-Version:       %{_ver_major}
-Release:       0.1
-License:       CPL
+Version:       %{_ver_major}.%{_ver_minor}
+Release:       1
+License:       CPL v1.0
 Group:         Development/Languages
-Source0:       http://download.eclipse.org/tools/cdt/releases/new/zips/org.eclipse.cdt-%{version}-linux.gtk.x86.zip
-# Source0-md5: 15fbefa22a0baf1e9ed4139ce219ade4
+%define                _eclipse_arch   %(echo %{_target_cpu} | sed 's/i.86/x86/;s/athlon/x86/;s/pentium./x86/')
+Source0:       http://download.eclipse.org/tools/cdt/releases/new/zips/%{version}/org.eclipse.cdt-%{version}-linux.%{_eclipse_arch}.zip
+# Source0-md5: 1542dee90e6c4451d51a8135f2860f41
 URL:           http://www.eclipse.org/cdt/
+BuildRequires: unzip
 Requires:      eclipse >= 3.0
-ExclusiveArch: %{ix86} ppc
+ExclusiveArch: %{ix86} ppc ia64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _eclipsedir  %{_datadir}/eclipse
+%define                _eclipsedir     %{_libdir}/eclipse
 
 %description
-The CDT project provides a set of plugins that implement a C/C++ IDE.
-It adds a C/C++ Perspective to the Eclipse Workbench that supports
-C/C++ development with a number of views, wizards, a powerful editor,
-and a debugger.
+The CDT project adds a C/C++ Perspective to the Eclipse Workbench that
+supports C/C++ development with a number of views, wizards, a powerful
+editor, and a debugger.
+
+%description -l pl
+Projekt CDT rozszerza zintegrowane ¶rodowisko programistyczne Eclipse
+o nowe elementy wspomagaj±ce tworzenie aplikacji w jêzykach C i C++.
 
 %prep
 %setup -q -c
 
 %build
-%ifarch %{ix86}
+%ifnarch %{ix86}
+rm -r eclipse/plugins/org.eclipse.cdt.core.linux_%{_ver_major}.%{_ver_minor}/os/linux/x86
+%endif
+%ifnarch ppc
 rm -r eclipse/plugins/org.eclipse.cdt.core.linux_%{_ver_major}.%{_ver_minor}/os/linux/ppc
 %endif
-%ifarch ppc
-rm -r eclipse/plugins/org.eclipse.cdt.core.linux_%{_ver_major}.%{_ver_minor}/os/linux/x86
+%ifnarch ia64
+rm -r eclipse/plugins/org.eclipse.cdt.core.linux_%{_ver_major}.%{_ver_minor}/os/linux/ia64
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 install -d $RPM_BUILD_ROOT%{_eclipsedir}/{features,plugins}
-cp -r * $RPM_BUILD_ROOT%{_datadir}
+
+cp -r * $RPM_BUILD_ROOT%{_libdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -44,4 +53,26 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %{_eclipsedir}/features/*
-%{_eclipsedir}/plugins/*
+%dir %{_eclipsedir}/plugins
+%{_eclipsedir}/plugins/org.eclipse.cdt_*.*.*
+%{_eclipsedir}/plugins/org.eclipse.cdt.core_*.*.*
+
+%dir %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux_*.*.*
+%dir %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux_*.*.*/os
+%dir %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux_*.*.*/os/linux
+%dir %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux_*.*.*/os/linux/%{_eclipse_arch}
+%attr(755,root,root) %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux_*.*.*/os/linux/%{_eclipse_arch}/*.so
+%{_eclipsedir}/plugins/org.eclipse.cdt.core.linux_*.*.*/*.jar
+%{_eclipsedir}/plugins/org.eclipse.cdt.core.linux_*.*.*/*.xml
+
+%{_eclipsedir}/plugins/org.eclipse.cdt.debug.core_*.*.*
+%{_eclipsedir}/plugins/org.eclipse.cdt.debug.mi.core_*.*.*
+%{_eclipsedir}/plugins/org.eclipse.cdt.debug.mi.ui_*.*.*
+%{_eclipsedir}/plugins/org.eclipse.cdt.debug.ui_*.*.*
+%{_eclipsedir}/plugins/org.eclipse.cdt.doc.user_*.*.*
+%{_eclipsedir}/plugins/org.eclipse.cdt.launch_*.*.*
+%{_eclipsedir}/plugins/org.eclipse.cdt.make.core_*.*.*
+%{_eclipsedir}/plugins/org.eclipse.cdt.make.ui_*.*.*
+%{_eclipsedir}/plugins/org.eclipse.cdt.managedbuilder.core_*.*.*
+%{_eclipsedir}/plugins/org.eclipse.cdt.managedbuilder.ui_*.*.*
+%{_eclipsedir}/plugins/org.eclipse.cdt.ui_*.*.*
This page took 0.068646 seconds and 4 git commands to generate.