]> git.pld-linux.org Git - packages/eclipse-plugin-cdt.git/blob - eclipse-plugin-cdt.spec
- rel 1
[packages/eclipse-plugin-cdt.git] / eclipse-plugin-cdt.spec
1 #
2 # Conditional build:
3 %bcond_without  incall  # don't include all tarballs in .src.rpm
4 #
5 %define         plugin_name     cdt
6 %define         need_x86        0
7 %define         need_ppc        0
8 %define         need_ia64       0
9 %define         need_x8664      0
10
11 %if %{with incall}
12 %define         need_x86        1
13 %define         need_ppc        1
14 %define         need_ia64       1
15 %define         need_x8664      1
16 %else
17 %ifarch %{ix86}
18 %define         need_x86        1
19 %endif
20 %ifarch ppc
21 %define         need_ppc        1
22 %endif
23 %ifarch ia64
24 %define         need_ia64       1
25 %endif
26 %ifarch %{x8664}
27 %define         need_x8664      1
28 %endif
29 %endif
30
31 Summary:        CDT - a set of plugins for Eclipse that implement a C/C++ IDE
32 Summary(pl.UTF-8):      CDT - zestaw wtyczek do środowiska Eclipse implementujący IDE C/C++
33 Name:           eclipse-plugin-%{plugin_name}
34 %define         _ver_major      7.0
35 %define         _ver_minor      1
36 Version:        %{_ver_major}.%{_ver_minor}
37 Release:        1
38 License:        CPL v1.0
39 Group:          Development/Languages
40 Source0:        http://download.eclipse.org/tools/cdt/releases/helios/dist/cdt-master-%{version}.zip
41 # Source0-md5:  c84f16f67b197b4ea8e8a62a9e1d6cea
42 URL:            http://www.eclipse.org/cdt/
43 BuildRequires:  unzip
44 Requires:       eclipse >= 3.6
45 ExclusiveArch:  %{ix86} %{x8664} ia64 ppc
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _plugindir      %{_libdir}/eclipse/dropins/%{plugin_name}
49
50 %description
51 The CDT project adds a C/C++ Perspective to the Eclipse Workbench that
52 supports C/C++ development with a number of views, wizards, a powerful
53 editor, and a debugger.
54
55 %description -l pl.UTF-8
56 Projekt CDT rozszerza zintegrowane środowisko programistyczne Eclipse
57 o nowe elementy wspomagające tworzenie aplikacji w językach C i C++.
58
59 %prep
60 %setup -q -c
61
62 %build
63 rm -rf plugins/org.eclipse.cdt.*aix*_%{_ver_major}.*
64 rm -rf plugins/org.eclipse.cdt.*macosx*_%{_ver_major}.*
65 rm -rf plugins/org.eclipse.cdt.*qnx*_%{_ver_major}.*
66 rm -rf plugins/org.eclipse.cdt.*solaris*_%{_ver_major}.*
67 rm -rf plugins/org.eclipse.cdt.*win32*_%{_ver_major}.*
68 %ifnarch %{ix86}
69 rm -rf plugins/org.eclipse.cdt.*.x86_%{_ver_major}.*
70 %endif
71 %ifnarch ppc
72 rm -rf plugins/org.eclipse.cdt.*.ppc_%{_ver_major}.*
73 %endif
74 %ifnarch ia64
75 rm -rf plugins/org.eclipse.cdt.*.ia64_%{_ver_major}.*
76 %endif
77 %ifnarch %{x8664}
78 rm -rf plugins/org.eclipse.cdt.*.x86_64_%{_ver_major}.*
79 %endif
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT%{_plugindir}/{features,plugins}
84
85 cp -r * $RPM_BUILD_ROOT%{_plugindir}
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %dir %{_plugindir}
93 %dir %{_plugindir}/features
94 %dir %{_plugindir}/plugins
95 %{_plugindir}/features/*.jar
96 %{_plugindir}/plugins/net.sourceforge.lpg*.jar
97 %{_plugindir}/plugins/org.eclipse.ant.*.jar
98 %{_plugindir}/plugins/org.eclipse.cdt*.jar
99 %{_plugindir}/plugins/org.eclipse.test*.jar
100 %{_plugindir}/plugins/org.eclipse.tm.tcf*.jar
This page took 0.077423 seconds and 4 git commands to generate.