]> git.pld-linux.org Git - packages/eclipse-plugin-cdt.git/blob - eclipse-plugin-cdt.spec
f747d800b6623ff81f726bc154bcf8cbbc575b5f
[packages/eclipse-plugin-cdt.git] / eclipse-plugin-cdt.spec
1 #
2 # Conditional build:
3 %bcond_without  incall  # don't include all tarballs in .src.rpm
4 #
5 %define         need_x86        0
6 %define         need_ppc        0
7 %define         need_ia64       0
8 %define         need_x8664      0
9
10 %if %{with incall}
11 %define         need_x86        1
12 %define         need_ppc        1
13 %define         need_x64        1
14 %define         need_x8664      1
15 %else
16 %ifarch %{ix86}
17 %define         need_x86        1
18 %endif
19 %ifarch ppc
20 %define         need_ppc        1
21 %endif
22 %ifarch ia64
23 %define         need_ia64       1
24 %endif
25 %ifarch %{x8664}
26 %define         need_x8664      1
27 %endif
28 %endif
29
30 %define         _rc     RC1
31 Summary:        CDT - a set of plugins for Eclipse that implement a C/C++ IDE
32 Summary(pl):    CDT - zestaw wtyczek do ¶rodowiska Eclipse implementuj±cy IDE C/C++
33 Name:           eclipse-plugin-cdt
34 %define         _ver_major      3.0
35 %define         _ver_minor      0
36 Version:        %{_ver_major}.%{_ver_minor}
37 Release:        0.%{_rc}.1
38 License:        CPL v1.0
39 Group:          Development/Languages
40 %if %{need_x86}
41 Source0:        http://download.eclipse.org/tools/cdt/builds/%{version}/%{_rc}/org.eclipse.cdt-%{version}-%{_rc}-linux.x86.tar.gz
42 # Source0-md5:  454b6e0279c83fd209d6ac839a459134
43 %endif
44 %if %{need_ppc}
45 Source1:        http://download.eclipse.org/tools/cdt/builds/%{version}/%{_rc}/org.eclipse.cdt-%{version}-%{_rc}-linux.ppc.tar.gz
46 # Source1-md5:  1e5e716bf6f0bfd56139c706d344142a
47 %endif
48 %if %{need_ia64}
49 Source2:        http://download.eclipse.org/tools/cdt/builds/%{version}/%{_rc}/org.eclipse.cdt-%{version}-%{_rc}-linux.ia64.tar.gz
50 # Source2-md5:  80ba477131beb0c0682019a7705b1cfe
51 %endif
52 %if %{need_x8664}
53 Source3:        http://download.eclipse.org/tools/cdt/builds/%{version}/%{_rc}/org.eclipse.cdt-%{version}-%{_rc}-linux.x86_64.tar.gz
54 # Source3-md5:  7d8e6c97e9a8055b0823292064f71dbd
55 %endif
56 URL:            http://www.eclipse.org/cdt/
57 BuildRequires:  unzip
58 Requires:       eclipse >= 3.0
59 ExclusiveArch:  %{ix86} %{x8664} ia64 ppc
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %define         _eclipse_arch   %(echo %{_target_cpu} | sed 's/i.86/x86/;s/athlon/x86/;s/pentium./x86/')
63 %define         _eclipsedir     %{_libdir}/eclipse
64
65 %description
66 The CDT project adds a C/C++ Perspective to the Eclipse Workbench that
67 supports C/C++ development with a number of views, wizards, a powerful
68 editor, and a debugger.
69
70 %description -l pl
71 Projekt CDT rozszerza zintegrowane ¶rodowisko programistyczne Eclipse
72 o nowe elementy wspomagaj±ce tworzenie aplikacji w jêzykach C i C++.
73
74 %prep
75 %ifarch %{ix86}
76 %setup -q -c -T -b0
77 %endif
78 %ifarch ppc
79 %setup -q -c -T -b1
80 %endif
81 %ifarch ia64
82 %setup -q -c -T -b2
83 %endif
84 %ifarch %{x8664}
85 %setup -q -c -T -b3
86 %endif
87
88 %build
89 %ifnarch %{ix86}
90 rm -rf eclipse/plugins/org.eclipse.cdt.core.linux_%{_ver_major}.%{_ver_minor}/os/linux/x86
91 %endif
92 %ifnarch ppc
93 rm -rf eclipse/plugins/org.eclipse.cdt.core.linux_%{_ver_major}.%{_ver_minor}/os/linux/ppc
94 %endif
95 %ifnarch ia64
96 rm -rf eclipse/plugins/org.eclipse.cdt.core.linux_%{_ver_major}.%{_ver_minor}/os/linux/ia64
97 %endif
98 %ifnarch %{x8664}
99 rm -rf eclipse/plugins/org.eclipse.cdt.core.linux_%{_ver_major}.%{_ver_minor}/os/linux/x86_64
100 %endif
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT%{_eclipsedir}/{features,plugins}
105
106 cp -r * $RPM_BUILD_ROOT%{_libdir}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %{_eclipsedir}/features/*
114 %dir %{_eclipsedir}/plugins
115 %{_eclipsedir}/plugins/org.eclipse.cdt_*.*.*
116 %{_eclipsedir}/plugins/org.eclipse.cdt.core_*.*.*
117
118 %dir %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux.%{_eclipse_arch}_*.*.*
119 %dir %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux.%{_eclipse_arch}_*.*.*/os
120 %dir %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux.%{_eclipse_arch}_*.*.*/os/linux
121 %dir %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux.%{_eclipse_arch}_*.*.*/os/linux/%{_eclipse_arch}
122 %attr(755,root,root) %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux.%{_eclipse_arch}_*.*.*/os/linux/%{_eclipse_arch}/*.so
123 %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux_*.*.*/*.jar
124 %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux_*.*.*/*.xml
125 %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux_*.*.*/*.html
126 %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux.%{_eclipse_arch}_*.*.*/*.xml
127 %{_eclipsedir}/plugins/org.eclipse.cdt.core.linux.%{_eclipse_arch}_*.*.*/*.html
128
129 %{_eclipsedir}/plugins/org.eclipse.cdt.debug.core_*.*.*
130 %{_eclipsedir}/plugins/org.eclipse.cdt.debug.mi.core_*.*.*
131 %{_eclipsedir}/plugins/org.eclipse.cdt.debug.mi.ui_*.*.*
132 %{_eclipsedir}/plugins/org.eclipse.cdt.debug.ui_*.*.*
133 %{_eclipsedir}/plugins/org.eclipse.cdt.doc.user_*.*.*
134 %{_eclipsedir}/plugins/org.eclipse.cdt.launch_*.*.*
135 %{_eclipsedir}/plugins/org.eclipse.cdt.make.core_*.*.*
136 %{_eclipsedir}/plugins/org.eclipse.cdt.make.ui_*.*.*
137 %{_eclipsedir}/plugins/org.eclipse.cdt.managedbuilder.core_*.*.*
138 %{_eclipsedir}/plugins/org.eclipse.cdt.managedbuilder.gnu.ui_*.*.*
139 %{_eclipsedir}/plugins/org.eclipse.cdt.managedbuilder.ui_*.*.*
140 %{_eclipsedir}/plugins/org.eclipse.cdt.refactoring_*.*.*
141 %{_eclipsedir}/plugins/org.eclipse.cdt.ui_*.*.*
This page took 0.052693 seconds and 2 git commands to generate.