]> git.pld-linux.org Git - packages/eclipse-plugin-cdt.git/blob - eclipse-plugin-cdt.spec
- up to 4.0.3
[packages/eclipse-plugin-cdt.git] / eclipse-plugin-cdt.spec
1 #
2 # Conditional build:
3 %bcond_without  incall  # don't include all tarballs in .src.rpm
4 #
5 %define         need_x86        0
6 %define         need_ppc        0
7 %define         need_ia64       0
8 %define         need_x8664      0
9
10 %if %{with incall}
11 %define         need_x86        1
12 %define         need_ppc        1
13 %define         need_ia64       1
14 %define         need_x8664      1
15 %else
16 %ifarch %{ix86}
17 %define         need_x86        1
18 %endif
19 %ifarch ppc
20 %define         need_ppc        1
21 %endif
22 %ifarch ia64
23 %define         need_ia64       1
24 %endif
25 %ifarch %{x8664}
26 %define         need_x8664      1
27 %endif
28 %endif
29
30 Summary:        CDT - a set of plugins for Eclipse that implement a C/C++ IDE
31 Summary(pl.UTF-8):      CDT - zestaw wtyczek do środowiska Eclipse implementujący IDE C/C++
32 Name:           eclipse-plugin-cdt
33 %define         _ver_major      4.0
34 %define         _ver_minor      3
35 Version:        %{_ver_major}.%{_ver_minor}
36 Release:        0.9
37 License:        CPL v1.0
38 Group:          Development/Languages
39 Source0:        http://download.eclipse.org/tools/cdt/releases/europa/dist/cdt-master-%{version}.zip
40 # Source0-md5:  ff4564cbcec07c234222dd8a779a6b3f
41 URL:            http://www.eclipse.org/cdt/
42 BuildRequires:  unzip
43 Requires:       eclipse >= 3.3
44 ExclusiveArch:  %{ix86} %{x8664} ia64 ppc
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _eclipse_arch   %(echo %{_target_cpu} | sed 's/i.86/x86/;s/athlon/x86/;s/pentium./x86/')
48 %define         _eclipsedir     %{_libdir}/eclipse
49
50 %description
51 The CDT project adds a C/C++ Perspective to the Eclipse Workbench that
52 supports C/C++ development with a number of views, wizards, a powerful
53 editor, and a debugger.
54
55 %description -l pl.UTF-8
56 Projekt CDT rozszerza zintegrowane środowisko programistyczne Eclipse
57 o nowe elementy wspomagające tworzenie aplikacji w językach C i C++.
58
59 %prep
60 %setup -q -c
61
62 %build
63 rm -rf plugins/org.eclipse.cdt.*aix*_%{_ver_major}.*
64 rm -rf plugins/org.eclipse.cdt.*macosx*_%{_ver_major}.*
65 rm -rf plugins/org.eclipse.cdt.*qnx*_%{_ver_major}.*
66 rm -rf plugins/org.eclipse.cdt.*solaris*_%{_ver_major}.*
67 rm -rf plugins/org.eclipse.cdt.*win32*_%{_ver_major}.*
68 %ifnarch %{ix86}
69 rm -rf plugins/org.eclipse.cdt.*.x86_%{_ver_major}.*
70 %endif
71 %ifnarch ppc
72 rm -rf plugins/org.eclipse.cdt.*.ppc_%{_ver_major}.*
73 %endif
74 %ifnarch ia64
75 rm -rf plugins/org.eclipse.cdt.*.ia64_%{_ver_major}.*
76 %endif
77 %ifnarch %{x8664}
78 rm -rf plugins/org.eclipse.cdt.*.x86_64_%{_ver_major}.*
79 %endif
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT%{_eclipsedir}/{features,plugins}
84
85 cp -r * $RPM_BUILD_ROOT%{_eclipsedir}
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %{_eclipsedir}/features/*.jar
93 %{_eclipsedir}/plugins/net.sourceforge.lpg*.jar
94 %{_eclipsedir}/plugins/org.eclipse.ant.*.jar
95 %{_eclipsedir}/plugins/org.eclipse.cdt*.jar
96 %{_eclipsedir}/plugins/org.eclipse.test*.jar
This page took 0.052981 seconds and 3 git commands to generate.