]> git.pld-linux.org Git - packages/eb.git/blob - eb.spec
- unconditional noarch subpackages
[packages/eb.git] / eb.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Library for accessing CD-ROM books
7 Summary(pl.UTF-8):      Biblioteka dostępu do książek na płytach CD-ROM
8 Name:           eb
9 Version:        4.4.3
10 Release:        5
11 License:        BSD
12 Group:          Libraries
13 Source0:        ftp://ftp.sra.co.jp/pub/misc/eb/%{name}-%{version}.tar.bz2
14 # Source0-md5:  17dd1fade7ba0b82ce6e60f19fcbc823
15 Patch0:         %{name}-link.patch
16 URL:            https://github.com/yasuhirokimura/eb
17 BuildRequires:  autoconf >= 2.54
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRequires:  zlib-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 EB Library supports to access CD-ROM books of EB, EBG, EBXA, EBXA-C,
25 S-EBXA and EPWING formats. CD-ROM books of those formats are popular
26 in Japan. Since CD-ROM books themseves are stands on the ISO 9660
27 format, you can mount the discs by the same way as other ISO 9660
28 discs.
29
30 %description -l pl.UTF-8
31 Biblioteka EB pozwala na dostęp do książek na płytach CD-ROM w
32 formatach EB, EBG, EBXA, EBXA-C, S-EBXA oraz EPWING. Książki w tych
33 formatach są popularne w Japonii. Ponieważ książki na płytach jako
34 takie są plikami zapisanymi w formacie ISO 9660, można montować takie
35 płyty w taki sam sposób, jak inne płyty ISO 9660.
36
37 %package utils
38 Summary:        Utilities provided by EB library
39 Summary(pl.UTF-8):      Narzędzia dostarczane przez bibliotekę EB
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description utils
44 Utilities provided by EB library.
45
46 %description utils -l pl.UTF-8
47 Narzędzia dostarczane przez bibliotekę EB.
48
49 %package devel
50 Summary:        Header files for EB library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki EB
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54
55 %description devel
56 Header files for EB library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki EB.
60
61 %package static
62 Summary:        Static EB library
63 Summary(pl.UTF-8):      Statyczna biblioteka EB
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static EB library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka EB.
72
73 %package apidocs
74 Summary:        EB API documentation
75 Summary(pl.UTF-8):      Dokumentacja API biblioteki EB
76 Group:          Documentation
77 BuildArch:      noarch
78
79 %description apidocs
80 API and internal documentation for EB library.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API biblioteki EB.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         --enable-samples \
97         --enable-pthread \
98         --enable-ebnet \
99         --enable-ipv6 \
100         --with-pkgdocdir=%{_docdir}/%{name}-apidocs-%{version} \
101         %{!?with_static_libs:--disable-static}
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %find_lang %{name}
111 %find_lang ebutils
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files -f %{name}.lang
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog* NEWS README
122 %attr(755,root,root) %{_libdir}/libeb.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libeb.so.16
124
125 %files utils -f ebutils.lang
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_bindir}/ebappendix
128 %attr(755,root,root) %{_bindir}/ebfont
129 %attr(755,root,root) %{_bindir}/ebinfo
130 %attr(755,root,root) %{_bindir}/ebrefile
131 %attr(755,root,root) %{_bindir}/ebstopcode
132 %attr(755,root,root) %{_bindir}/ebunzip
133 %attr(755,root,root) %{_bindir}/ebzip
134 %attr(755,root,root) %{_bindir}/ebzipinfo
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libeb.so
139 %{_libdir}/libeb.la
140 %{_includedir}/eb
141 %{_sysconfdir}/eb.conf
142 %{_aclocaldir}/eb4.m4
143
144 %if %{with static_libs}
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libeb.a
148 %endif
149
150 %if %{with apidocs}
151 %files apidocs
152 %defattr(644,root,root,755)
153 %doc %{_docdir}/%{name}-apidocs-%{version}
154 %endif
This page took 0.125882 seconds and 4 git commands to generate.