]> git.pld-linux.org Git - packages/dyncall.git/blob - dyncall.spec
- disable debugsource packages (not working with only static libs?)
[packages/dyncall.git] / dyncall.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # manual.pdf
4 #
5 Summary:        A Generic Dynamic FFI package
6 Summary(pl.UTF-8):      Ogólny pakiet do dynamicznych wywołań obcych funkcji (FFI)
7 Name:           dyncall
8 Version:        1.3
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 #Source0Download: https://dyncall.org/download
13 Source0:        https://dyncall.org/r%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  4f96a2f86aae116f84ee7db01b164d41
15 Patch0:         %{name}-libdir.patch
16 # https://dyncall.org/pub/dyncall/dyncall/raw-rev/1e65b8911603
17 Patch1:         %{name}-cmake.patch
18 URL:            https://dyncall.org/
19 BuildRequires:  cmake >= 2.6
20 BuildRequires:  rpm-build >= 4.6
21 %if %{with doc}
22 BuildRequires:  texlive-format-pdflatex
23 BuildRequires:  texlive-latex
24 # colortbl.sty
25 BuildRequires:  texlive-latex-extend
26 BuildRequires:  texlive-latex-moreverb
27 # for html
28 #BuildRequires: texlive-tex4ht
29 %endif
30 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 ia64 mips mips64 ppc ppc64 sh sparc sparcv9 sparc64
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _debugsource_packages   0
34
35 %description
36 dyncall is a low-level toolkit providing a portable abstraction for
37 handling native code dynamically at run time.
38
39 It comprises three independent components, available as C libraries,
40 namely:
41 - 'dyncall' for making function calls,
42 - 'dyncallback' for writing generic callback handlers, and
43 - 'dynload' for loading code.
44
45 %description -l pl.UTF-8
46 dyncall to zestaw niskopoziomowych narzędzi z przenośną abstrakcją
47 dynamicznej obsługi kodu natywnego w czasie uruchomienia.
48
49 Obejmuje trzy niezależne komponenty, dostępne jako biblioteki C:
50 - dyncall do wywołań funkcji
51 - dyncallback do pisania generycznej obsługi wywołań zwrotnych
52 - dynload do ładowania kodu
53
54 %package doc
55 Summary:        Documentation for dyncall libraries
56 Summary(pl.UTF-8):      Dokumentacja bibliotek dyncall
57 Group:          Documentation
58 BuildArch:      noarch
59
60 %description doc
61 Documentation for dyncall libraries.
62
63 %description doc -l pl.UTF-8
64 Dokumentacja bibliotek dyncall.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69 %patch1 -p1
70
71 %build
72 install -d build
73 cd build
74 %cmake ..
75
76 %{__make}
77 cd ..
78
79 %if %{with doc}
80 cd doc/manual
81 %{__make} -f Makefile.generic pdf
82
83 # TODO: html (but broken even with SHELL=/bin/bash)
84 %endif
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} -C build install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS BUGS ChangeLog LICENSE README ToDo
98 %{_libdir}/libdyncall_s.a
99 %{_libdir}/libdyncallback_s.a
100 %{_libdir}/libdynload_s.a
101 %{_includedir}/dyncall*.h
102 %{_includedir}/dynload.h
103
104 %if %{with doc}
105 %files doc
106 %defattr(644,root,root,755)
107 %doc doc/manual/manual.pdf
108 %endif
This page took 0.188818 seconds and 4 git commands to generate.