]> git.pld-linux.org Git - packages/dynamips.git/blob - dynamips.spec
- fix building on x32
[packages/dynamips.git] / dynamips.spec
1 %define         subver  RC2
2 %define         rel     4
3 Summary:        Cisco 7200 Simulator
4 Summary(pl.UTF-8):      Symulator Cisco 7200
5 Name:           dynamips
6 Version:        0.2.8
7 Release:        0.%{subver}.%{rel}
8 License:        GPL
9 Group:          Applications/Emulators
10 Source0:        http://www.ipflow.utc.fr/dynamips/%{name}-%{version}-%{subver}.tar.gz
11 # Source0-md5:  8d12d28684d164fe3312a3fe43c84d2e
12 Patch0:         %{name}-Makefile.patch
13 Patch1:         %{name}-debian.patch
14 Patch2:         x32.patch
15 URL:            http://www.ipflow.utc.fr/index.php/Cisco_7200_Simulator
16 BuildRequires:  elfutils-devel
17 BuildRequires:  flex
18 BuildRequires:  libpcap-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Cisco 7200 Simulator.
23
24 %description -l pl.UTF-8
25 Symulator Cisco 7200.
26
27 %prep
28 %setup -q -n %{name}-%{version}-%{subver}
29 %patch0 -p1
30 %patch1 -p1
31 %ifarch x32
32 %patch2 -p1
33 %endif
34
35 %build
36 %ifarch %{x8664}
37 ARCH=amd64
38 %else
39 %ifarch %{ix86} x32
40 ARCH=x86
41 %else
42 ARCH=nojit
43 %endif
44 %endif
45
46 %{__make} \
47         DYNAMIPS_ARCH=$ARCH \
48         CC="%{__cc}" \
49         RPM_CFLAGS="%{rpmcflags}" \
50         LD="%{__ld}"
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT \
56         PREFIX="%{_prefix}"
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README README.hypervisor ChangeLog TODO
64 %attr(755,root,root) %{_bindir}/*
65 %{_mandir}/man1/*.1*
66 %{_mandir}/man7/*.7*
This page took 0.061885 seconds and 4 git commands to generate.