]> git.pld-linux.org Git - packages/dumb.git/blob - dumb.spec
- release 6 (by relup.sh)
[packages/dumb.git] / dumb.spec
1 # TODO: don't build debug version of libraries when not packaging them
2 #
3 # Conditional build:
4 %bcond_without  allegro         # Allegro libraries
5 %bcond_without  debug_libs      # debug libraries packaging (they are built anyway)
6 #
7 Summary:        DUMB - Dynamic Universal Music Bibliotheque
8 Summary(pl.UTF-8):      DUMB - uniwersalna biblioteka do odtwarzania muzyki
9 Name:           dumb
10 Version:        0.9.3
11 Release:        6
12 License:        GPL-like
13 Group:          Development/Libraries
14 Source0:        http://downloads.sourceforge.net/dumb/%{name}-%{version}.tar.gz
15 # Source0-md5:  f48da5b990aa8aa822d3b6a951baf5c2
16 Patch0:         %{name}-shared.patch
17 URL:            http://dumb.sourceforge.net/
18 %{?with_allegro:BuildRequires:  allegro-devel}
19 BuildRequires:  libtool
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         specflags_ia32          -fomit-frame-pointer
23
24 %description
25 DUMB (Dynamic Universal Music Bibliotheque, formerly Dedicated
26 Universal Music Bastardisation) - IT, XM, S3M and MOD player library.
27
28 %description -l pl.UTF-8
29 DUMB (Dynamic Universal Music Bibliotheque, dawniej Dedicated
30 Universal Music Bastardisation) - biblioteka do odtwarzania muzyki w
31 formatach IT, XM, S3M i MOD.
32
33 %package devel
34 Summary:        Header files for DUMB library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki DUMB
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for DUMB library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki DUMB.
44
45 %package static
46 Summary:        Static DUMB libraries
47 Summary(pl.UTF-8):      Statyczne biblioteki DUMB
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static DUMB libraries.
53
54 %description static -l pl.UTF-8
55 Statyczne biblioteki DUMB.
56
57 %package allegro
58 Summary:        DUMB Allegro library
59 Summary(pl.UTF-8):      Biblioteka DUMB dla Allegro
60 Group:          Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description allegro
64 DUMB Allegro library.
65
66 %description allegro -l pl.UTF-8
67 Biblioteka DUMB dla Allegro.
68
69 %package allegro-devel
70 Summary:        Header files for DUMB Allegro library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki DUMB dla Allegro
72 Group:          Development/Libraries
73 Requires:       %{name}-allegro = %{version}-%{release}
74 Requires:       %{name}-devel = %{version}-%{release}
75 Requires:       allegro-devel
76
77 %description allegro-devel
78 Header files for DUMB Allegro library.
79
80 %description allegro-devel -l pl.UTF-8
81 Pliki nagłówkowe biblioteki DUMB dla Allegro.
82
83 %package allegro-static
84 Summary:        Static DUMB Allegro libraries
85 Summary(pl.UTF-8):      Statyczne biblioteki DUMB dla Allegro
86 Group:          Development/Libraries
87 Requires:       %{name}-allegro-devel = %{version}-%{release}
88
89 %description allegro-static
90 Static DUMB Allegro libraries.
91
92 %description allegro-static -l pl.UTF-8
93 Statyczne biblioteki DUMB dla Allegro.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 cat <<EOF > make/config.txt
101 include make/unix.inc
102 ALL_TARGETS := core core-examples core-headers
103 %if %{with allegro}
104 ALL_TARGETS += allegro allegro-examples allegro-headers
105 %endif
106 PREFIX := /usr
107 EOF
108
109 %{__make} -j1 all \
110         CC="%{__cc}" \
111         LDFLAGS="%{rpmldflags}" \
112         OFLAGS="%{rpmcflags}" \
113         DBGFLAGS="-DDEBUGMODE=1 %{rpmcflags}" \
114         LIB_INSTALL_PATH=%{_libdir}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_bindir}}
119
120 %{__make} install \
121         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
122         LIB_INSTALL_PATH=$RPM_BUILD_ROOT%{_libdir}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %post   allegro -p /sbin/ldconfig
131 %postun allegro -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc *.txt docs/*.txt
136 %attr(755,root,root) %{_bindir}/dumb2wav
137 %attr(755,root,root) %{_bindir}/dumbout
138 %attr(755,root,root) %{_libdir}/libdumb.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libdumb.so.0
140 %if %{with debug_libs}
141 %attr(755,root,root) %{_libdir}/libdumbd.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libdumbd.so.0
143 %endif
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libdumb.so
148 %{_libdir}/libdumb.la
149 %if %{with debug_libs}
150 %attr(755,root,root) %{_libdir}/libdumbd.so
151 %{_libdir}/libdumbd.la
152 %endif
153 %{_includedir}/dumb.h
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libdumb.a
158 %if %{with debug_libs}
159 %{_libdir}/libdumbd.a
160 %endif
161
162 %files allegro
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/dumbplay
165 %attr(755,root,root) %{_libdir}/libaldmb.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libaldmb.so.0
167 %if %{with debug_libs}
168 %attr(755,root,root) %{_libdir}/libaldmd.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libaldmd.so.0
170 %endif
171
172 %files allegro-devel
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/libaldmb.so
175 %{_libdir}/libaldmb.la
176 %if %{with debug_libs}
177 %attr(755,root,root) %{_libdir}/libaldmd.so
178 %{_libdir}/libaldmd.la
179 %endif
180 %{_includedir}/aldumb.h
181
182 %files allegro-static
183 %defattr(644,root,root,755)
184 %{_libdir}/libaldmb.a
185 %if %{with debug_libs}
186 %{_libdir}/libaldmd.a
187 %endif
This page took 0.07731 seconds and 4 git commands to generate.