]> git.pld-linux.org Git - packages/dssi.git/blob - dssi.spec
- x32 rebuild
[packages/dssi.git] / dssi.spec
1 #
2 # Conditional build:
3 %bcond_without  gui             # don't build gui examples (require qt4)
4 #
5 Summary:        Disposable Soft Synth Interface specification
6 Summary(pl.UTF-8):      Specyfikacja Disposable Soft Synth Interface
7 Name:           dssi
8 Version:        1.1.1
9 Release:        2
10 License:        LGPL v2.1
11 Group:          Development/Libraries
12 Source0:        http://downloads.sourceforge.net/dssi/%{name}-%{version}.tar.gz
13 # Source0-md5:  619ab73c883b02dc37ddb37001591f8b
14 Patch0:         %{name}-lib64.patch
15 Patch1:         %{name}-libx32.patch
16 URL:            http://dssi.sourceforge.net/
17 %if %{with gui}
18 BuildRequires:  QtCore-devel >= 4.0.1
19 BuildRequires:  QtGui-devel >= 4.0.1
20 BuildRequires:  qt4-build >= 4.0.1
21 %endif
22 BuildRequires:  alsa-lib-devel >= 0.9
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  jack-audio-connection-kit-devel >= 0.99.14
26 BuildRequires:  ladspa-devel >= 1.0
27 BuildRequires:  liblo-devel >= 0.12
28 BuildRequires:  libsamplerate-devel
29 BuildRequires:  libsndfile-devel
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 BuildRequires:  xorg-lib-libX11-devel
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 DSSI (pronounced "dizzy") is an API for audio plugins, with particular
37 application for software synthesis plugins with native user
38 interfaces. DSSI is an open specification developed for use in Linux
39 audio applications, although portable to other platforms. It may be
40 thought of as LADSPA-for-instruments, or something comparable to VSTi.
41
42 DSSI consists of a C language API for use by plugins and hosts, based
43 on the LADSPA API, and an OSC (Open Sound Control) API for use in user
44 interface to host communications. The DSSI specification consists of
45 an RFC which describes the background for the proposal and defines the
46 OSC part of the specification, and a documented header file which
47 defines the C API.
48
49 %description -l pl.UTF-8
50 DSSI (wymawiane "dizzy") to API dla wtyczek dźwiękowych z
51 zastosowaniem szczególnie dla wtyczek syntezy programowej z natywnymi
52 interfejsami użytkownika. DSSI to otwarta specyfikacja stworzona do
53 używania w linuksowych aplikacjach dźwiękowych, ale przenośna na inne
54 platformy. Można ją określić jako LADSPA dla instrumentów lub coś
55 porównywalnego do VSTi.
56
57 DSSI składa się z API języka C do użytku przez wtyczki i hosty, oparte
58 o API LADSPA oraz API OSC (Open Sound Control) do użytku w
59 interfejsach użytkownika do komunikacji z hostem. Specyfikacja DSSI
60 składa się z RFC opisującego tło propozycji i definiującego część OSC
61 specyfikacji oraz udokumentowanego pliku nagłówkowego definiującego
62 API C.
63
64 %package devel
65 Summary:        DSSI development files
66 Summary(pl.UTF-8):      Pliki nagłówkowe DSSI
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       alsa-lib-devel >= 0.9
70 Requires:       ladspa-devel >= 1.0
71 Obsoletes:      dssi < 1.0.0
72
73 %description devel
74 DSSI development files.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe DSSI.
78
79 %package host-jack
80 Summary:        A simple JACK/ALSA-sequencer plugin host
81 Summary(pl.UTF-8):      Prosty host wtyczek sekwencera JACK/ALSA
82 Group:          Applications/Sound
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       liblo >= 0.12
85
86 %description host-jack
87 A simple JACK/ALSA-sequencer plugin host.
88
89 %description host-jack -l pl.UTF-8
90 Prosty host wtyczek sekwencera JACK/ALSA.
91
92 %package examples
93 Summary:        Example DSSI plugins
94 Summary(pl.UTF-8):      Przykładowe wtyczki DSSI
95 Group:          Applications/Sound
96 Requires:       %{name} = %{version}-%{release}
97
98 %description examples
99 Example DSSI plugins.
100
101 %description examples -l pl.UTF-8
102 Przykładowe wtyczki DSSI
103
104 %prep
105 %setup -q
106 %if "%{_lib}" == "lib64"
107 %patch0 -p1
108 %endif
109 %if "%{_lib}" == "libx32"
110 %patch1 -p1
111 %endif
112
113 %build
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoconf}
117 %{__autoheader}
118 %{__automake}
119
120 %configure
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/dssi/*.la
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 %defattr(644,root,root,755)
136 %doc ChangeLog README doc/TODO doc/*.txt
137 %attr(755,root,root) %{_bindir}/dssi_analyse_plugin
138 %attr(755,root,root) %{_bindir}/dssi_list_plugins
139 %attr(755,root,root) %{_bindir}/dssi_osc_send
140 %attr(755,root,root) %{_bindir}/dssi_osc_update
141 %dir %{_libdir}/dssi
142 %{_mandir}/man1/dssi*.1*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %{_includedir}/dssi.h
147 %{_pkgconfigdir}/dssi.pc
148
149 %files host-jack
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/jack-dssi-host
152 %{_mandir}/man1/jack-dssi-host.1*
153
154 %files examples
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_bindir}/karplong
157 %attr(755,root,root) %{_bindir}/less_trivial_synth
158 %attr(755,root,root) %{_bindir}/trivial_sampler
159 %attr(755,root,root) %{_bindir}/trivial_synth
160 %attr(755,root,root) %{_libdir}/dssi/*.so
161 %if %{with gui}
162 %dir %{_libdir}/dssi/less_trivial_synth
163 %attr(755,root,root) %{_libdir}/dssi/less_trivial_synth/*_qt
164 %dir %{_libdir}/dssi/trivial_sampler
165 %attr(755,root,root) %{_libdir}/dssi/trivial_sampler/*_qt
166 %endif
This page took 0.155331 seconds and 4 git commands to generate.