]> git.pld-linux.org Git - packages/dnfdaemon.git/blob - dnfdaemon.spec
rebuild with python 3.10
[packages/dnfdaemon.git] / dnfdaemon.spec
1 Summary:        DBus daemon for dnf package actions
2 Name:           dnfdaemon
3 Version:        0.3.20
4 Release:        4
5 License:        GPL v2+
6 Source0:        https://github.com/manatools/dnfdaemon/releases/download/dnfdaemon-%{version}/%{name}-%{version}.tar.xz
7 # Source0-md5:  45f02532eb3d114793aa5076ce6e5e11
8 URL:            https://github.com/manatools/dnfdaemon
9 BuildRequires:  python3-modules
10 BuildRequires:  systemd-devel
11 Requires:       dnf >= 4.3.6
12 Requires:       polkit
13 Requires:       python3-dbus
14 Requires:       python3-pygobject3
15 Requires(post,preun,postun):    systemd-units >= 38
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Dbus daemon for performing package actions with the dnf package
21 manager
22
23 %package -n python3-%{name}
24 Summary:        Python 3 api for communicating with the dnf-daemon DBus service
25 Requires:       %{name} = %{version}-%{release}
26
27 %description -n python3-%{name}
28 Python API for communicating with the dnf-daemon DBus service.
29
30 %prep
31 %setup -q
32
33 %build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT%{systemdunitdir}
38
39 %{__make} install \
40         DESTDIR=$RPM_BUILD_ROOT \
41         DATADIR=%{_datadir} \
42         SYSCONFDIR=%{_datadir} \
43         SYSTEMDSYSTEMUNITDIR=%{systemdunitdir} \
44         PYLIBDIR3=$(echo %{py3_sitescriptdir} | sed 's/\/site-packages//')
45
46 %py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnfdaemon
47 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnfdaemon
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 %systemd_post %{name}.service
54
55 %postun
56 %systemd_postun %{name}.service
57
58 %preun
59 %systemd_preun %{name}.service
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README.md ChangeLog
64 %{_datadir}/dbus-1/system-services/org.baseurl.Dnf*
65 %{_datadir}/dbus-1/services/org.baseurl.Dnf*
66 %{_datadir}/polkit-1/actions/org.baseurl.Dnf*
67 %{_datadir}/dbus-1/system.d/org.baseurl.Dnf*
68 %{_datadir}/%{name}
69 %dir %{py3_sitescriptdir}/%{name}
70 %{py3_sitescriptdir}/%{name}/*.py
71 %{py3_sitescriptdir}/%{name}/__pycache__
72 %{py3_sitescriptdir}/%{name}/server
73 %{systemdunitdir}/%{name}.service
74
75 %files -n  python3-%{name}
76 %defattr(644,root,root,755)
77 %{py3_sitescriptdir}/%{name}/client
This page took 0.089879 seconds and 4 git commands to generate.