]> git.pld-linux.org Git - packages/denemo.git/blob - denemo.spec
- updated to 2.6.0
[packages/denemo.git] / denemo.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # ALSA support
4 %bcond_without  aubio           # AUBIO support
5 %bcond_without  evince          # Evince support
6 %bcond_without  fluidsynth      # Fluidsynth support
7 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
8 %bcond_without  jack            # JACK support
9 %bcond_without  portaudio       # PortAudio support
10 %bcond_without  portmidi        # PortMIDI support
11 %bcond_without  rubberband      # Rubberband support
12
13 Summary:        GTK+ frontend for GNU lilypond
14 Summary(pl.UTF-8):      Frontend GTK+ na GNU lilypond
15 Name:           denemo
16 Version:        2.6.0
17 Release:        1
18 License:        GPL v3+
19 Group:          X11/Applications/Sound
20 Source0:        https://ftp.gnu.org/gnu/denemo/%{name}-%{version}.tar.gz
21 # Source0-md5:  3267b27350e7a103cd809012aeb15e43
22 Patch0:         %{name}-fontsdir.patch
23 Patch1:         guile3.0.patch
24 URL:            http://www.denemo.org/
25 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 1.0.0}
26 %{?with_aubio:BuildRequires:    aubio-devel >= 0.4.0}
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake
29 %if %{with evince}
30 %if %{with gtk2}
31 BuildRequires:  evince-devel >= 2.32
32 BuildRequires:  evince-devel < 3
33 %else
34 BuildRequires:  evince-devel >= 3.0
35 %endif
36 %endif
37 %{?with_fluidsynth:BuildRequires:       fluidsynth-devel >= 1.0.8}
38 %{?with_portaudio:BuildRequires:        fftw3-devel >= 3.1.2}
39 BuildRequires:  fontconfig-devel >= 2.2.0
40 BuildRequires:  gettext-tools >= 0.18
41 BuildRequires:  glib2-devel >= 1:2.30
42 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.6.0}
43 %{!?with_gtk2:BuildRequires:    gtk+3-devel >= 3.0.0}
44 BuildRequires:  gtk-doc >= 1.14
45 %{?with_gtk2:BuildRequires:     gtksourceview2-devel >= 2.0}
46 %{!?with_gtk2:BuildRequires:    gtksourceview3-devel >= 3.0}
47 BuildRequires:  guile-devel >= 2.2
48 BuildRequires:  intltool >= 0.35.0
49 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.102.0}
50 BuildRequires:  librsvg-devel >= 2.0
51 BuildRequires:  libsmf-devel >= 1.3
52 BuildRequires:  libsndfile-devel >= 1.0
53 BuildRequires:  libstdc++-devel
54 BuildRequires:  libxml2-devel >= 2.3.10
55 BuildRequires:  pkgconfig
56 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
57 %{?with_portmidi:BuildRequires: portmidi-devel}
58 %{?with_rubberband:BuildRequires:       rubberband-devel >= 1.0.8}
59 BuildRequires:  xorg-lib-libX11-devel
60 Requires:       lilypond >= 2.6
61 Obsoletes:      denemo-devel < 2
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 Denemo is a graphical music notation program written in C with GTK+.
66
67 It is intended to be used in conjunction with GNU Lilypond
68 (<http://lilypond.org/>), but is adaptable to other
69 computer-music-related purposes as well.
70
71 %description -l pl.UTF-8
72 Denemo to program do graficznej notacji muzycznej używający GTK+.
73
74 Jest przeznaczony do używania z GNU Lilypond (<http://lilypond.org/>),
75 ale może być zaadaptowany do innych celów związanych z muzyką.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81
82 %build
83 %{__intltoolize}
84 %{__aclocal} -I build
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 CFLAGS="%{rpmcflags} %{?debug:-DDEBUG}"
89 %configure \
90         %{?with_alsa:--enable-alsa} \
91         %{!?with_aubio:--disable-aubio} \
92         %{!?with_evince:--disable-evince} \
93         %{!?with_fluidsynth:--disable-fluidsynth} \
94         %{?with_gtk2:--enable-gtk2} \
95         %{!?with_gtk2:--enable-gtk3} \
96         %{?with_jack:--enable-jack} \
97         %{!?with_portaudio:--disable-portaudio} \
98         %{!?with_portmidi:--disable-portmidi} \
99         %{!?with_rubberband:--disable-rubberband}
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %find_lang %{name}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files -f %{name}.lang
115 %defattr(644,root,root,755)
116 %doc AUTHORS ChangeLog NEWS docs/{DESIGN*,GOALS,TODO}
117 %attr(755,root,root) %{_bindir}/annotator
118 %attr(755,root,root) %{_bindir}/cairo_svg2path
119 %attr(755,root,root) %{_bindir}/denemo
120 %attr(755,root,root) %{_bindir}/denemo_file_update
121 %attr(755,root,root) %{_bindir}/pageswitcher
122 %attr(755,root,root) %{_bindir}/pageturner
123 %attr(755,root,root) %{_bindir}/twopageturner
124 %{_datadir}/appdata/org.denemo.Denemo.appdata.xml
125 %{_datadir}/denemo
126 %{_fontsdir}/denemo
127 %{_desktopdir}/org.denemo.Denemo.desktop
128 %{_pixmapsdir}/org.denemo.Denemo.png
This page took 0.063125 seconds and 4 git commands to generate.