]> git.pld-linux.org Git - packages/datamash.git/blob - datamash.spec
up to 1.8
[packages/datamash.git] / datamash.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't run tests
4
5 Summary:        A statistical, numerical and textual operations tool
6 Name:           datamash
7 Version:        1.8
8 Release:        1
9 License:        GPL v3+
10 Group:          Applications
11 Source0:        http://ftp.gnu.org/gnu/datamash/%{name}-%{version}.tar.gz
12 # Source0-md5:  b5f2dcfcefb2d41f88c54619b08727e3
13 URL:            https://www.gnu.org/software/datamash/
14 BuildRequires:  gettext-tools
15 BuildRequires:  pkgconfig
16 %if %{with tests}
17 BuildRequires:  perl-base
18 BuildRequires:  perl-modules
19 BuildRequires:  rpm-build >= 4.6
20 %endif
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 GNU datamash is a command-line program which performs basic numeric,
25 textual and statistical operations on input textual data files.
26
27 %package -n bash-completion-datamash
28 Summary:        Bash completion for datamash command line
29 Group:          Applications/Shells
30 Requires:       %{name} = %{version}-%{release}
31 Requires:       bash-completion >= 1:2.0
32 BuildArch:      noarch
33
34 %description -n bash-completion-datamash
35 Bash completion for datamash command line.
36
37 %prep
38 %setup -q
39
40 %build
41 %configure \
42         --with-bash-completion-dir="%{bash_compdir}"
43
44 %{__make}
45
46 %{?with_tests:%{__make} check}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 install -d $RPM_BUILD_ROOT%{bash_compdir}
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
57
58 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/examples
59
60 %find_lang %{name}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post   -p /sbin/postshell
66 -/usr/sbin/fix-info-dir -c %{_infodir}
67
68 %postun -p /sbin/postshell
69 -/usr/sbin/fix-info-dir -c %{_infodir}
70
71 %files -f %{name}.lang
72 %defattr(644,root,root,755)
73 %doc AUTHORS ChangeLog NEWS README THANKS examples
74 %attr(755,root,root) %{_bindir}/datamash
75 %attr(755,root,root) %{_bindir}/decorate
76 %{_infodir}/datamash.info*
77 %{_mandir}/man1/datamash.1*
78 %{_mandir}/man1/decorate.1*
79
80 %files -n bash-completion-datamash
81 %defattr(644,root,root,755)
82 %{bash_compdir}/datamash
This page took 0.107741 seconds and 4 git commands to generate.