]> git.pld-linux.org Git - packages/daala.git/blob - daala.spec
- unconditional noarch subpackages
[packages/daala.git] / daala.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  tests           # unit tests
5
6 %define snap    20140214
7 %define rel             3
8 Summary:        Daala next-generation video codec
9 Summary(pl.UTF-8):      Daala - kodek obrazu następnej generacji
10 Name:           daala
11 Version:        0.0
12 Release:        0.%{snap}.%{rel}
13 License:        BSD
14 Group:          Libraries
15 # git clone https://git.xiph.org/daala.git
16 # cd daala && ./update_version && cd ..
17 # tar cJf daala.tar.xz daala
18 Source0:        %{name}.tar.xz
19 # Source0-md5:  95bb883af28b16ff1312960cc52a2282
20 URL:            http://xiph.org/daala/
21 BuildRequires:  SDL-devel
22 BuildRequires:  autoconf >= 2.53
23 BuildRequires:  automake >= 1:1.11
24 %{?with_tests:BuildRequires:    check-devel >= 0.9.8}
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libogg-devel >= 1:1.3
27 BuildRequires:  libpng-devel
28 BuildRequires:  libtheora-devel
29 BuildRequires:  libtool >= 2:2
30 %if %{with apidocs}
31 BuildRequires:  doxygen
32 BuildRequires:  transfig
33 %endif
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Daala is the code-name for a new video compression technology. The
38 effort is a collaboration between Mozilla Foundation, Xiph.Org
39 Foundation and other contributors.
40
41 The goal of the project is to provide a free to implement, use and
42 distribute digital media format and reference implementation with
43 technical performance superior to H.265.
44
45 %description -l pl.UTF-8
46 Daala to nazwa kodowa nowej technologii kompresji obrazu. Próby te są
47 efektem współpracy Mozilla Foundation, Xiph.Org oraz innych
48 współpracowników.
49
50 Celem projektu jest dostarczenie wolnego w implementacji, użyciu i
51 rozpowszechnianiu formatu treści cyfrowej oraz wzorcowej implementacji
52 o wydajności lepszej niż H.265.
53
54 %package devel
55 Summary:        Header files for Daala libraries
56 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Daala
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       libogg-devel >= 1.3
60 Requires:       libpng-devel
61
62 %description devel
63 Header files for Daala libraries.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe bibliotek Daala.
67
68 %package static
69 Summary:        Static Daala libraries
70 Summary(pl.UTF-8):      Statyczne biblioteki Daala
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static Daala libraries.
76
77 %description static -l pl.UTF-8
78 Statyczne biblioteki Daala.
79
80 %package apidocs
81 Summary:        Daala API documentation
82 Summary(pl.UTF-8):      Dokumentacja API bibliotek Daala
83 Group:          Documentation
84 BuildArch:      noarch
85
86 %description apidocs
87 API documentation for Daala libraries.
88
89 %description apidocs -l pl.UTF-8
90 Dokumentacja API bibliotek Daala.
91
92 %prep
93 %setup -q -n %{name}
94
95 %build
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         %{!?with_apidocs:--disable-doc} \
103         --disable-silent-rules \
104         %{!?with_tests:--disable-unit-tests}
105 %{__make}
106
107 %if %{with tests}
108 %{__make} check
109 %endif
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 # obsoleted by pkg-config
118 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdaala*.la
119 # packaged as %doc
120 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/daala
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS COPYING README
131 %attr(755,root,root) %{_libdir}/libdaalabase.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libdaalabase.so.0
133 %attr(755,root,root) %{_libdir}/libdaaladec.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libdaaladec.so.0
135 %attr(755,root,root) %{_libdir}/libdaalaenc.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libdaalaenc.so.0
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libdaalabase.so
141 %attr(755,root,root) %{_libdir}/libdaaladec.so
142 %attr(755,root,root) %{_libdir}/libdaalaenc.so
143 %{_includedir}/daala
144 %{_pkgconfigdir}/daaladec.pc
145 %{_pkgconfigdir}/daalaenc.pc
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libdaalabase.a
150 %{_libdir}/libdaaladec.a
151 %{_libdir}/libdaalaenc.a
152
153 %if %{with apidocs}
154 %files apidocs
155 %defattr(644,root,root,755)
156 %doc doc/html/*
157 %endif
This page took 0.065305 seconds and 4 git commands to generate.