]> git.pld-linux.org Git - packages/cups.git/commitdiff
- rel 2 auto/th/cups-1_5_0-2
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 2 Aug 2011 12:21:12 +0000 (12:21 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix printing over SSL, amazing apple idiots

Changed files:
    cups-ssl-segfault.patch -> 1.1
    cups.spec -> 1.302

cups-ssl-segfault.patch [new file with mode: 0644]
cups.spec

diff --git a/cups-ssl-segfault.patch b/cups-ssl-segfault.patch
new file mode 100644 (file)
index 0000000..938c341
--- /dev/null
@@ -0,0 +1,26 @@
+--- cups-1.5.0/cups/http.c~    2011-06-16 22:12:16.000000000 +0200
++++ cups-1.5.0/cups/http.c     2011-08-02 14:06:25.143633360 +0200
+@@ -3814,7 +3814,7 @@
+   BIO_ctrl(bio, BIO_C_SET_FILE_PTR, 0, (char *)http);
+   http->tls = SSL_new(context);
+-  SSL_set_bio(http->tls_credentials, bio, bio);
++  SSL_set_bio(http->tls, bio, bio);
+   if (SSL_connect(http->tls) != 1)
+   {
+@@ -4173,11 +4173,11 @@
+ #  ifdef HAVE_LIBSSL
+   SSL_CTX     *context;               /* Context for encryption */
+-  context = SSL_get_SSL_CTX(http->tls_credentials);
++  context = SSL_get_SSL_CTX(http->tls);
+-  SSL_shutdown(http->tls_credentials);
++  SSL_shutdown(http->tls);
+   SSL_CTX_free(context);
+-  SSL_free(http->tls_credentials);
++  SSL_free(http->tls);
+ #  elif defined(HAVE_GNUTLS)
+   gnutls_certificate_client_credentials *credentials;
index ad9bb0bcb987997c2c148ee5a2b80f375ab00018..abf589487a5081b22743f86ca7a60705954b7f35 100644 (file)
--- a/cups.spec
+++ b/cups.spec
@@ -17,7 +17,7 @@ Summary(pl.UTF-8):    Ogólny system druku dla Uniksa
 Summary(pt_BR.UTF-8):  Sistema Unix de Impressão
 Name:          cups
 Version:       1.5.0
-Release:       1
+Release:       2
 Epoch:         1
 License:       LGPL v2 (libraries), GPL v2 (the rest) + openssl exception
 Group:         Applications/Printing
@@ -42,6 +42,7 @@ Patch9:               %{name}-verbose-compilation.patch
 Patch10:       %{name}-peercred.patch
 Patch11:       %{name}-usb.patch
 Patch12:       %{name}-desktop.patch
+Patch13:       %{name}-ssl-segfault.patch
 URL:           http://www.cups.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf >= 2.60
@@ -311,6 +312,7 @@ Wsparcie dla LPD w serwerze wydruków CUPS.
 # why it hasn't been merged for so long (and why no other distro uses it)
 #%patch11 -p1
 %patch12 -p1
+%patch13 -p1
 
 %build
 %{__aclocal} -I config-scripts
This page took 0.203062 seconds and 4 git commands to generate.