]> git.pld-linux.org Git - packages/cups.git/blobdiff - cups-lspp.patch
- up to 2.3.1
[packages/cups.git] / cups-lspp.patch
index 667cda196d3a6b6cc26e1cb10eecb30a75aefa5a..7c094d210e453316157b3ce8c2d0ddf9709c856f 100644 (file)
@@ -1,7 +1,7 @@
-diff -up cups-2.2.8/config.h.in.lspp cups-2.2.8/config.h.in
---- cups-2.2.8/config.h.in.lspp        2018-06-05 18:06:54.000000000 +0200
-+++ cups-2.2.8/config.h.in     2018-06-08 17:34:38.682653959 +0200
-@@ -730,4 +730,11 @@ static __inline int _cups_abs(int i) { r
+diff -up cups-2.3.0/config.h.in.lspp cups-2.3.0/config.h.in
+--- cups-2.3.0/config.h.in.lspp        2019-08-23 17:19:38.000000000 +0200
++++ cups-2.3.0/config.h.in     2019-10-07 12:24:43.058597468 +0200
+@@ -684,4 +684,11 @@ static __inline int _cups_abs(int i) { r
  #  endif /* __GNUC__ || __STDC_VERSION__ */
  #endif /* !HAVE_ABS && !abs */
  
@@ -13,9 +13,9 @@ diff -up cups-2.2.8/config.h.in.lspp cups-2.2.8/config.h.in
 +
 +
  #endif /* !_CUPS_CONFIG_H_ */
-diff -up cups-2.2.8/config-scripts/cups-lspp.m4.lspp cups-2.2.8/config-scripts/cups-lspp.m4
---- cups-2.2.8/config-scripts/cups-lspp.m4.lspp        2018-06-08 17:34:38.682653959 +0200
-+++ cups-2.2.8/config-scripts/cups-lspp.m4     2018-06-08 17:34:38.682653959 +0200
+diff -up cups-2.3.0/config-scripts/cups-lspp.m4.lspp cups-2.3.0/config-scripts/cups-lspp.m4
+--- cups-2.3.0/config-scripts/cups-lspp.m4.lspp        2019-10-07 12:24:43.058597468 +0200
++++ cups-2.3.0/config-scripts/cups-lspp.m4     2019-10-07 12:24:43.058597468 +0200
 @@ -0,0 +1,36 @@
 +dnl
 +dnl   LSPP code for the Common UNIX Printing System (CUPS).
@@ -53,22 +53,22 @@ diff -up cups-2.2.8/config-scripts/cups-lspp.m4.lspp cups-2.2.8/config-scripts/c
 +            ;;
 +    esac
 +fi
-diff -up cups-2.2.8/configure.ac.lspp cups-2.2.8/configure.ac
---- cups-2.2.8/configure.ac.lspp       2018-06-05 18:06:54.000000000 +0200
-+++ cups-2.2.8/configure.ac    2018-06-08 17:34:38.682653959 +0200
-@@ -38,6 +38,8 @@ sinclude(config-scripts/cups-startup.m4)
+diff -up cups-2.3.0/configure.ac.lspp cups-2.3.0/configure.ac
+--- cups-2.3.0/configure.ac.lspp       2019-10-07 12:24:43.058597468 +0200
++++ cups-2.3.0/configure.ac    2019-10-07 12:39:20.122546282 +0200
+@@ -34,6 +34,8 @@ sinclude(config-scripts/cups-dnssd.m4)
+ sinclude(config-scripts/cups-startup.m4)
  sinclude(config-scripts/cups-defaults.m4)
- sinclude(config-scripts/cups-scripting.m4)
  
 +sinclude(config-scripts/cups-lspp.m4)
 +
  INSTALL_LANGUAGES=""
  UNINSTALL_LANGUAGES=""
  LANGFILES=""
-diff -up cups-2.2.8/filter/common.c.lspp cups-2.2.8/filter/common.c
---- cups-2.2.8/filter/common.c.lspp    2018-06-05 18:06:54.000000000 +0200
-+++ cups-2.2.8/filter/common.c 2018-06-08 17:34:38.682653959 +0200
-@@ -17,6 +17,12 @@
+diff -up cups-2.3.0/filter/common.c.lspp cups-2.3.0/filter/common.c
+--- cups-2.3.0/filter/common.c.lspp    2019-08-23 17:19:38.000000000 +0200
++++ cups-2.3.0/filter/common.c 2019-10-07 12:24:43.059597461 +0200
+@@ -11,6 +11,12 @@
   * Include necessary headers...
   */
  
@@ -81,7 +81,7 @@ diff -up cups-2.2.8/filter/common.c.lspp cups-2.2.8/filter/common.c
  #include "common.h"
  #include <locale.h>
  
-@@ -299,6 +305,18 @@ WriteLabelProlog(const char *label,       /* I
+@@ -293,6 +299,18 @@ WriteLabelProlog(const char *label,       /* I
  {
    const char  *classification;        /* CLASSIFICATION environment variable */
    const char  *ptr;                   /* Temporary string pointer */
@@ -100,7 +100,7 @@ diff -up cups-2.2.8/filter/common.c.lspp cups-2.2.8/filter/common.c
  
  
   /*
-@@ -321,6 +339,124 @@ WriteLabelProlog(const char *label,      /* I
+@@ -315,6 +333,124 @@ WriteLabelProlog(const char *label,      /* I
      return;
    }
  
@@ -225,7 +225,7 @@ diff -up cups-2.2.8/filter/common.c.lspp cups-2.2.8/filter/common.c
   /*
    * Set the classification + page label string...
    */
-@@ -401,7 +537,10 @@ WriteLabelProlog(const char *label,       /* I
+@@ -395,7 +531,10 @@ WriteLabelProlog(const char *label,       /* I
    printf("  %.0f moveto ESPpl show\n", top - 14.0);
    puts("pop");
    puts("}bind put");
@@ -236,10 +236,10 @@ diff -up cups-2.2.8/filter/common.c.lspp cups-2.2.8/filter/common.c
  
  
  /*
-diff -up cups-2.2.8/filter/pstops.c.lspp cups-2.2.8/filter/pstops.c
---- cups-2.2.8/filter/pstops.c.lspp    2018-06-05 18:06:54.000000000 +0200
-+++ cups-2.2.8/filter/pstops.c 2018-06-08 17:34:38.683653951 +0200
-@@ -3176,6 +3176,18 @@ write_label_prolog(pstops_doc_t *doc,   /*
+diff -up cups-2.3.0/filter/pstops.c.lspp cups-2.3.0/filter/pstops.c
+--- cups-2.3.0/filter/pstops.c.lspp    2019-08-23 17:19:38.000000000 +0200
++++ cups-2.3.0/filter/pstops.c 2019-10-07 12:24:43.059597461 +0200
+@@ -3170,6 +3170,18 @@ write_label_prolog(pstops_doc_t *doc,   /*
  {
    const char  *classification;        /* CLASSIFICATION environment variable */
    const char  *ptr;                   /* Temporary string pointer */
@@ -258,7 +258,7 @@ diff -up cups-2.2.8/filter/pstops.c.lspp cups-2.2.8/filter/pstops.c
  
  
   /*
-@@ -3198,6 +3210,124 @@ write_label_prolog(pstops_doc_t *doc,  /*
+@@ -3192,6 +3204,124 @@ write_label_prolog(pstops_doc_t *doc,  /*
      return;
    }
  
@@ -383,7 +383,7 @@ diff -up cups-2.2.8/filter/pstops.c.lspp cups-2.2.8/filter/pstops.c
   /*
    * Set the classification + page label string...
    */
-@@ -3276,7 +3406,10 @@ write_label_prolog(pstops_doc_t *doc,   /*
+@@ -3270,7 +3400,10 @@ write_label_prolog(pstops_doc_t *doc,   /*
    doc_printf(doc, "  %.0f moveto ESPpl show\n", top - 14.0);
    doc_puts(doc, "pop\n");
    doc_puts(doc, "}bind put\n");
@@ -394,22 +394,22 @@ diff -up cups-2.2.8/filter/pstops.c.lspp cups-2.2.8/filter/pstops.c
  
  
  /*
-diff -up cups-2.2.8/Makedefs.in.lspp cups-2.2.8/Makedefs.in
---- cups-2.2.8/Makedefs.in.lspp        2018-06-05 18:06:54.000000000 +0200
-+++ cups-2.2.8/Makedefs.in     2018-06-08 17:34:38.683653951 +0200
-@@ -161,7 +161,7 @@ LDFLAGS            =       -L../cgi-bin -L../cups -L../f
-                       @LDFLAGS@ @RELROFLAGS@ @PIEFLAGS@ $(OPTIM)
- LINKCUPS      =       @LINKCUPS@ $(LIBGSSAPI) $(DNSSDLIBS) $(SSLLIBS) $(LIBZ)
- LINKCUPSIMAGE =       @LINKCUPSIMAGE@
--LIBS          =       $(LINKCUPS) $(COMMONLIBS)
-+LIBS          =       $(LINKCUPS) $(COMMONLIBS) @LIBAUDIT@ @LIBSELINUX@
+diff -up cups-2.3.0/Makedefs.in.lspp cups-2.3.0/Makedefs.in
+--- cups-2.3.0/Makedefs.in.lspp        2019-10-07 12:24:43.059597461 +0200
++++ cups-2.3.0/Makedefs.in     2019-10-07 12:37:19.200565805 +0200
+@@ -174,7 +174,7 @@ IPPFIND_MAN        =       @IPPFIND_MAN@
+ LDFLAGS               =       @LDFLAGS@
+ LINKCUPS      =       @LINKCUPS@
+ LINKCUPSSTATIC        =       ../cups/$(LIBCUPSSTATIC) $(LIBS)
+-LIBS          =       $(LIBGSSAPI) $(DNSSDLIBS) $(SSLLIBS) $(LIBZ) $(COMMONLIBS)
++LIBS          =       $(LIBGSSAPI) $(DNSSDLIBS) $(SSLLIBS) $(LIBZ) $(COMMONLIBS) @LIBAUDIT@ @LIBSELINUX@
  ONDEMANDFLAGS =       @ONDEMANDFLAGS@
  ONDEMANDLIBS  =       @ONDEMANDLIBS@
  OPTIM         =       @OPTIM@
-diff -up cups-2.2.8/scheduler/client.c.lspp cups-2.2.8/scheduler/client.c
---- cups-2.2.8/scheduler/client.c.lspp 2018-06-05 18:06:54.000000000 +0200
-+++ cups-2.2.8/scheduler/client.c      2018-06-08 17:34:38.729653586 +0200
-@@ -22,12 +22,20 @@
+diff -up cups-2.3.0/scheduler/client.c.lspp cups-2.3.0/scheduler/client.c
+--- cups-2.3.0/scheduler/client.c.lspp 2019-08-23 17:19:38.000000000 +0200
++++ cups-2.3.0/scheduler/client.c      2019-10-07 12:33:10.459693580 +0200
+@@ -19,12 +19,20 @@
  #define _HTTP_NO_PRIVATE
  #include "cupsd.h"
  
@@ -430,7 +430,7 @@ diff -up cups-2.2.8/scheduler/client.c.lspp cups-2.2.8/scheduler/client.c
  
  
  /*
-@@ -268,6 +276,59 @@ cupsdAcceptClient(cupsd_listener_t *lis)
+@@ -265,6 +273,59 @@ cupsdAcceptClient(cupsd_listener_t *lis)
    }
  #endif /* HAVE_TCPD_H */
  
@@ -490,9 +490,9 @@ diff -up cups-2.2.8/scheduler/client.c.lspp cups-2.2.8/scheduler/client.c
  #ifdef AF_LOCAL
    if (httpAddrFamily(httpGetAddress(con->http)) == AF_LOCAL)
    {
-@@ -562,6 +623,13 @@ cupsdReadClient(cupsd_client_t *con)      /*
+@@ -558,6 +619,13 @@ cupsdReadClient(cupsd_client_t *con)      /*
+   struct stat         filestats;      /* File information */
    mime_type_t         *type;          /* MIME type of file */
-   cupsd_printer_t     *p;             /* Printer */
    static unsigned     request_id = 0; /* Request ID for temp files */
 +#ifdef WITH_LSPP
 +  security_context_t  spoolcon;       /* context of the job file */
@@ -504,7 +504,7 @@ diff -up cups-2.2.8/scheduler/client.c.lspp cups-2.2.8/scheduler/client.c
  
  
    status = HTTP_STATUS_CONTINUE;
-@@ -1938,6 +2006,73 @@ cupsdReadClient(cupsd_client_t *con)    /*
+@@ -1679,6 +1747,73 @@ cupsdReadClient(cupsd_client_t *con)    /*
              fcntl(con->file, F_SETFD, fcntl(con->file, F_GETFD) | FD_CLOEXEC);
          }
  
@@ -578,7 +578,7 @@ diff -up cups-2.2.8/scheduler/client.c.lspp cups-2.2.8/scheduler/client.c
          if (httpGetState(con->http) != HTTP_STATE_POST_SEND)
          {
            if (!httpWait(con->http, 0))
-@@ -3485,6 +3620,49 @@ is_path_absolute(const char *path)      /* I
+@@ -3174,6 +3309,49 @@ is_path_absolute(const char *path)      /* I
    return (1);
  }
  
@@ -628,10 +628,10 @@ diff -up cups-2.2.8/scheduler/client.c.lspp cups-2.2.8/scheduler/client.c
  
  /*
   * 'pipe_command()' - Pipe the output of a command to the remote client.
-diff -up cups-2.2.8/scheduler/client.h.lspp cups-2.2.8/scheduler/client.h
---- cups-2.2.8/scheduler/client.h.lspp 2018-06-05 18:06:54.000000000 +0200
-+++ cups-2.2.8/scheduler/client.h      2018-06-08 17:34:38.729653586 +0200
-@@ -16,6 +16,13 @@
+diff -up cups-2.3.0/scheduler/client.h.lspp cups-2.3.0/scheduler/client.h
+--- cups-2.3.0/scheduler/client.h.lspp 2019-08-23 17:19:38.000000000 +0200
++++ cups-2.3.0/scheduler/client.h      2019-10-07 12:24:43.113597079 +0200
+@@ -13,6 +13,13 @@
  #endif /* HAVE_AUTHORIZATION_H */
  
  
@@ -645,7 +645,7 @@ diff -up cups-2.2.8/scheduler/client.h.lspp cups-2.2.8/scheduler/client.h
  /*
   * HTTP client structure...
   */
-@@ -66,6 +73,10 @@ struct cupsd_client_s
+@@ -63,6 +70,10 @@ struct cupsd_client_s
  #ifdef HAVE_AUTHORIZATION_H
    AuthorizationRef    authref;        /* Authorization ref */
  #endif /* HAVE_AUTHORIZATION_H */
@@ -656,7 +656,7 @@ diff -up cups-2.2.8/scheduler/client.h.lspp cups-2.2.8/scheduler/client.h
  };
  
  #define HTTP(con) ((con)->http)
-@@ -139,6 +150,9 @@ extern void        cupsdStartListening(void);
+@@ -136,6 +147,9 @@ extern void        cupsdStartListening(void);
  extern void   cupsdStopListening(void);
  extern void   cupsdUpdateCGI(void);
  extern void   cupsdWriteClient(cupsd_client_t *con);
@@ -666,10 +666,10 @@ diff -up cups-2.2.8/scheduler/client.h.lspp cups-2.2.8/scheduler/client.h
  
  #ifdef HAVE_SSL
  extern int    cupsdEndTLS(cupsd_client_t *con);
-diff -up cups-2.2.8/scheduler/conf.c.lspp cups-2.2.8/scheduler/conf.c
---- cups-2.2.8/scheduler/conf.c.lspp   2018-06-08 17:34:38.676654007 +0200
-+++ cups-2.2.8/scheduler/conf.c        2018-06-08 17:34:38.730653578 +0200
-@@ -40,6 +40,9 @@
+diff -up cups-2.3.0/scheduler/conf.c.lspp cups-2.3.0/scheduler/conf.c
+--- cups-2.3.0/scheduler/conf.c.lspp   2019-10-07 12:24:43.049597531 +0200
++++ cups-2.3.0/scheduler/conf.c        2019-10-07 12:24:43.113597079 +0200
+@@ -37,6 +37,9 @@
  #  define INADDR_NONE 0xffffffff
  #endif /* !INADDR_NONE */
  
@@ -700,7 +700,7 @@ diff -up cups-2.2.8/scheduler/conf.c.lspp cups-2.2.8/scheduler/conf.c
  
  
   /*
-@@ -863,6 +873,25 @@ cupsdReadConfiguration(void)
+@@ -864,6 +874,25 @@ cupsdReadConfiguration(void)
  
    RunUser = getuid();
  
@@ -726,7 +726,7 @@ diff -up cups-2.2.8/scheduler/conf.c.lspp cups-2.2.8/scheduler/conf.c
    cupsdLogMessage(CUPSD_LOG_INFO, "Remote access is %s.",
                    RemotePort ? "enabled" : "disabled");
  
-@@ -1274,7 +1303,19 @@ cupsdReadConfiguration(void)
+@@ -1275,7 +1304,19 @@ cupsdReadConfiguration(void)
      cupsdClearString(&Classification);
  
    if (Classification)
@@ -746,7 +746,7 @@ diff -up cups-2.2.8/scheduler/conf.c.lspp cups-2.2.8/scheduler/conf.c
  
   /*
    * Check the MaxClients setting, and then allocate memory for it...
-@@ -3832,6 +3873,18 @@ read_location(cups_file_t *fp,          /* I - C
+@@ -3830,6 +3871,18 @@ read_location(cups_file_t *fp,          /* I - C
    return ((FatalErrors & CUPSD_FATAL_CONFIG) ? 0 : linenum);
  }
  
@@ -765,10 +765,10 @@ diff -up cups-2.2.8/scheduler/conf.c.lspp cups-2.2.8/scheduler/conf.c
  
  /*
   * 'read_policy()' - Read a <Policy name> definition.
-diff -up cups-2.2.8/scheduler/conf.h.lspp cups-2.2.8/scheduler/conf.h
---- cups-2.2.8/scheduler/conf.h.lspp   2018-06-05 18:06:54.000000000 +0200
-+++ cups-2.2.8/scheduler/conf.h        2018-06-08 17:34:38.730653578 +0200
-@@ -246,6 +246,13 @@ VAR char          *ServerKeychain         VALUE(NULL);
+diff -up cups-2.3.0/scheduler/conf.h.lspp cups-2.3.0/scheduler/conf.h
+--- cups-2.3.0/scheduler/conf.h.lspp   2019-08-23 17:19:38.000000000 +0200
++++ cups-2.3.0/scheduler/conf.h        2019-10-07 12:24:43.113597079 +0200
+@@ -243,6 +243,13 @@ VAR char          *ServerKeychain         VALUE(NULL);
                                        /* Keychain holding cert + key */
  #endif /* HAVE_SSL */
  
@@ -782,7 +782,7 @@ diff -up cups-2.2.8/scheduler/conf.h.lspp cups-2.2.8/scheduler/conf.h
  #ifdef HAVE_ONDEMAND
  VAR int                       IdleExitTimeout         VALUE(60);
                                        /* Time after which an idle cupsd will exit */
-@@ -264,6 +271,9 @@ VAR int                    HaveServerCreds         VALUE(0);
+@@ -261,6 +268,9 @@ VAR int                    HaveServerCreds         VALUE(0);
  VAR gss_cred_id_t     ServerCreds;    /* Server's GSS credentials */
  #endif /* HAVE_GSSAPI */
  
@@ -792,11 +792,11 @@ diff -up cups-2.2.8/scheduler/conf.h.lspp cups-2.2.8/scheduler/conf.h
  
  /*
   * Prototypes...
-diff -up cups-2.2.8/scheduler/cupsd.h.lspp cups-2.2.8/scheduler/cupsd.h
---- cups-2.2.8/scheduler/cupsd.h.lspp  2018-06-05 18:06:54.000000000 +0200
-+++ cups-2.2.8/scheduler/cupsd.h       2018-06-08 17:34:38.730653578 +0200
-@@ -11,6 +11,8 @@
-  * file is missing or damaged, see the license at "http://www.cups.org/".
+diff -up cups-2.3.0/scheduler/cupsd.h.lspp cups-2.3.0/scheduler/cupsd.h
+--- cups-2.3.0/scheduler/cupsd.h.lspp  2019-08-23 17:19:38.000000000 +0200
++++ cups-2.3.0/scheduler/cupsd.h       2019-10-07 12:31:38.458480578 +0200
+@@ -8,6 +8,8 @@
+  * information.
   */
  
 +/* Copyright (C) 2005 Trusted Computer Solutions, Inc. */
@@ -804,9 +804,9 @@ diff -up cups-2.2.8/scheduler/cupsd.h.lspp cups-2.2.8/scheduler/cupsd.h
  
  /*
   * Include necessary headers.
-@@ -36,13 +38,20 @@
+@@ -33,6 +35,14 @@
  #  include <unistd.h>
- #endif /* WIN32 */
+ #endif /* _WIN32 */
  
 +#include "config.h"
 +#ifdef WITH_LSPP
@@ -819,18 +819,11 @@ diff -up cups-2.2.8/scheduler/cupsd.h.lspp cups-2.2.8/scheduler/cupsd.h
  #include "mime.h"
  
  #if defined(HAVE_CDSASSL)
- #  include <CoreFoundation/CoreFoundation.h>
- #endif /* HAVE_CDSASSL */
--
- /*
-  * Some OS's don't have hstrerror(), most notably Solaris...
-  */
-diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
---- cups-2.2.8/scheduler/ipp.c.lspp    2018-06-08 17:34:38.652654197 +0200
-+++ cups-2.2.8/scheduler/ipp.c 2018-06-08 17:37:19.166378937 +0200
-@@ -14,6 +14,9 @@
-  * missing or damaged, see the license at "http://www.cups.org/".
+diff -up cups-2.3.0/scheduler/ipp.c.lspp cups-2.3.0/scheduler/ipp.c
+--- cups-2.3.0/scheduler/ipp.c.lspp    2019-10-07 12:24:43.016597764 +0200
++++ cups-2.3.0/scheduler/ipp.c 2019-10-07 12:31:01.243798920 +0200
+@@ -11,6 +11,9 @@
+  * information.
   */
  
 +/* Copyright (C) 2005 Trusted Computer Solutions, Inc. */
@@ -839,8 +832,8 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
  /*
   * Include necessary headers...
   */
-@@ -37,6 +40,14 @@ extern int mbr_check_membership_by_id(uu
- #  endif /* HAVE_MEMBERSHIPPRIV_H */
+@@ -27,6 +30,14 @@ extern int mbr_group_name_to_uuid(const
+ extern int mbr_check_membership_by_id(uuid_t user, gid_t group, int* ismember);
  #endif /* __APPLE__ */
  
 +#ifdef WITH_LSPP
@@ -854,7 +847,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
  
  /*
   * Local functions...
-@@ -61,6 +72,9 @@ static void  cancel_all_jobs(cupsd_client
+@@ -51,6 +62,9 @@ static void  cancel_all_jobs(cupsd_client
  static void   cancel_job(cupsd_client_t *con, ipp_attribute_t *uri);
  static void   cancel_subscription(cupsd_client_t *con, int id);
  static int    check_rss_recipient(const char *recipient);
@@ -864,7 +857,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
  static int    check_quotas(cupsd_client_t *con, cupsd_printer_t *p);
  static void   close_job(cupsd_client_t *con, ipp_attribute_t *uri);
  static void   copy_attrs(ipp_t *to, ipp_t *from, cups_array_t *ra,
-@@ -1250,6 +1264,21 @@ add_job(cupsd_client_t  *con,           /* I - Cl
+@@ -1240,6 +1254,21 @@ add_job(cupsd_client_t  *con,           /* I - Cl
      "time-at-creation",
      "time-at-processing"
    };
@@ -886,7 +879,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
  
  
    cupsdLogMessage(CUPSD_LOG_DEBUG2, "add_job(%p[%d], %p(%s), %p(%s/%s))",
-@@ -1578,6 +1607,106 @@ add_job(cupsd_client_t  *con,          /* I - Cl
+@@ -1568,6 +1597,106 @@ add_job(cupsd_client_t  *con,          /* I - Cl
  
    attr = ippFindAttribute(con->request, "requesting-user-name", IPP_TAG_NAME);
  
@@ -993,7 +986,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
    if ((job = cupsdAddJob(priority, printer->name)) == NULL)
    {
      send_ipp_status(con, IPP_INTERNAL_ERROR,
-@@ -1586,6 +1715,32 @@ add_job(cupsd_client_t  *con,           /* I - Cl
+@@ -1576,6 +1705,32 @@ add_job(cupsd_client_t  *con,           /* I - Cl
      return (NULL);
    }
  
@@ -1026,7 +1019,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
    job->dtype   = printer->type & (CUPS_PRINTER_CLASS | CUPS_PRINTER_REMOTE);
    job->attrs   = con->request;
    job->dirty   = 1;
-@@ -1773,6 +1928,29 @@ add_job(cupsd_client_t  *con,           /* I - Cl
+@@ -1763,6 +1918,29 @@ add_job(cupsd_client_t  *con,           /* I - Cl
        ippSetString(job->attrs, &attr, 0, printer->job_sheets[0]);
        ippSetString(job->attrs, &attr, 1, printer->job_sheets[1]);
      }
@@ -1056,7 +1049,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
  
      job->job_sheets = attr;
  
-@@ -1803,6 +1981,9 @@ add_job(cupsd_client_t  *con,            /* I - Cl
+@@ -1793,6 +1971,9 @@ add_job(cupsd_client_t  *con,            /* I - Cl
                                             "job-sheets=\"%s,none\", "
                                             "job-originating-user-name=\"%s\"",
                      Classification, job->username);
@@ -1066,7 +1059,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
        }
        else if (attr->num_values == 2 &&
                 strcmp(attr->values[0].string.text,
-@@ -1821,6 +2002,9 @@ add_job(cupsd_client_t  *con,            /* I - Cl
+@@ -1811,6 +1992,9 @@ add_job(cupsd_client_t  *con,            /* I - Cl
                                             "job-originating-user-name=\"%s\"",
                      attr->values[0].string.text,
                      attr->values[1].string.text, job->username);
@@ -1076,7 +1069,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
        }
        else if (strcmp(attr->values[0].string.text, Classification) &&
                 strcmp(attr->values[0].string.text, "none") &&
-@@ -1841,6 +2025,9 @@ add_job(cupsd_client_t  *con,            /* I - Cl
+@@ -1831,6 +2015,9 @@ add_job(cupsd_client_t  *con,            /* I - Cl
                        "job-originating-user-name=\"%s\"",
                        attr->values[0].string.text,
                        attr->values[1].string.text, job->username);
@@ -1086,7 +1079,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
          }
        }
        else if (strcmp(attr->values[0].string.text, Classification) &&
-@@ -1881,8 +2068,52 @@ add_job(cupsd_client_t  *con,           /* I - Cl
+@@ -1871,8 +2058,52 @@ add_job(cupsd_client_t  *con,           /* I - Cl
                      "job-sheets=\"%s\", "
                      "job-originating-user-name=\"%s\"",
                      Classification, job->username);
@@ -1139,7 +1132,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
  
     /*
      * See if we need to add the starting sheet...
-@@ -3656,6 +3887,128 @@ check_rss_recipient(
+@@ -3648,6 +3879,128 @@ check_rss_recipient(
  }
  
  
@@ -1268,7 +1261,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
  /*
   * 'check_quotas()' - Check quotas for a printer and user.
   */
-@@ -4112,6 +4465,15 @@ copy_banner(cupsd_client_t *con,        /* I -
+@@ -4103,6 +4456,15 @@ copy_banner(cupsd_client_t *con,        /* I -
    char                attrname[255],          /* Name of attribute */
                *s;                     /* Pointer into name */
    ipp_attribute_t *attr;              /* Attribute */
@@ -1284,7 +1277,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
  
  
    cupsdLogMessage(CUPSD_LOG_DEBUG2,
-@@ -4147,6 +4509,85 @@ copy_banner(cupsd_client_t *con,        /* I -
+@@ -4138,6 +4500,85 @@ copy_banner(cupsd_client_t *con,        /* I -
  
    fchmod(cupsFileNumber(out), 0640);
    fchown(cupsFileNumber(out), RunUser, Group);
@@ -1370,7 +1363,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
  
   /*
    * Try the localized banner file under the subdirectory...
-@@ -4241,6 +4682,24 @@ copy_banner(cupsd_client_t *con,        /* I -
+@@ -4232,6 +4673,24 @@ copy_banner(cupsd_client_t *con,        /* I -
        else
          s = attrname;
  
@@ -1395,7 +1388,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
        if (!strcmp(s, "printer-name"))
        {
          cupsFilePuts(out, job->dest);
-@@ -6480,6 +6939,22 @@ get_job_attrs(cupsd_client_t  *con,     /* I
+@@ -6439,6 +6898,22 @@ get_job_attrs(cupsd_client_t  *con,     /* I
  
    exclude = cupsdGetPrivateAttrs(policy, con, printer, job->username);
  
@@ -1418,7 +1411,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
   /*
    * Copy attributes...
    */
-@@ -6877,6 +7352,11 @@ get_jobs(cupsd_client_t  *con,          /* I - C
+@@ -6836,6 +7311,11 @@ get_jobs(cupsd_client_t  *con,          /* I - C
        if (username[0] && _cups_strcasecmp(username, job->username))
        continue;
  
@@ -1430,7 +1423,7 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
        if (count > 0)
        ippAddSeparator(con->response);
  
-@@ -11475,6 +11955,11 @@ validate_user(cupsd_job_t    *job,    /* I
+@@ -11445,6 +11925,11 @@ validate_user(cupsd_job_t    *job,    /* I
  
    strlcpy(username, get_username(con), userlen);
  
@@ -1442,11 +1435,11 @@ diff -up cups-2.2.8/scheduler/ipp.c.lspp cups-2.2.8/scheduler/ipp.c
   /*
    * Check the username against the owner...
    */
-diff -up cups-2.2.8/scheduler/job.c.lspp cups-2.2.8/scheduler/job.c
---- cups-2.2.8/scheduler/job.c.lspp    2018-06-08 17:34:38.657654158 +0200
-+++ cups-2.2.8/scheduler/job.c 2018-06-08 17:34:38.733653554 +0200
-@@ -11,6 +11,9 @@
-  * missing or damaged, see the license at "http://www.cups.org/".
+diff -up cups-2.3.0/scheduler/job.c.lspp cups-2.3.0/scheduler/job.c
+--- cups-2.3.0/scheduler/job.c.lspp    2019-10-07 12:24:43.024597707 +0200
++++ cups-2.3.0/scheduler/job.c 2019-10-07 12:30:13.092210820 +0200
+@@ -8,6 +8,9 @@
+  * information.
   */
  
 +/* Copyright (C) 2005 Trusted Computer Solutions, Inc. */
@@ -1455,7 +1448,7 @@ diff -up cups-2.2.8/scheduler/job.c.lspp cups-2.2.8/scheduler/job.c
  /*
   * Include necessary headers...
   */
-@@ -26,6 +29,14 @@
+@@ -23,6 +26,14 @@
  #  endif /* HAVE_IOKIT_PWR_MGT_IOPMLIBPRIVATE_H */
  #endif /* __APPLE__ */
  
@@ -1470,7 +1463,7 @@ diff -up cups-2.2.8/scheduler/job.c.lspp cups-2.2.8/scheduler/job.c
  
  /*
   * Design Notes for Job Management
-@@ -547,6 +558,14 @@ cupsdContinueJob(cupsd_job_t *job)        /* I
+@@ -544,6 +555,14 @@ cupsdContinueJob(cupsd_job_t *job)        /* I
                                        /* PRINTER_STATE_REASONS env var */
                        rip_max_cache[255];
                                        /* RIP_MAX_CACHE env variable */
@@ -1485,7 +1478,7 @@ diff -up cups-2.2.8/scheduler/job.c.lspp cups-2.2.8/scheduler/job.c
  
  
    cupsdLogMessage(CUPSD_LOG_DEBUG2,
-@@ -1083,6 +1102,67 @@ cupsdContinueJob(cupsd_job_t *job)      /* I
+@@ -1080,6 +1099,67 @@ cupsdContinueJob(cupsd_job_t *job)      /* I
    if (final_content_type[0])
      envp[envc ++] = final_content_type;
  
@@ -1553,7 +1546,7 @@ diff -up cups-2.2.8/scheduler/job.c.lspp cups-2.2.8/scheduler/job.c
    if (Classification && !banner_page)
    {
      if ((attr = ippFindAttribute(job->attrs, "job-sheets",
-@@ -1862,6 +1942,22 @@ cupsdLoadJob(cupsd_job_t *job)          /* I - J
+@@ -1858,6 +1938,22 @@ cupsdLoadJob(cupsd_job_t *job)          /* I - J
        ippSetString(job->attrs, &job->reasons, 0, "none");
    }
  
@@ -1576,7 +1569,7 @@ diff -up cups-2.2.8/scheduler/job.c.lspp cups-2.2.8/scheduler/job.c
    job->impressions = ippFindAttribute(job->attrs, "job-impressions-completed", IPP_TAG_INTEGER);
    job->sheets      = ippFindAttribute(job->attrs, "job-media-sheets-completed", IPP_TAG_INTEGER);
    job->job_sheets  = ippFindAttribute(job->attrs, "job-sheets", IPP_TAG_NAME);
-@@ -2275,6 +2371,14 @@ cupsdSaveJob(cupsd_job_t *job)          /* I - J
+@@ -2273,6 +2369,14 @@ cupsdSaveJob(cupsd_job_t *job)          /* I - J
  {
    char                filename[1024];         /* Job control filename */
    cups_file_t *fp;                    /* Job file */
@@ -1591,7 +1584,7 @@ diff -up cups-2.2.8/scheduler/job.c.lspp cups-2.2.8/scheduler/job.c
  
  
    cupsdLogMessage(CUPSD_LOG_DEBUG2, "cupsdSaveJob(job=%p(%d)): job->attrs=%p",
-@@ -2297,6 +2401,78 @@ cupsdSaveJob(cupsd_job_t *job)          /* I - J
+@@ -2295,6 +2399,78 @@ cupsdSaveJob(cupsd_job_t *job)          /* I - J
  
    fchown(cupsFileNumber(fp), RunUser, Group);
  
@@ -1670,7 +1663,7 @@ diff -up cups-2.2.8/scheduler/job.c.lspp cups-2.2.8/scheduler/job.c
    job->attrs->state = IPP_IDLE;
  
    if (ippWriteIO(fp, (ipp_iocb_t)cupsFileWrite, 1, NULL,
-@@ -3943,6 +4119,19 @@ get_options(cupsd_job_t *job,           /* I - Jo
+@@ -3995,6 +4171,19 @@ get_options(cupsd_job_t *job,           /* I - Jo
          banner_page)
          continue;
  
@@ -1690,7 +1683,7 @@ diff -up cups-2.2.8/scheduler/job.c.lspp cups-2.2.8/scheduler/job.c
       /*
        * Otherwise add them to the list...
        */
-@@ -4704,6 +4893,18 @@ start_job(cupsd_job_t     *job,         /* I -
+@@ -4805,6 +4994,18 @@ start_job(cupsd_job_t     *job,         /* I -
            cupsd_printer_t *printer)   /* I - Printer to print job */
  {
    const char  *filename;              /* Support filename */
@@ -1709,7 +1702,7 @@ diff -up cups-2.2.8/scheduler/job.c.lspp cups-2.2.8/scheduler/job.c
    ipp_attribute_t *cancel_after = ippFindAttribute(job->attrs,
                                                   "job-cancel-after",
                                                   IPP_TAG_INTEGER);
-@@ -4892,6 +5093,113 @@ start_job(cupsd_job_t     *job,                /* I -
+@@ -4993,6 +5194,113 @@ start_job(cupsd_job_t     *job,                /* I -
    fcntl(job->side_pipes[1], F_SETFD,
        fcntl(job->side_pipes[1], F_GETFD) | FD_CLOEXEC);
  
@@ -1823,11 +1816,11 @@ diff -up cups-2.2.8/scheduler/job.c.lspp cups-2.2.8/scheduler/job.c
   /*
    * Now start the first file in the job...
    */
-diff -up cups-2.2.8/scheduler/job.h.lspp cups-2.2.8/scheduler/job.h
---- cups-2.2.8/scheduler/job.h.lspp    2018-06-05 18:06:54.000000000 +0200
-+++ cups-2.2.8/scheduler/job.h 2018-06-08 17:34:38.733653554 +0200
-@@ -11,6 +11,13 @@
-  * missing or damaged, see the license at "http://www.cups.org/".
+diff -up cups-2.3.0/scheduler/job.h.lspp cups-2.3.0/scheduler/job.h
+--- cups-2.3.0/scheduler/job.h.lspp    2019-08-23 17:19:38.000000000 +0200
++++ cups-2.3.0/scheduler/job.h 2019-10-07 12:29:54.364371023 +0200
+@@ -7,6 +7,13 @@
+  * Licensed under Apache License v2.0.  See the file "LICENSE" for more information.
   */
  
 +/* Copyright (C) 2005 Trusted Computer Solutions, Inc. */
@@ -1840,7 +1833,7 @@ diff -up cups-2.2.8/scheduler/job.h.lspp cups-2.2.8/scheduler/job.h
  /*
   * Constants...
   */
-@@ -88,6 +95,10 @@ struct cupsd_job_s                  /**** Job request *
+@@ -84,6 +91,10 @@ struct cupsd_job_s                  /**** Job request *
    int                 progress;       /* Printing progress */
    int                 num_keywords;   /* Number of PPD keywords */
    cups_option_t               *keywords;      /* PPD keywords */
@@ -1851,10 +1844,10 @@ diff -up cups-2.2.8/scheduler/job.h.lspp cups-2.2.8/scheduler/job.h
  };
  
  typedef struct cupsd_joblog_s         /**** Job log message ****/
-diff -up cups-2.2.8/scheduler/main.c.lspp cups-2.2.8/scheduler/main.c
---- cups-2.2.8/scheduler/main.c.lspp   2018-06-08 17:34:38.663654110 +0200
-+++ cups-2.2.8/scheduler/main.c        2018-06-08 17:34:38.734653546 +0200
-@@ -56,6 +56,9 @@
+diff -up cups-2.3.0/scheduler/main.c.lspp cups-2.3.0/scheduler/main.c
+--- cups-2.3.0/scheduler/main.c.lspp   2019-10-07 12:24:43.037597616 +0200
++++ cups-2.3.0/scheduler/main.c        2019-10-07 12:24:43.119597037 +0200
+@@ -57,6 +57,9 @@
  #  include <sys/param.h>
  #endif /* HAVE_SYS_PARAM_H */
  
@@ -1864,7 +1857,7 @@ diff -up cups-2.2.8/scheduler/main.c.lspp cups-2.2.8/scheduler/main.c
  
  /*
   * Local functions...
-@@ -122,6 +125,9 @@ main(int  argc,                            /* I - Number of comm
+@@ -123,6 +126,9 @@ main(int  argc,                            /* I - Number of comm
  #if defined(HAVE_SIGACTION) && !defined(HAVE_SIGSET)
    struct sigaction    action;         /* Actions for POSIX signals */
  #endif /* HAVE_SIGACTION && !HAVE_SIGSET */
@@ -1900,7 +1893,7 @@ diff -up cups-2.2.8/scheduler/main.c.lspp cups-2.2.8/scheduler/main.c
   /*
    * Let the system know we are busy while we bring up cupsd...
    */
-@@ -1188,6 +1213,11 @@ main(int  argc,                         /* I - Number of comm
+@@ -1201,6 +1226,11 @@ main(int  argc,                         /* I - Number of comm
  
    cupsdStopSelect();
  
@@ -1912,11 +1905,11 @@ diff -up cups-2.2.8/scheduler/main.c.lspp cups-2.2.8/scheduler/main.c
    return (!stop_scheduler);
  }
  
-diff -up cups-2.2.8/scheduler/printers.c.lspp cups-2.2.8/scheduler/printers.c
---- cups-2.2.8/scheduler/printers.c.lspp       2018-06-05 18:06:54.000000000 +0200
-+++ cups-2.2.8/scheduler/printers.c    2018-06-08 17:34:38.734653546 +0200
-@@ -11,6 +11,8 @@
-  * missing or damaged, see the license at "http://www.cups.org/".
+diff -up cups-2.3.0/scheduler/printers.c.lspp cups-2.3.0/scheduler/printers.c
+--- cups-2.3.0/scheduler/printers.c.lspp       2019-08-23 17:19:38.000000000 +0200
++++ cups-2.3.0/scheduler/printers.c    2019-10-07 12:29:17.956658129 +0200
+@@ -8,6 +8,8 @@
+  * information.
   */
  
 +/* (c) Copyright 2005-2006 Hewlett-Packard Development Company, L.P. */
@@ -1924,7 +1917,7 @@ diff -up cups-2.2.8/scheduler/printers.c.lspp cups-2.2.8/scheduler/printers.c
  /*
   * Include necessary headers...
   */
-@@ -35,6 +37,10 @@
+@@ -32,6 +34,10 @@
  #  include <asl.h>
  #endif /* __APPLE__ */
  
@@ -1935,7 +1928,7 @@ diff -up cups-2.2.8/scheduler/printers.c.lspp cups-2.2.8/scheduler/printers.c
  
  /*
   * Local functions...
-@@ -2202,6 +2208,13 @@ cupsdSetPrinterAttrs(cupsd_printer_t *p)
+@@ -2252,6 +2258,13 @@ cupsdSetPrinterAttrs(cupsd_printer_t *p)
    ipp_attribute_t *attr;              /* Attribute data */
    char                *name,                  /* Current user/group name */
                *filter;                /* Current filter */
@@ -1948,8 +1941,8 @@ diff -up cups-2.2.8/scheduler/printers.c.lspp cups-2.2.8/scheduler/printers.c
 +#endif /* WITH_LSPP */
  
  
-   DEBUG_printf(("cupsdSetPrinterAttrs: entering name = %s, type = %x\n", p->name,
-@@ -2329,6 +2342,45 @@ cupsdSetPrinterAttrs(cupsd_printer_t *p)
+  /*
+@@ -2378,6 +2391,45 @@ cupsdSetPrinterAttrs(cupsd_printer_t *p)
        attr->values[1].string.text = _cupsStrAlloc(Classification ?
                                           Classification : p->job_sheets[1]);
      }
This page took 0.068676 seconds and 4 git commands to generate.