]> git.pld-linux.org Git - packages/ctop.git/blob - ctop.spec
new
[packages/ctop.git] / ctop.spec
1 %define         vendor_version  0.7.7
2
3 Summary:        Top-like interface for container metrics
4 Name:           ctop
5 Version:        0.7.7
6 Release:        1
7 License:        MIT
8 Group:          Applications/System
9 Source0:        https://github.com/bcicen/ctop/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  9221f9bd69952392c47b8570d2ba25eb
11 Source1:        %{name}-vendor-%{vendor_version}.tar.xz
12 # Source1-md5:  66c94eb62c9a648fb69a2a95cbafa3c3
13 URL:            https://ctop.sh
14 BuildRequires:  golang >= 1.15
15 BuildRequires:  rpmbuild(macros) >= 2.009
16 BuildRequires:  tar >= 1:1.22
17 BuildRequires:  xz
18 ExclusiveArch:  %go_arches
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _debugsource_packages   0
22
23 %description
24 ctop provides a concise and condensed overview of real-time metrics
25 for multiple containers as well as a single container view for
26 inspecting a specific container.
27
28 ctop comes with built-in support for Docker and runC.
29
30 %prep
31 %setup -q -a1
32
33 %{__mv} ctop-%{vendor_version}/vendor .
34
35 %{__mkdir} .go-cache
36
37 %build
38 %__go build -v -mod=vendor -o target/%{name}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 install -d $RPM_BUILD_ROOT%{_bindir}
44
45 cp -p target/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49 %files
50 %defattr(644,root,root,755)
51 %doc README.md
52 %attr(755,root,root) %{_bindir}/%{name}
This page took 0.145958 seconds and 4 git commands to generate.