]> git.pld-linux.org Git - packages/ctl.git/blob - ctl.spec
- added link patch (missing linking with -lImath)
[packages/ctl.git] / ctl.spec
1 Summary:        Color Transform Language libraries
2 Summary(pl.UTF-8):      Biblioteki CTL (języka przekształceń kolorów)
3 Name:           ctl
4 Version:        1.5.2
5 Release:        4
6 License:        BSD + IP clause
7 Group:          Libraries
8 #Source0Download: https://github.com/ampas/CTL/tags
9 Source0:        https://github.com/ampas/CTL/archive/%{name}-%{version}.tar.gz
10 # Source0-md5:  4796bf258d0c66d421c864996482f952
11 Patch0:         %{name}-libdir.patch
12 Patch1:         %{name}-ctlrender.patch
13 Patch2:         %{name}-pc.patch
14 Patch3:         %{name}-openexr-update.patch
15 Patch4:         %{name}-c++17.patch
16 Patch5:         %{name}-link.patch
17 URL:            https://www.oscars.org/science-technology/sci-tech-projects/color-transformation-language
18 BuildRequires:  OpenEXR-devel
19 BuildRequires:  aces_container-devel
20 BuildRequires:  cmake >= 2.8
21 BuildRequires:  ilmbase-devel >= 2.0.0
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtiff-devel
24 BuildRequires:  pkgconfig
25 Requires:       ilmbase >= 2.0.0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 CTL (Color Transform Language) interpreter contains the following C++
30 libraries:
31
32 IlmCtl - CTL interpreter frontend and the interpreter's public
33 programming interface.
34
35 IlmCtlSimd - interpreter's SIMD backend.
36
37 IlmCtlMath - math routines used by IlmCtlSimd: conversions between
38 standard color spaces, 1D and 3D lookup tables, 3D scattered data
39 interpolation.
40
41 %description -l pl.UTF-8
42 Interpreter CTL (Color Transform Language - języka przekształceń
43 kolorów) składa się z następujących bibliotek C++:
44
45 IlmCtl - frontend interpretera CTL i jego publiczny interfejs
46 programistyczny.
47
48 IlmCtlSimd - backend SIMD interpretera.
49
50 IlmCtlMath - funkcje matematyczne wykorzystywane przez IlmCtlSimd:
51 przekształcenia między standardowymi przestrzeniami kolorów, tablice
52 wyszukiwań 1D i 3D, interpolacja zgromadzonych danych 3D.
53
54 %package devel
55 Summary:        Header files for CTL library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CTL
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       ilmbase-devel >= 2.0.0
60 Requires:       libstdc++-devel
61 Obsoletes:      ctl-static < 1.5
62
63 %description devel
64 Header files for CTL library.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe biblioteki CTL.
68
69 %package -n openexr_ctl
70 Summary:        OpenEXR interface to CTL (Color Transform Language)
71 Summary(pl.UTF-8):      Interfejs OpenEXR do CTL (języka przekształceń kolorów)
72 Group:          Libraries
73 Requires:       ctl = %{version}-%{release}
74
75 %description -n openexr_ctl
76 IlmImfCtl provides a simplified OpenEXR interface to CTL (Color
77 Transform Language).
78
79 %description -n openexr_ctl -l pl.UTF-8
80 IlmImfCtl udostępnia uproszczony interfejs OpenEXR do CTL (języka
81 przekształceń kolorów).
82
83 %package -n openexr_ctl-devel
84 Summary:        Header files for IlmInfCtl library
85 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki IlmInfCtl
86 Group:          Development/Libraries
87 Requires:       OpenEXR-devel
88 Requires:       ctl-devel = %{version}-%{release}
89 Requires:       openexr_ctl = %{version}-%{release}
90 Obsoletes:      openexr_ctl-static < 1.1
91
92 %description -n openexr_ctl-devel
93 Header files for IlmInfCtl library.
94
95 %description -n openexr_ctl-devel -l pl.UTF-8
96 Pliki nagłówkowe biblioteki IlmInfCtl.
97
98 %package -n openexr_ctl-progs
99 Summary:        Programs utilizing OpenEXR/CTL interface
100 Summary(pl.UTF-8):      Programy wykorzystujące interfejs OpenEXR/CTL
101 Group:          Applications/Graphics
102 Requires:       openexr_ctl = %{version}-%{release}
103
104 %description -n openexr_ctl-progs
105 Programs utilizing OpenEXR/CTL interface:
106
107 exrdpx is an initial version of a CTL-driven file converter that
108 translates DPX files into OpenEXR files and vice versa. The conversion
109 between the DPX and OpenEXR color spaces is handled by CTL transforms.
110
111 exr_ctl_exr is an initial version of a program that can bake the
112 effect of a series of CTL transforms into the pixels of an OpenEXR
113 file.
114
115 %description -n openexr_ctl-progs -l pl.UTF-8
116 Programy wykorzystujące interfejs OpenEXR/CTL:
117
118 exrdpx to wstępna wersja konwertera plików sterowanego CTL-em,
119 tłumaczącego pliki DPX na OpenEXR i na odwrót. Przekształcenia między
120 przestrzeniami kolorów DPX i OpenEXR są obsługiwane przez
121 przekształcenia CTL.
122
123 exr_ctl_exr to wstępna wersja programu potrafiącego zamienić efekt
124 serii przekształceń CTL na piksele w pliku OpenEXR.
125
126 %package -n ctlrender
127 Summary:        CLI application to apply CTL transforms to an image
128 Summary(pl.UTF-8):      Uruchamiany z linii poleceń program do nakładania przekształceń CTL na obraz
129 Group:          Applications/Graphics
130 Requires:       ctl = %{version}-%{release}
131
132 %description -n ctlrender
133 ctlrender is a command line application for applying CTL transforms to
134 an image using one or more CTL scripts, potentially converting the
135 file format in the process.
136
137 ctlrender supports OpenEXR, TIFF, DPX, and ACES container file
138 formats.
139
140 %description -n ctlrender
141 ctlrender to uruchamiany z linii poleceń program do nakładania
142 przekształceń CTL na obraz przy użyciu jednego lub więcej skryptów
143 CTL, potencjalnie także zmieniając w trakcie format pliku.
144
145 ctlrender obsługuje formaty plików OpenEXR, TIFF, DPX oraz ACES.
146
147 %prep
148 %setup -q -n CTL-%{name}-%{version}
149 %patch0 -p1
150 %patch1 -p1
151 %patch2 -p1
152 %patch3 -p1
153 %patch4 -p1
154 %patch5 -p1
155
156 %build
157 install -d build
158 cd build
159 %cmake .. \
160         -DINSTALL_CMAKE_DIR=%{_libdir}/cmake/CTL \
161         -DINSTALL_LIB_DIR=%{_libdir}
162 %{__make}
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166
167 %{__make} -C build install \
168         DESTDIR=$RPM_BUILD_ROOT
169
170 # packaged as %doc
171 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/CTL
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   -p /sbin/ldconfig
177 %postun -p /sbin/ldconfig
178
179 %files
180 %defattr(644,root,root,755)
181 %doc AUTHORS CHANGELOG LICENSE README.md
182 %attr(755,root,root) %{_libdir}/libIlmCtl.so.*.*.*
183 %attr(755,root,root) %{_libdir}/libIlmCtlMath.so.*.*.*
184 %attr(755,root,root) %{_libdir}/libIlmCtlSimd.so.*.*.*
185 %dir %{_datadir}/CTL
186
187 %files devel
188 %defattr(644,root,root,755)
189 %doc doc/CtlManual.pdf
190 %attr(755,root,root) %{_libdir}/libIlmCtl.so
191 %attr(755,root,root) %{_libdir}/libIlmCtlMath.so
192 %attr(755,root,root) %{_libdir}/libIlmCtlSimd.so
193 %{_includedir}/CTL
194 %{_pkgconfigdir}/CTL.pc
195 %{_libdir}/cmake/CTL
196
197 %files -n openexr_ctl
198 %defattr(644,root,root,755)
199 %doc OpenEXR_CTL/README
200 %attr(755,root,root) %{_libdir}/libIlmImfCtl.so
201
202 %files -n openexr_ctl-devel
203 %defattr(644,root,root,755)
204 #%attr(755,root,root) %{_libdir}/libIlmImfCtl.so
205 %{_includedir}/OpenEXR/ImfCtlApplyTransforms.h
206 %{_pkgconfigdir}/OpenEXR_CTL.pc
207
208 %files -n openexr_ctl-progs
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_bindir}/exr_ctl_exr
211 %attr(755,root,root) %{_bindir}/exrdpx
212 %{_datadir}/CTL/change_saturation.ctl
213 %{_datadir}/CTL/transform_DPX_EXR.ctl
214 %{_datadir}/CTL/transform_EXR_DPX.ctl
215 %{_datadir}/CTL/utilities.ctl
216
217 %files -n ctlrender
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_bindir}/ctlrender
This page took 0.10149 seconds and 4 git commands to generate.