]> git.pld-linux.org Git - packages/cspice.git/blob - cspice.spec
- unconditional noarch subpackages
[packages/cspice.git] / cspice.spec
1 # TODO: build actual tools (for now only library is prepared, for use by other packages)
2 Summary:        ANSI C version of the SPICE Toolkit
3 Summary(pl.UTF-8):      Wersja oprogramowania SPICE Toolkit dla ANSI C
4 Name:           cspice
5 Version:        66
6 Release:        1
7 License:        NASA/CalTech
8 Group:          Libraries
9 # couldn't find pure source distribution, but binary package contains sources as well
10 Source0:        http://naif.jpl.nasa.gov/pub/naif/toolkit/C/PC_Linux_GCC_32bit/packages/cspice.tar.Z
11 # Source0-md5:  35a5e7f8e9501b503b18d94ca8a9da47
12 URL:            https://naif.jpl.nasa.gov/naif/toolkit.html
13 BuildRequires:  libtool
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 ANSI C version of the SPICE Toolkit.
18
19 %description -l pl.UTF-8
20 Wersja oprogramowania SPICE Toolkit dla ANSI C.
21
22 %package devel
23 Summary:        Header files for CSPICE library
24 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CSPICE
25 Group:          Development/Libraries
26 Requires:       %{name} = %{version}-%{release}
27
28 %description devel
29 Header files for CSPICE library.
30
31 %description devel -l pl.UTF-8
32 Pliki nagłówkowe biblioteki CSPICE.
33
34 %package static
35 Summary:        Static CSPICE library
36 Summary(pl.UTF-8):      Statyczna biblioteka CSPICE
37 Group:          Development/Libraries
38 Requires:       %{name}-devel = %{version}-%{release}
39
40 %description static
41 Static CSPICE library.
42
43 %description static -l pl.UTF-8
44 Statyczna biblioteka CSPICE.
45
46 %package doc
47 Summary:        Documentation for CSPICE
48 Summary(pl.UTF-8):      Dokumentacja do CSPICE
49 Group:          Documentation
50 BuildArch:      noarch
51
52 %description doc
53 Documentation for CSPICE.
54
55 %description doc -l pl.UTF-8
56 Dokumentacja do CSPICE.
57
58 %prep
59 %setup -q -n %{name}
60
61 %{__rm} lib/*.a exe/*
62
63 %build
64 cd src/cspice
65
66 for f in *.c ; do
67         libtool --mode=compile %{__cc} %{rpmcflags} %{rpmcppflags} -c $f
68 done
69 libtool --mode=link %{__cc} %{rpmldflags} %{rpmcflags} -o libcspice.la -lm -rpath %{_libdir} *.lo
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
74
75 libtool --mode=install install src/cspice/libcspice.la $RPM_BUILD_ROOT%{_libdir}
76
77 cp -p include/Spice*.h $RPM_BUILD_ROOT%{_includedir}
78
79 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcspice.la
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc doc/{dscriptn.txt,version.txt,whats.new}
90 %attr(755,root,root) %{_libdir}/libcspice.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libcspice.so.0
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libcspice.so
96 %{_includedir}/Spice*.h
97
98 %files static
99 %defattr(644,root,root,755)
100 %{_libdir}/libcspice.a
101
102 %files doc
103 %defattr(644,root,root,755)
104 %doc doc/html/*
This page took 0.085876 seconds and 4 git commands to generate.