]> git.pld-linux.org Git - packages/crosss390x-binutils.git/blob - crosss390x-binutils.spec
- switch to gnu binutils and update to 2.26.1
[packages/crosss390x-binutils.git] / crosss390x-binutils.spec
1 Summary:        Cross S/390 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - S/390 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - S/390 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla S/390 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - S/390 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - S/390 binutils
7 Name:           crosss390x-binutils
8 Version:        2.26.1
9 Release:        1
10 License:        GPL
11 Group:          Development/Tools
12 Source0:        http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  d2b24e5b5301b7ff0207414c34c3e0fb
14 URL:            http://sources.redhat.com/binutils/
15 BuildRequires:  automake
16 BuildRequires:  bash
17 BuildRequires:  bison
18 BuildRequires:  flex
19 ExcludeArch:    s390x
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         target          s390x-pld-linux
23 %define         arch            %{_prefix}/%{target}
24
25 %description
26 Binutils is a collection of binary utilities, including:
27 - ar - create, modify and extract from archives,
28 - nm - lists symbols from object files,
29 - objcopy - copy and translate object files,
30 - objdump - display information from object files,
31 - ranlib - generate an index for the contents of an archive,
32 - size - list the section sizes of an object or archive file,
33 - strings - list printable strings from files,
34 - strip - discard symbols,
35 - c++filt - a filter for demangling encoded C++ symbols,
36 - addr2line - convert addresses to file and line,
37 - nlmconv - convert object code into an NLM.
38
39 This package contains the cross version for S/390.
40
41 %description -l pl.UTF-8
42 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
43 programów. Znajdują się tutaj między innymi assembler, konsolidator
44 (linker), a także inne narzędzia do manipulowania binarnymi plikami
45 programów i bibliotek.
46
47 Ten pakiet zawiera wersję skrośną generującą kod dla S/390.
48
49 %prep
50 %setup -q -n binutils-%{version}
51
52 %build
53 cp /usr/share/automake/config.sub .
54
55 # ldscripts won't be generated properly if SHELL is not bash...
56 CFLAGS="%{rpmcflags} -fno-strict-aliasing" \
57 LDFLAGS="%{rpmldflags}" \
58 CONFIG_SHELL="/bin/bash" \
59 ./configure \
60         --disable-shared \
61         --disable-nls \
62         --prefix=%{_prefix} \
63         --libdir=%{_libdir} \
64         --mandir=%{_mandir} \
65         --infodir=%{_infodir} \
66         --enable-64-bit-bfd \
67         --target=%{target}
68
69 %{__make} all \
70         tooldir=%{_prefix} \
71         EXEEXT=""
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT%{_prefix}
76
77 %{__make} install \
78         prefix=$RPM_BUILD_ROOT%{_prefix} \
79         mandir=$RPM_BUILD_ROOT%{_mandir} \
80         infodir=$RPM_BUILD_ROOT%{_infodir} \
81         libdir=$RPM_BUILD_ROOT%{_libdir}
82
83 # remove these man pages unless we cross-build for win*/netware platforms.
84 # however, this should be done in Makefiles.
85 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc README
93 %attr(755,root,root) %{_bindir}/%{target}-*
94 %dir %{arch}
95 %dir %{arch}/bin
96 %attr(755,root,root) %{arch}/bin/*
97 %dir %{arch}/lib
98 %dir %{arch}/lib/*
99 %{arch}/lib/ldscripts/*
100 %{_mandir}/man?/%{target}-*
This page took 0.113186 seconds and 4 git commands to generate.