]> git.pld-linux.org Git - packages/crossmingw32-pangomm.git/blob - crossmingw32-pangomm.spec
- updated to 2.46.4
[packages/crossmingw32-pangomm.git] / crossmingw32-pangomm.spec
1 Summary:        A C++ interface for pango library - cross MinGW32 version
2 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32
3 Name:           crossmingw32-pangomm
4 Version:        2.46.4
5 Release:        1
6 License:        LGPL v2+
7 Group:          Development/Libraries
8 Source0:        https://download.gnome.org/sources/pangomm/2.46/pangomm-%{version}.tar.xz
9 # Source0-md5:  5947d35899db62813531d7ea8faee60c
10 URL:            https://www.gtkmm.org/
11 BuildRequires:  autoconf >= 2.59
12 BuildRequires:  automake >= 1:1.11
13 BuildRequires:  crossmingw32-cairomm >= 1.12.0
14 BuildRequires:  crossmingw32-gcc-c++ >= 1:4.7
15 BuildRequires:  crossmingw32-glibmm >= 2.48.0
16 BuildRequires:  crossmingw32-pango >= 1.45.1
17 # for gmmproc tools
18 BuildRequires:  glibmm-devel >= 2.46.2
19 BuildRequires:  libtool >= 2:2.0
20 BuildRequires:  mm-common >= 0.9.10
21 BuildRequires:  pkgconfig >= 1:0.15
22 BuildRequires:  rpmbuild(macros) >= 1.446
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Requires:       crossmingw32-cairomm >= 1.12.0
26 Requires:       crossmingw32-gcc-c++ >= 1:4.7
27 Requires:       crossmingw32-glibmm >= 2.48.0
28 Requires:       crossmingw32-pango >= 1.45.1
29 Provides:       crossmingw32-gtkmm-pango
30 Obsoletes:      crossmingw32-gtkmm-pango < 2.14
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         no_install_post_strip   1
34 %define         _enable_debug_packages  0
35
36 %define         target                  i386-mingw32
37 %define         target_platform         i386-pc-mingw32
38
39 %define         _sysprefix              /usr
40 %define         _prefix                 %{_sysprefix}/%{target}
41 %define         _libdir                 %{_prefix}/lib
42 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
43 %define         _dlldir                 /usr/share/wine/windows/system
44 %define         __cc                    %{target}-gcc
45 %define         __cxx                   %{target}-g++
46 %define         __pkgconfig_provides    %{nil}
47 %define         __pkgconfig_requires    %{nil}
48
49 %define         _ssp_cflags             %{nil}
50 %ifnarch %{ix86}
51 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
52 %define         optflags        -O2
53 %endif
54 # -z options are invalid for mingw linker, most of -f options are Linux-specific
55 %define         filterout_ld    -Wl,-z,.*
56 %define         filterout_c     -f[-a-z0-9=]*
57
58 %description
59 A C++ interface for pango library - cross MinGW32 version.
60
61 %description -l pl.UTF-8
62 Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32.
63
64 %package static
65 Summary:        Static pangomm library (cross MinGW32 version)
66 Summary(pl.UTF-8):      Statyczna biblioteka pangomm (wersja skrośna MinGW32)
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Provides:       crossmingw32-gtkmm-pango-static
70 Obsoletes:      crossmingw32-gtkmm-pango-static < 2.14
71
72 %description static
73 Static pangomm library (cross MinGW32 version).
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka pangomm (wersja skrośna MinGW32).
77
78 %package dll
79 Summary:        DLL pangomm library for Windows
80 Summary(pl.UTF-8):      Biblioteka DLL pangomm dla Windows
81 Group:          Applications/Emulators
82 Requires:       crossmingw32-cairomm-dll >= 1.12.0
83 Requires:       crossmingw32-glibmm-dll >= 2.48.0
84 Requires:       crossmingw32-pango-dll >= 1.45.1
85 Requires:       wine
86 Provides:       crossmingw32-gtkmm-pango-dll
87 Obsoletes:      crossmingw32-gtkmm-pango-dll < 2.14
88
89 %description dll
90 DLL pangomm library for Windows.
91
92 %description dll -l pl.UTF-8
93 Biblioteka DLL pangomm dla Windows.
94
95 %prep
96 %setup -q -n pangomm-%{version}
97
98 %build
99 # use host gmmprocdir (before changing PKG_CONFIG_LIBDIR to cross target)
100 # note: rpm.org sets PKG_CONFIG_PATH according to _libdir and _datadir
101 GMMPROC_DIR=$(PKG_CONFIG_PATH=%{_sysprefix}/%{_lib}/pkgconfig pkg-config --variable=gmmprocdir glibmm-2.4)
102 export PKG_CONFIG_PATH=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
103 mm-common-prepare --copy --force
104 %{__libtoolize}
105 %{__aclocal} -I build
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 # std-threads required by glibmm requires at least WinXP API
110 CPPFLAGS="%{rpmcppflags} -DWINVER=0x0501"
111 %configure \
112         --target=%{target} \
113         --host=%{target} \
114         --disable-documentation \
115         --enable-maintainer-mode \
116         --disable-silent-rules \
117         --enable-static
118
119 %{__make} \
120         GMMPROC_DIR="$GMMPROC_DIR"
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 install -d $RPM_BUILD_ROOT%{_dlldir}
129 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
130
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libpangomm-*.la
132
133 %if 0%{!?debug:1}
134 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
135 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
136 %endif
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %doc ChangeLog NEWS README.md
144 %{_libdir}/libpangomm-1.4.dll.a
145 %{_libdir}/pangomm-1.4
146 %{_includedir}/pangomm-1.4
147 %{_pkgconfigdir}/pangomm-1.4.pc
148
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libpangomm-1.4.a
152
153 %files dll
154 %defattr(644,root,root,755)
155 %{_dlldir}/libpangomm-1.4-1.dll
This page took 0.128888 seconds and 4 git commands to generate.