]> git.pld-linux.org Git - packages/crossmingw32-bzip2.git/blob - crossmingw32-bzip2.spec
- updated to 1.0.8
[packages/crossmingw32-bzip2.git] / crossmingw32-bzip2.spec
1 %define         realname                bzip2
2 Summary:        Extremely powerful file compression utility - MinGW32 cross version
3 Summary(es.UTF-8):      Un compresor de archivos con un nuevo algoritmo
4 Summary(fr.UTF-8):      Utilitaire de compression de fichier extrêmement puissant
5 Summary(pl.UTF-8):      Kompresor plików bzip2 - wersja skrośna dla MinGW32
6 Summary(pt_BR.UTF-8):   Compactador de arquivo extremamente poderoso
7 Summary(uk.UTF-8):      Компресор файлів на базі алгоритму блочного сортування
8 Summary(ru.UTF-8):      Компрессор файлов на основе алгоритма блочной сортировки
9 Name:           crossmingw32-%{realname}
10 Version:        1.0.8
11 Release:        1
12 License:        BSD-like
13 Group:          Applications/Archiving
14 Source0:        https://sourceware.org/pub/bzip2/%{realname}-%{version}.tar.gz
15 # Source0-md5:  67e051268d0c475ea773822f7500d0e5
16 Patch0:         %{name}.patch
17 URL:            https://sourceware.org/bzip2/
18 BuildRequires:  crossmingw32-gcc
19 Requires:       crossmingw32-runtime
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         no_install_post_strip   1
23
24 %define         target                  i386-mingw32
25 %define         target_platform         i386-pc-mingw32
26
27 %define         _sysprefix              /usr
28 %define         _prefix                 %{_sysprefix}/%{target}
29 %define         _libdir                 %{_prefix}/lib
30 %define         _dlldir                 /usr/share/wine/windows/system
31 %define         __cc                    %{target}-gcc
32 %define         __cxx                   %{target}-g++
33
34 %ifnarch %{ix86}
35 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
36 %define         optflags        -O2
37 %endif
38 # -z options are invalid for mingw linker, most of -f options are Linux-specific
39 %define         filterout_ld    -Wl,-z,.*
40 %define         filterout_c     -f[-a-z0-9=]*
41
42 %description
43 Bzip2 compresses files using the Burrows-Wheeler block-sorting text
44 compression algorithm, and Huffman coding. Compression is generally
45 considerably better than that achieved by more conventional
46 LZ77/LZ78-based compressors, and approaches the performance of the PPM
47 family of statistical compressors. The command-line options are
48 deliberately very similar to those of GNU Gzip, but they are not
49 identical.
50
51 %description -l es.UTF-8
52 Bzip2 es un programa de compresión/descompresión. Típicamente el
53 archivo compactado queda entre 20 la 30 por ciento menor de que se
54 fuera compactado con gzip. Observa que bzip2 no entiende los archivos
55 del bzip original, ni los archivos del gzip.
56
57 %description -l fr.UTF-8
58 Bzip2 compresse des fichiers en utilisant l'algorithme de compression
59 en tri de blocks de texte Burrows-Wheeler, et le codage Huffman. La
60 compression est considérablement meilleure que celle effectuée par les
61 plus conventionels compresseurs basés sur LZ77/LZ78, et approche la
62 performance de la famille PPM de compresseurs statistiques.
63
64 %description -l pl.UTF-8
65 Kompresor bzip2 używa algorytmu Burrows-Wheelera do kompresji danych i
66 metody Huffmana do ich kodowania. Kompresja pliku czy archiwum tar
67 jest z reguły lepsza niż w przypadku stosowania klasycznych
68 kompresorów LZ77/LZ78. Opcje linii poleceń są bardzo podobne do
69 poleceń GNU Gzip ale nie są identyczne.
70
71 %description -l pt_BR.UTF-8
72 Bzip2 é um programa de compressão/descompressão. Tipicamente o arquivo
73 compactado fica 20 a 30 por cento menor do que se fosse compactado com
74 o gzip.
75
76 Note que o bzip2 não entende os arquivos do bzip original, nem os
77 arquivos do gzip.
78
79 %description -l ru.UTF-8
80 bzip2 компрессирует файлы используя компрессирующий текстовый алгоритм
81 блочной сортировки Burrows-Wheeler и кодирование Huffman'а.
82 Достигаемая компрессия обычно существенно лучше достигаемой более
83 привычными компрессорами на основе LZ77/LZ78 и приближается к той,
84 которую обеспечивает семейство статистических компрессоров PPM.
85
86 %description -l uk.UTF-8
87 bzip2 компресує файли використовуючи текстовий алгоритм блочного
88 сортування Burrows-Wheeler та кодування Huffman'а. Компресія, яка
89 досягається bzip2, як правило краща за ту, що забезпечують
90 розповсюджені компресори на базі LZ77/LZ78 і наближається до тої, що
91 її забезпечує сімейство статистичних компресорів PPM.
92
93 %package static
94 Summary:        Static bzip2 library (cross MinGW32 version)
95 Summary(pl.UTF-8):      Statyczna biblioteka bzip2 (wersja skrośna MinGW32)
96 Group:          Development/Libraries
97 Requires:       %{name} = %{version}-%{release}
98
99 %description static
100 Static bzip2 library (cross MinGW32 version).
101
102 %description static -l pl.UTF-8
103 Statyczna biblioteka bzip2 (wersja skrośna MinGW32).
104
105 %package dll
106 Summary:        %{realname} - DLL library for Windows
107 Summary(pl.UTF-8):      %{realname} - biblioteka DLL dla Windows
108 Group:          Applications/Emulators
109
110 %description dll
111 %{realname} - DLL library for Windows.
112
113 %description dll -l pl.UTF-8
114 %{realname} - biblioteka DLL dla Windows.
115
116 %prep
117 %setup -q -n %{realname}-%{version}
118 %patch0 -p1
119
120 %build
121 %{__make} \
122         AR="%{target}-ar" \
123         RANLIB="%{target}-ranlib" \
124         CC="%{__cc}" \
125         CFLAGS="%{rpmcflags} -Wall \$(BIGFILES)"
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{_dlldir}}
130
131 install *.h $RPM_BUILD_ROOT%{_includedir}
132 install *.a $RPM_BUILD_ROOT%{_libdir}
133 install *.dll $RPM_BUILD_ROOT%{_dlldir}
134
135 %if 0%{!?debug:1}
136 %{target}-strip $RPM_BUILD_ROOT%{_dlldir}/*.dll
137 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
138 %endif
139
140 # for compatibility
141 ln -sf libbz2.a $RPM_BUILD_ROOT%{_libdir}/libbzip2.a
142 ln -sf libbz2.dll.a $RPM_BUILD_ROOT%{_libdir}/libbzip2.dll.a
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files
148 %defattr(644,root,root,755)
149 %{_libdir}/libbz2.dll.a
150 %{_libdir}/libbzip2.dll.a
151 %{_includedir}/bzlib*.h
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libbz2.a
156 %{_libdir}/libbzip2.a
157
158 %files dll
159 %defattr(644,root,root,755)
160 %{_dlldir}/bzip2.dll
This page took 0.056823 seconds and 3 git commands to generate.