]> git.pld-linux.org Git - packages/crossmingw32-atkmm.git/blob - crossmingw32-atkmm.spec
- updated to 2.28.4
[packages/crossmingw32-atkmm.git] / crossmingw32-atkmm.spec
1 Summary:        A C++ interface for atk library - cross MinGW32 version
2 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki atk - wersja skrośna MinGW32
3 Name:           crossmingw32-atkmm
4 Version:        2.28.4
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Development/Libraries
8 Source0:        https://download.gnome.org/sources/atkmm/2.28/atkmm-%{version}.tar.xz
9 # Source0-md5:  e0f7271990c89a6c9987f215ba47bfc5
10 URL:            https://www.gtkmm.org/
11 BuildRequires:  autoconf >= 2.59
12 BuildRequires:  automake >= 1:1.9
13 BuildRequires:  crossmingw32-atk >= 2.18.0
14 BuildRequires:  crossmingw32-gcc-c++ >= 1:4.7
15 BuildRequires:  crossmingw32-glibmm >= 2.46.2
16 # for gmmproc tools
17 BuildRequires:  glibmm-devel >= 2.46.2
18 BuildRequires:  libtool >= 2:2.0
19 BuildRequires:  mm-common >= 0.9.10
20 BuildRequires:  pkgconfig >= 1:0.15
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       crossmingw32-atk >= 2.18.0
24 Requires:       crossmingw32-gcc-c++ >= 1:4.7
25 Requires:       crossmingw32-glibmm >= 2.46.2
26 Provides:       crossmingw32-gtkmm-atk
27 Obsoletes:      crossmingw32-gtkmm-atk < 2.22.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         no_install_post_strip   1
31 %define         _enable_debug_packages  0
32
33 %define         target                  i386-mingw32
34 %define         target_platform         i386-pc-mingw32
35
36 %define         _sysprefix              /usr
37 %define         _prefix                 %{_sysprefix}/%{target}
38 %define         _libdir                 %{_prefix}/lib
39 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
40 %define         _dlldir                 /usr/share/wine/windows/system
41 %define         __cc                    %{target}-gcc
42 %define         __cxx                   %{target}-g++
43 %define         __pkgconfig_provides    %{nil}
44 %define         __pkgconfig_requires    %{nil}
45
46 %define         _ssp_cflags             %{nil}
47 %ifnarch %{ix86}
48 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
49 %define         optflags        -O2
50 %endif
51 # -z options are invalid for mingw linker, most of -f options are Linux-specific
52 %define         filterout_ld    -Wl,-z,.*
53 %define         filterout_c             -f[-a-z0-9=]*
54
55 %description
56 A C++ interface for atk library - cross MinGW32 version.
57
58 %description -l pl.UTF-8
59 Interfejs C++ dla biblioteki atk - wersja skrośna MinGW32.
60
61 %package static
62 Summary:        Static atkmm library (cross MinGW32 version)
63 Summary(pl.UTF-8):      Statyczna biblioteka atkmm (wersja skrośna MinGW32)
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Provides:       crossmingw32-gtkmm-atk-static
67 Obsoletes:      crossmingw32-gtkmm-atk-static < 2.22.0
68
69 %description static
70 Static atkmm library (cross MinGW32 version).
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka atkmm (wersja skrośna MinGW32).
74
75 %package dll
76 Summary:        DLL atkmm library for Windows
77 Summary(pl.UTF-8):      Biblioteka DLL atkmm dla Windows
78 Group:          Applications/Emulators
79 Requires:       crossmingw32-atk-dll >= 2.18.0
80 Requires:       crossmingw32-glibmm-dll >= 2.46.2
81 Requires:       wine
82 Provides:       crossmingw32-gtkmm-atk-dll
83 Obsoletes:      crossmingw32-gtkmm-atk-dll < 2.22.0
84
85 %description dll
86 DLL atkmm library for Windows.
87
88 %description dll -l pl.UTF-8
89 Biblioteka DLL atkmm dla Windows.
90
91 %prep
92 %setup -q -n atkmm-%{version}
93
94 %build
95 # use host gmmprocdir (before changing PKG_CONFIG_LIBDIR to cross target)
96 # note: rpm.org sets PKG_CONFIG_PATH according to _libdir and _datadir
97 GMMPROC_DIR=$(PKG_CONFIG_PATH=%{_sysprefix}/%{_lib}/pkgconfig pkg-config --variable=gmmprocdir glibmm-2.4)
98 export PKG_CONFIG_PATH=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
99 mm-common-prepare --copy --force
100 %{__libtoolize}
101 %{__aclocal} -I build
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 # std-threads required by glibmm requires at least WinXP API
106 CPPFLAGS="%{rpmcppflags} -DWINVER=0x0501"
107 %configure \
108         --target=%{target} \
109         --host=%{target} \
110         --disable-documentation \
111         --enable-maintainer-mode \
112         --disable-silent-rules \
113         --enable-static
114
115 %{__make} \
116         GMMPROC_DIR="$GMMPROC_DIR"
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install -d $RPM_BUILD_ROOT%{_dlldir}
125 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
126
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libatkmm-*.la
128
129 %if 0%{!?debug:1}
130 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
131 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
132 %endif
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc ChangeLog NEWS README.md
140 %{_libdir}/libatkmm-1.6.dll.a
141 %{_libdir}/atkmm-1.6
142 %{_includedir}/atkmm-1.6
143 %{_pkgconfigdir}/atkmm-1.6.pc
144
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libatkmm-1.6.a
148
149 %files dll
150 %defattr(644,root,root,755)
151 %{_dlldir}/libatkmm-1.6-1.dll
This page took 0.064591 seconds and 4 git commands to generate.