]> git.pld-linux.org Git - packages/crossavr-binutils.git/blob - crossavr-binutils.spec
- release 2 (x32 rebuild)
[packages/crossavr-binutils.git] / crossavr-binutils.spec
1 Summary:        Cross AVR GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - AVR binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - AVR binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla AVR - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - AVR binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - AVR binutils
7 Name:           crossavr-binutils
8 Version:        2.23.1
9 Release:        2
10 Epoch:          1
11 License:        GPL v3+
12 Group:          Development/Tools
13 Source0:        http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
14 # Source0-md5:  33adb18c3048d057ac58d07a3f1adb38
15 Patch0:         am.patch
16 # Patches 1xx are taken form Atmel official AVR8-GNU toolchain version 3.4.2
17 # http://distribute.atmel.no/tools/opensource/Atmel-AVR-Toolchain-3.4.2/avr/avr-patches.tar.gz
18 Patch100:       001-xmega-Makefile_am-typo.patch
19 Patch101:       002-tinycore-support.patch
20 Patch102:       003-RMW-insn-constriant.patch
21 Patch103:       004-new-part-supports.patch
22 Patch104:       005-additional-part-supports.patch
23 Patch105:       006-xmega-showuage-typo.patch
24 Patch106:       007-ata6289-architecture-correction.patch
25 Patch107:       008-add-usersig-section.patch
26 Patch108:       009-dwarf-relax-fix.patch
27 Patch109:       010-disable-demand-paging.patch
28 Patch110:       200-binutils-avr-size.patch
29 Patch111:       201-binutils-dwarf2-AVRStudio-workaround.patch
30 Patch112:       202-binutils-bug13113.patch
31 Patch113:       400-binutils-atmxt336s.patch
32 Patch114:       401-binutils-atmega48hvf.patch
33 Patch115:       402-binutils-atmega26hvg.patch
34 Patch116:       403-binutils-atmxt224_224e.patch
35 Patch117:       404-binutils-atmxt112sl.patch
36 Patch118:       405-binutils-atmxt540s.patch
37 Patch119:       406-binutils-ata5831.patch
38 Patch120:       407-binutils-attiny841.patch
39 Patch121:       408-binutils-atmegarfa2.patch
40 Patch122:       409-binutils-ata5790n.patch
41 Patch123:       410-binutils-atmega64hve2.patch
42 Patch124:       411-binutils-attiny474.patch
43 Patch125:       412-binutils-atmxts200.patch
44 Patch126:       500-binutils-avrtc530-backported.patch
45 URL:            http://sources.redhat.com/binutils/
46 BuildRequires:  autoconf >= 2.64
47 BuildRequires:  automake >= 1:1.9
48 BuildRequires:  bash
49 BuildRequires:  bison
50 BuildRequires:  flex
51 BuildRequires:  gettext-tools
52 BuildRequires:  gcc-c++
53 BuildRequires:  perl-tools-pod
54 BuildRequires:  texinfo
55 %ifarch sparc sparc32
56 BuildRequires:  sparc32
57 %endif
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         target          avr
61 %define         archprefix      %{_prefix}/%{target}
62 %define         archbindir      %{archprefix}/bin
63 %define         archlibdir      %{archprefix}/lib
64
65 %description
66 Binutils is a collection of binary utilities, including:
67 - ar - create, modify and extract from archives,
68 - nm - lists symbols from object files,
69 - objcopy - copy and translate object files,
70 - objdump - display information from object files,
71 - ranlib - generate an index for the contents of an archive,
72 - size - list the section sizes of an object or archive file,
73 - strings - list printable strings from files,
74 - strip - discard symbols,
75 - c++filt - a filter for demangling encoded C++ symbols,
76 - addr2line - convert addresses to file and line.
77
78 This package contains the cross version for Atmel AVR.
79
80 %description -l pl.UTF-8
81 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
82 programów. Znajdują się tutaj między innymi assembler, konsolidator
83 (linker), a także inne narzędzia do manipulowania binarnymi plikami
84 programów i bibliotek.
85
86 Ten pakiet zawiera wersję skrośną generującą kod dla Atmel AVR.
87
88 %prep
89 %setup -q -n binutils-%{version}
90 %patch0 -p1
91 %patch100 -p0
92 %patch101 -p0
93 %patch102 -p0
94 %patch103 -p0
95 %patch104 -p0
96 %patch105 -p0
97 %patch106 -p0
98 %patch107 -p0
99 %patch108 -p0
100 %patch109 -p0
101 %patch110 -p0
102 %patch111 -p0
103 %patch112 -p0
104 %patch113 -p0
105 %patch114 -p0
106 %patch115 -p0
107 %patch116 -p0
108 %patch117 -p0
109 %patch118 -p0
110 %patch119 -p0
111 %patch120 -p0
112 %patch121 -p0
113 %patch122 -p0
114 %patch123 -p0
115 %patch124 -p0
116 %patch125 -p0
117 %patch126 -p0
118
119 # Remove hacks for specific autoconf version.
120 echo > config/override.m4
121
122 %build
123 %{__aclocal}
124 %{__autoconf}
125 for subdir in bfd binutils ld; do
126         cd $subdir
127         %{__aclocal} -I.. -I../bfd -I../config
128         %{__automake}
129         %{__autoconf}
130         cd -
131 done
132
133 # ldscripts won't be generated properly if SHELL is not bash...
134 CFLAGS="%{rpmcflags}" \
135 LDFLAGS="%{rpmldflags}" \
136 CONFIG_SHELL="/bin/bash" \
137 ./configure \
138         MAKEINFO=/bin/true \
139         --prefix=%{_prefix} \
140         --libdir=%{_libdir} \
141         --mandir=%{_mandir} \
142         --infodir=%{_infodir} \
143         --host=%{_target_platform} \
144         --build=%{_target_platform} \
145         --target=%{target} \
146         --enable-gold \
147         --disable-shared \
148         --disable-werror
149
150 # We have to regenerate headers after patching.
151 %{__make} configure-host \
152         tooldir=%{_prefix} \
153         EXEEXT=""
154
155 %{__make} -C bfd headers \
156         tooldir=%{_prefix} \
157         EXEEXT=""
158
159 %{__make} all \
160         tooldir=%{_prefix} \
161         EXEEXT=""
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165 install -d $RPM_BUILD_ROOT%{_prefix}
166
167 %{__make} install \
168         MAKEINFO=/bin/true \
169         prefix=$RPM_BUILD_ROOT%{_prefix} \
170         mandir=$RPM_BUILD_ROOT%{_mandir} \
171         infodir=$RPM_BUILD_ROOT%{_infodir} \
172         libdir=$RPM_BUILD_ROOT%{_libdir}
173
174 # remove these man pages unless we cross-build for win*/netware platforms.
175 # however, this should be done in Makefiles.
176 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windmc,*windres}.1
177
178 # rely on system locales and info documentation
179 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}
180 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
181
182 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libiberty.a
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %files
188 %defattr(644,root,root,755)
189 %doc README
190 %attr(755,root,root) %{_bindir}/%{target}-addr2line
191 %attr(755,root,root) %{_bindir}/%{target}-ar
192 %attr(755,root,root) %{_bindir}/%{target}-as
193 %attr(755,root,root) %{_bindir}/%{target}-c++filt
194 %attr(755,root,root) %{_bindir}/%{target}-elfedit
195 %attr(755,root,root) %{_bindir}/%{target}-gprof
196 %attr(755,root,root) %{_bindir}/%{target}-ld
197 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
198 %attr(755,root,root) %{_bindir}/%{target}-nm
199 %attr(755,root,root) %{_bindir}/%{target}-objcopy
200 %attr(755,root,root) %{_bindir}/%{target}-objdump
201 %attr(755,root,root) %{_bindir}/%{target}-ranlib
202 %attr(755,root,root) %{_bindir}/%{target}-readelf
203 %attr(755,root,root) %{_bindir}/%{target}-size
204 %attr(755,root,root) %{_bindir}/%{target}-strings
205 %attr(755,root,root) %{_bindir}/%{target}-strip
206 %dir %{archprefix}
207 %dir %{archbindir}
208 %attr(755,root,root) %{archbindir}/ar
209 %attr(755,root,root) %{archbindir}/as
210 %attr(755,root,root) %{archbindir}/ld
211 %attr(755,root,root) %{archbindir}/ld.bfd
212 %attr(755,root,root) %{archbindir}/nm
213 %attr(755,root,root) %{archbindir}/objcopy
214 %attr(755,root,root) %{archbindir}/objdump
215 %attr(755,root,root) %{archbindir}/ranlib
216 %attr(755,root,root) %{archbindir}/strip
217 %dir %{archlibdir}
218 %{archlibdir}/ldscripts
219 %{_mandir}/man1/%{target}-addr2line.1*
220 %{_mandir}/man1/%{target}-ar.1*
221 %{_mandir}/man1/%{target}-as.1*
222 %{_mandir}/man1/%{target}-c++filt.1*
223 %{_mandir}/man1/%{target}-elfedit.1*
224 %{_mandir}/man1/%{target}-gprof.1*
225 %{_mandir}/man1/%{target}-ld.1*
226 %{_mandir}/man1/%{target}-nm.1*
227 %{_mandir}/man1/%{target}-objcopy.1*
228 %{_mandir}/man1/%{target}-objdump.1*
229 %{_mandir}/man1/%{target}-ranlib.1*
230 %{_mandir}/man1/%{target}-readelf.1*
231 %{_mandir}/man1/%{target}-size.1*
232 %{_mandir}/man1/%{target}-strings.1*
233 %{_mandir}/man1/%{target}-strip.1*
This page took 0.09819 seconds and 4 git commands to generate.