]> git.pld-linux.org Git - packages/crmsh.git/blob - crmsh.spec
- fix shebangs
[packages/crmsh.git] / crmsh.spec
1 #
2 # Note: This is not noarch, as it has %{_libdir} etc. hardcoded in *.py files
3 %define         _enable_debug_packages  0
4 #
5 Summary:        Pacemaker command line interface for management and configuration
6 Summary(pl.UTF-8):      Interfejs linii poleceń do zarządzania i konfiguracji Pacemakera
7 Name:           crmsh
8 Version:        3.0.0
9 Release:        2
10 License:        GPL v2+
11 Group:          Applications/System
12 #Source0Download: https://github.com/ClusterLabs/crmsh/releases
13 Source0:        https://github.com/ClusterLabs/crmsh/archive/%{version}/crmsh-%{version}.tar.gz
14 # Source0-md5:  ff41cc2f4abf4498ea55fe033eb854f3
15 Patch0:         %{name}-awk.patch
16 URL:            http://crmsh.github.io/
17 BuildRequires:  asciidoc
18 BuildRequires:  autoconf >= 2.53
19 BuildRequires:  automake
20 BuildRequires:  docbook-dtd45-xml
21 BuildRequires:  python >= 1:2.6
22 BuildRequires:  python-modules >= 1:2.6
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  sed >= 4.0
25 Requires:       cluster-glue
26 Requires:       pacemaker >= 1.1.11
27 Provides:       pacemaker-shell
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Pacemaker command line interface for management and configuration.
32
33 Contains the 'crm' utility which was part of Pacemaker < 1.1.8.
34
35 %description -l pl.UTF-8
36 Interfejs linii poleceń do zarządzania i konfiguracji Pacemakera.
37
38 Zawiera polecenie "crm", które było częścią Pacemakera < 1.1.8.
39
40 %prep
41 %setup -q
42 %patch0 -p1
43
44 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
45       utils/crm_clean.py \
46       utils/crm_pkg.py \
47       utils/crm_rpmcheck.py \
48       scripts/check-uptime/*.py \
49       scripts/health/*.py \
50       bin/crm
51
52 %build
53 %{__aclocal}
54 %{__autoconf}
55 %{__automake}
56 %configure \
57         PYTHON=%{__python}
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
67 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
68 # can we py_postclean?
69
70 # packaged as %doc
71 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
72 # tests
73 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/tests
74 # reduntant
75 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/crmsh/install_files.txt
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc AUTHORS ChangeLog README.md TODO doc/*.html
83 %dir /etc/crm
84 %config(noreplace) %verify(not md5 mtime size) /etc/crm/crm.conf
85 %attr(755,root,root) %{_bindir}/crm
86 %{py_sitedir}/crmsh
87 %{py_sitedir}/crmsh-%{version}-py*.egg-info
88 %{_datadir}/%{name}
89 %{_mandir}/man8/crm.8*
90 %{_mandir}/man8/crmsh_hb_report.8*
This page took 0.154624 seconds and 4 git commands to generate.