]> git.pld-linux.org Git - packages/createrepo_c.git/blame - createrepo_c.spec
up to 1.1.0
[packages/createrepo_c.git] / createrepo_c.spec
CommitLineData
cb0b4095 1# TODO:
cb0b4095 2# - drpm support?
eb85e3be
JB
3#
4# Conditional build:
d04b5509
JR
5%bcond_with rpm5 # build with rpm5, tests may fail (rpm.org vs rpm5 compat problems?)
6%bcond_without tests # make tests
7ab42891 7
eb85e3be
JB
8Summary: Creates a common metadata repository
9Summary(pl.UTF-8): Tworzenie wspólnego repozytorium metadanych
10Name: createrepo_c
2d88101e 11Version: 1.1.0
6c555e93 12Release: 1
eb85e3be
JB
13License: GPL v2+
14Group: Applications/System
807f0e8d
JB
15#Source0Download: https://github.com/rpm-software-management/createrepo_c/releases
16Source0: https://github.com/rpm-software-management/createrepo_c/archive/%{version}/%{name}-%{version}.tar.gz
2d88101e 17# Source0-md5: c79963bca76c1ddbd954d96e858f550d
eb85e3be 18Patch0: %{name}-rpm5.patch
807f0e8d 19URL: https://github.com/rpm-software-management/createrepo_c
e2180175 20BuildRequires: bash-completion-devel >= 1:2.0
eb85e3be 21BuildRequires: bzip2-devel
6c555e93 22BuildRequires: cmake >= 2.8.12
eb85e3be
JB
23BuildRequires: curl-devel
24BuildRequires: doxygen
cb0b4095 25#BuildRequires: drpm-devel
eb85e3be 26BuildRequires: glib2-devel >= 1:2.22.0
e2180175 27BuildRequires: libmodulemd-devel
eb85e3be
JB
28BuildRequires: libxml2-devel >= 2
29BuildRequires: openssl-devel
6c555e93 30BuildRequires: pkgconfig
eb85e3be 31%{?with_tests:BuildRequires: python-nose}
807f0e8d 32BuildRequires: python3-devel >= 1:3.2
6a19adf5 33BuildRequires: python3-modules
807f0e8d 34%{?with_tests:BuildRequires: python3-nose}
4bb7343f 35BuildRequires: python3-setuptools
88265fc4 36BuildRequires: rpm-build >= 4.6
d04b5509 37BuildRequires: rpm-devel
eb85e3be 38BuildRequires: rpm-pythonprov
7fe79feb 39BuildRequires: rpmbuild(macros) >= 1.673
e2180175 40BuildRequires: sphinx-pdg
845faf14 41BuildRequires: sqlite3-devel >= 3.6.18
eb85e3be 42BuildRequires: xz-devel
e2180175 43BuildRequires: zchunk-devel
eb85e3be 44BuildRequires: zlib-devel
1cd780f3 45BuildRequires: zstd-devel
317621c2 46%{?with_tests:BuildRequires: zchunk}
eb85e3be
JB
47Requires: %{name}-libs = %{version}-%{release}
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51C implementation of Createrepo. This utility will generate a common
52metadata repository from a directory of RPM packages.
53
54%description -l pl.UTF-8
55Implementacja w C programu Createrepo. To narzędzie generuje wspólne
56repozytorium metadanych z katalogu pakietów RPM.
57
58%package libs
59Summary: Library for repodata manipulation
60Summary(pl.UTF-8): Biblioteka do operacji na danych repozytorium
61Group: Libraries
62Requires: glib2 >= 1:2.22.0
845faf14 63Requires: sqlite3-libs >= 3.6.18
eb85e3be
JB
64
65%description libs
66This package contains the createrepo_c library for applications to
67easy manipulate with a repodata.
68
69%description libs -l pl.UTF-8
70Ten pakiet zawiera bibliotekę createrepo_c, pozwalającą aplikacjom na
71łatwe operowanie na danych repozytorium (repodata).
72
73%package devel
74Summary: Header files for createrepo_c library
75Summary(pl.UTF-8): Pliki nagłówkowe biblioteki createrepo_c
76Group: Development/Libraries
77Requires: %{name}-libs = %{version}-%{release}
78Requires: bzip2-devel
79Requires: curl-devel
80Requires: expat-devel
81Requires: glib2-devel >= 1:2.22.0
eb85e3be 82Requires: libxml2-devel >= 2
d04b5509 83Requires: rpm-devel
845faf14 84Requires: sqlite3-devel >= 3.6.18
eb85e3be
JB
85Requires: xz-devel
86Requires: zlib-devel
1cd780f3 87Requires: zstd-devel
eb85e3be
JB
88
89%description devel
90This package contains the createrepo_c C header files. These
91development files are for easy manipulation with a repodata.
92
93%description devel -l pl.UTF-8
7ab42891
ER
94Ten pakiet zawiera pliki nagłówkowe C biblioteki createrepo_c. Mają na
95celu łatwe operowanie na danych repozytorium (repodata).
eb85e3be
JB
96
97%package apidocs
98Summary: API documentation for createrepo_c library
99Summary(pl.UTF-8): Dokumentacja API biblioteki createrepo_c
100Group: Documentation
88265fc4 101BuildArch: noarch
eb85e3be
JB
102
103%description apidocs
104API documentation for createrepo_c library.
105
106%description apidocs -l pl.UTF-8
107Dokumentacja API biblioteki createrepo_c.
108
807f0e8d
JB
109%package -n python3-createrepo_c
110Summary: Python 3 bindings for the createrepo_c library
111Summary(pl.UTF-8): Wiązania Pythona 3 do biblioteki createrepo_c
112Group: Development/Languages/Python
113Requires: %{name}-libs = %{version}-%{release}
317621c2 114Obsoletes: python-createrepo_c < 0.17.6
807f0e8d
JB
115
116%description -n python3-createrepo_c
117Python 3 bindings for the createrepo_c library.
118
119%description -n python3-createrepo_c -l pl.UTF-8
120Wiązania Pythona 3 do biblioteki createrepo_c.
eb85e3be
JB
121
122%package -n bash-completion-createrepo_c
123Summary: Bash completion for createrepo_c commands
124Summary(pl.UTF-8): Bashowe uzupełnianie dla poleceń createrepo_c
125Group: Applications/Shells
126Requires: %{name} = %{version}-%{release}
b5b52576 127Requires: bash-completion >= 1:2.0
88265fc4 128BuildArch: noarch
eb85e3be
JB
129
130%description -n bash-completion-createrepo_c
131Bash completion for createrepo_c commands (createrepo_c, mergerepo_c,
132modifyrepo_c).
133
134%description -n bash-completion-createrepo_c -l pl.UTF-8
135Bashowe uzupełnianie dla poleceń createrepo_c (createrepo_c,
136mergerepo_c, modifyrepo_c).
137
138%prep
807f0e8d 139%setup -q
d04b5509 140%{?with_rpm5:%patch0 -p1}
eb85e3be
JB
141
142%build
317621c2 143install -d build
807f0e8d 144cd build
807f0e8d 145%cmake .. \
7fe79feb 146 -DBASHCOMP_DIR=%{bash_compdir} \
807f0e8d
JB
147 -DPYTHON_DESIRED=3
148
149%{__make}
317621c2 150%{__make} doc
807f0e8d
JB
151
152%if %{with tests}
153%{__make} tests
154%{__make} test \
155 ARGS="-V"
156%endif
eb85e3be
JB
157
158%install
159rm -rf $RPM_BUILD_ROOT
160
317621c2 161%{__make} -C build install \
807f0e8d 162 DESTDIR=$RPM_BUILD_ROOT
9aa7d4d3 163
807f0e8d
JB
164%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/createrepo_c
165%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/createrepo_c
eb85e3be
JB
166
167%clean
168rm -rf $RPM_BUILD_ROOT
169
170%post libs -p /sbin/ldconfig
171%postun libs -p /sbin/ldconfig
172
173%files
174%defattr(644,root,root,755)
175%attr(755,root,root) %{_bindir}/createrepo_c
176%attr(755,root,root) %{_bindir}/mergerepo_c
177%attr(755,root,root) %{_bindir}/modifyrepo_c
807f0e8d 178%attr(755,root,root) %{_bindir}/sqliterepo_c
eb85e3be
JB
179%{_mandir}/man8/createrepo_c.8*
180%{_mandir}/man8/mergerepo_c.8*
7ab42891 181%{_mandir}/man8/modifyrepo_c.8*
807f0e8d 182%{_mandir}/man8/sqliterepo_c.8*
eb85e3be
JB
183
184%files libs
185%defattr(644,root,root,755)
186%doc AUTHORS README.md
187%attr(755,root,root) %{_libdir}/libcreaterepo_c.so.*.*.*
1cd780f3 188%attr(755,root,root) %ghost %{_libdir}/libcreaterepo_c.so.1
eb85e3be
JB
189
190%files devel
191%defattr(644,root,root,755)
192%attr(755,root,root) %{_libdir}/libcreaterepo_c.so
193%{_pkgconfigdir}/createrepo_c.pc
194%{_includedir}/createrepo_c
195
196%files apidocs
197%defattr(644,root,root,755)
807f0e8d 198%doc build/doc/html
eb85e3be 199
807f0e8d
JB
200%files -n python3-createrepo_c
201%defattr(644,root,root,755)
202%dir %{py3_sitedir}/createrepo_c
203%attr(755,root,root) %{py3_sitedir}/createrepo_c/_createrepo_c.so
204%{py3_sitedir}/createrepo_c/__init__.py
205%{py3_sitedir}/createrepo_c/__pycache__
317621c2 206%{py3_sitedir}/createrepo_c-%{version}-py*.egg-info
807f0e8d 207
eb85e3be
JB
208%files -n bash-completion-createrepo_c
209%defattr(644,root,root,755)
bd7532a4
JB
210%{bash_compdir}/createrepo_c
211%{bash_compdir}/mergerepo_c
212%{bash_compdir}/modifyrepo_c
213%{bash_compdir}/sqliterepo_c
This page took 0.458712 seconds and 4 git commands to generate.