]> git.pld-linux.org Git - packages/coq.git/blobdiff - coq.spec
- updated BRs and files
[packages/coq.git] / coq.spec
index cbb02cd532940d88d568516961f635f86e9677b3..0e09f442b1d2c4a9d7935725a64ae0a972988a67 100644 (file)
--- a/coq.spec
+++ b/coq.spec
@@ -3,18 +3,23 @@
 #      - package and R: Csdp (https://projects.coin-or.org/Csdp)
 #
 # Conditional build:
-%bcond_with    tests   # run testsuite (csdp dependant micromega tests fail badly on x86_64)
+%bcond_without ocaml_opt       # skip building native optimized binaries (bytecode is always built)
+%bcond_with    tests           # run testsuite (csdp dependant micromega tests fail badly on x86_64)
 #
+%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
+%undefine      with_ocaml_opt
+%endif
+
 Summary:       The Coq Proof Assistant
 Summary(pl.UTF-8):     Coq - narzędzie pomagające w udowadnianiu
 Name:          coq
-Version:       8.3pl1
-Release:       0.1
+Version:       8.4pl5
+Release:       1
 License:       GPL
 Group:         Applications/Math
 Vendor:                INRIA Rocquencourt
-Source0:       http://coq.inria.fr/V%{version}/files/%{name}-%{version}.tar.gz
-# Source0-md5: 1869d22b337f5da59ba3bbe1433f9a3b
+Source0:       http://coq.inria.fr/distrib/V%{version}/files/%{name}-%{version}.tar.gz
+# Source0-md5: 7839005b48527a85149da950bd2ac006
 Source1:       coqide.desktop
 Source2:       coqide.xpm
 Patch0:                %{name}-lablgtk2.patch
@@ -27,11 +32,14 @@ BuildRequires:      ocaml >= 3.09.0
 BuildRequires: camlp5 >= 5.01
 BuildRequires: ocaml-lablgtk2-devel >= 2.12.0
 BuildRequires: sed >= 4.0
+BuildRequires: texlive-fonts-cmextra
+BuildRequires: texlive-fonts-other
 BuildRequires: texlive-latex-ams
 BuildRequires: texlive-latex-comment
 BuildRequires: texlive-latex-moreverb
 BuildRequires: texlive-psutils
 BuildRequires: texlive-format-pdflatex
+%requires_eq   ocaml-runtime
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -88,15 +96,17 @@ Styl dokumentacji Coq dla latexa.
        -libdir %{_libdir}/coq \
        -mandir %{_mandir} \
        -docdir %{_docdir}/%{name}-%{version} \
+       -configdir %{_sysconfdir}/%{name} \
+       -datadir %{_datadir}/%{name} \
        -emacs emacs \
        -browser "xdg-open %s" \
        -emacslib %{_datadir}/emacs/site-lisp \
-       -opt \
+       %{?with_ocaml_opt:-opt} \
        --coqdocdir %{_datadir}/texmf/tex/latex/misc \
-       --coqide opt
+       --coqide %{?with_ocaml_opt:opt}%{!?with_ocaml_opt:byte}
 
-%{__make} -j1 world VERBOSE=1
-%{?with_tests:%{__make} -j1 check VERBOSE=1}   # Use native coq to compile theories
+%{__make} -j1 world VERBOSE=1 CAML_LD_LIBRARY_PATH=kernel/byterun
+%{?with_tests:%{__make} -j1 check VERBOSE=1 CAML_LD_LIBRARY_PATH=kernel/byterun} # Use native coq to compile theories
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -109,23 +119,29 @@ install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
 
+# pdf is enough
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/ps
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
+%doc %{_docdir}/%{name}-%{version}
+%dir %{_sysconfdir}/%{name}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/coqide-gtk2rc
 %attr(755,root,root) %{_bindir}/coq_makefile
 %attr(755,root,root) %{_bindir}/coq-tex
 %attr(755,root,root) %{_bindir}/coqc
 %attr(755,root,root) %{_bindir}/coqchk
-%attr(755,root,root) %{_bindir}/coqchk.opt
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/coqchk.opt}
 %attr(755,root,root) %{_bindir}/coqdep
 %attr(755,root,root) %{_bindir}/coqdoc
 %attr(755,root,root) %{_bindir}/coqide*
 %attr(755,root,root) %{_bindir}/coqmktop
 %attr(755,root,root) %{_bindir}/coqtop
 %attr(755,root,root) %{_bindir}/coqtop.byte
-%attr(755,root,root) %{_bindir}/coqtop.opt
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/coqtop.opt}
 %attr(755,root,root) %{_bindir}/coqwc
 %attr(755,root,root) %{_bindir}/gallina
 %dir %{_libdir}/coq
@@ -140,11 +156,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/coqmktop.1*
 %{_mandir}/man1/coqtop.1*
 %{_mandir}/man1/coqtop.byte.1*
-%{_mandir}/man1/coqtop.opt.1*
+%{?with_ocaml_opt:%{_mandir}/man1/coqtop.opt.1*}
 %{_mandir}/man1/coqwc.1*
 %{_mandir}/man1/gallina.1*
 %{_desktopdir}/coqide.desktop
 %{_pixmapsdir}/coqide.xpm
+%{_datadir}/%{name}
 
 %files emacs
 %defattr(644,root,root,755)
This page took 0.03144 seconds and 4 git commands to generate.