]> git.pld-linux.org Git - packages/coq.git/blob - coq.spec
- rebuild with ocaml 4.04.1
[packages/coq.git] / coq.spec
1 #
2 # TODO:
3 #       - package and R: Csdp (https://projects.coin-or.org/Csdp)
4 #
5 # Conditional build:
6 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
7 %bcond_with     tests           # run testsuite (csdp dependant micromega tests fail badly on x86_64)
8 #
9 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
10 %undefine       with_ocaml_opt
11 %endif
12
13 Summary:        The Coq Proof Assistant
14 Summary(pl.UTF-8):      Coq - narzędzie pomagające w udowadnianiu
15 Name:           coq
16 Version:        8.4pl6
17 Release:        3
18 License:        LGPL v2.1
19 Group:          Applications/Math
20 Source0:        http://coq.inria.fr/distrib/V%{version}/files/%{name}-%{version}.tar.gz
21 # Source0-md5:  2334a98b64578cb81d2b4127e327b368
22 Source1:        coqide.desktop
23 Source2:        coqide.xpm
24 Patch0:         %{name}-lablgtk2.patch
25 URL:            http://coq.inria.fr/
26 BuildRequires:  bash
27 BuildRequires:  emacs
28 BuildRequires:  hevea
29 BuildRequires:  netpbm-progs
30 BuildRequires:  ocaml >= 3.09.0
31 BuildRequires:  camlp5 >= 5.01
32 BuildRequires:  ocaml-lablgtk2-devel >= 2.12.0
33 BuildRequires:  sed >= 4.0
34 BuildRequires:  texlive-fonts-cmextra
35 BuildRequires:  texlive-fonts-cmsuper
36 BuildRequires:  texlive-fonts-other
37 BuildRequires:  texlive-format-pdflatex
38 BuildRequires:  texlive-latex-ams
39 BuildRequires:  texlive-latex-comment
40 BuildRequires:  texlive-latex-moreverb
41 BuildRequires:  texlive-latex-ucs
42 BuildRequires:  texlive-makeindex
43 BuildRequires:  texlive-psutils
44 # hyperref.sty (from latex) requires ifxexex.sty (from xetex)
45 BuildRequires:  texlive-xetex
46 %requires_eq    ocaml-runtime
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Coq is a proof assistant which:
51  - allows to handle calculus assertions,
52  - check mechanically proofs of these assertions,
53  - helps to find formal proofs,
54  - extracts a certified program from the constructive proof of its
55    formal specification.
56
57 %description -l pl.UTF-8
58 Coq to narzędzie pomagające w udowadnianiu, które:
59 - pozwala uporać się z twierdzeniami dotyczącymi rachunku
60   różniczkowego,
61 - mechanicznie sprawdzać dowody tych twierdzeń,
62 - pomagać w znalezieniu formalnych dowodów,
63 - wyciągać program o dowiedzionej poprawności z konstruktywnego
64   dowodu jego formalnej specyfikacji.
65
66 %package emacs
67 Summary:        Emacs mode and syntax for Coq
68 Summary(pl.UTF-8):      Tryb i składnia Coq dla Emacsa
69 Group:          Development/Tools
70 Requires:       %{name} = %{version}-%{release}
71
72 %description emacs
73 Emacs mode and suyntax files for Coq.
74
75 %description emacs -l pl.UTF-8
76 Pliki trybu i składni Coq dla Emacsa.
77
78 %package latex
79 Summary:        Coq documentation style for latex
80 Summary(pl.UTF-8):      Styl dokumentacji Coq dla latexa
81 Group:          Development/Tools
82 Requires:       %{name} = %{version}-%{release}
83
84 %description latex
85 Coq documentation style for latex.
86
87 %description latex -l pl.UTF-8
88 Styl dokumentacji Coq dla latexa.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93
94 %{__sed} -i -e 's|#!/bin/sh|#!/bin/bash|' test-suite/check
95 %{__sed} -i -e 's|\(MAKE_TSOPTS=.*\) -s \(.*\)|\1 \2|' Makefile.build
96
97 %build
98 ./configure \
99         -bindir %{_bindir} \
100         -libdir %{_libdir}/coq \
101         -mandir %{_mandir} \
102         -docdir %{_docdir}/%{name}-%{version} \
103         -configdir %{_sysconfdir}/%{name} \
104         -datadir %{_datadir}/%{name} \
105         -emacs emacs \
106         -browser "xdg-open %s" \
107         -emacslib %{_datadir}/emacs/site-lisp \
108         %{?with_ocaml_opt:-opt} \
109         --coqdocdir %{_datadir}/texmf/tex/latex/misc \
110         --coqide %{?with_ocaml_opt:opt}%{!?with_ocaml_opt:byte}
111
112 %{__make} -j1 world VERBOSE=1 CAML_LD_LIBRARY_PATH=kernel/byterun
113 %{?with_tests:%{__make} -j1 check VERBOSE=1 CAML_LD_LIBRARY_PATH=kernel/byterun} # Use native coq to compile theories
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
118
119 %{__make} -e install \
120         COQINSTALLPREFIX=$RPM_BUILD_ROOT/
121 # To install only locally the binaries compiled with absolute paths
122
123 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
124 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
125
126 # pdf is enough
127 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/ps
128 cp -p CHANGES COMPATIBILITY COPYRIGHT CREDITS README $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(644,root,root,755)
135 %doc %{_docdir}/%{name}-%{version}
136 %dir %{_sysconfdir}/%{name}
137 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/coqide-gtk2rc
138 %attr(755,root,root) %{_bindir}/coq_makefile
139 %attr(755,root,root) %{_bindir}/coq-tex
140 %attr(755,root,root) %{_bindir}/coqc
141 %attr(755,root,root) %{_bindir}/coqchk
142 %{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/coqchk.opt}
143 %attr(755,root,root) %{_bindir}/coqdep
144 %attr(755,root,root) %{_bindir}/coqdoc
145 %attr(755,root,root) %{_bindir}/coqide*
146 %attr(755,root,root) %{_bindir}/coqmktop
147 %attr(755,root,root) %{_bindir}/coqtop
148 %attr(755,root,root) %{_bindir}/coqtop.byte
149 %{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/coqtop.opt}
150 %attr(755,root,root) %{_bindir}/coqwc
151 %attr(755,root,root) %{_bindir}/gallina
152 %dir %{_libdir}/coq
153 %{_libdir}/coq/*
154 %{_mandir}/man1/coq_makefile.1*
155 %{_mandir}/man1/coq-tex.1*
156 %{_mandir}/man1/coqc.1*
157 %{_mandir}/man1/coqchk.1*
158 %{_mandir}/man1/coqdep.1*
159 %{_mandir}/man1/coqdoc.1*
160 %{_mandir}/man1/coqide.1*
161 %{_mandir}/man1/coqmktop.1*
162 %{_mandir}/man1/coqtop.1*
163 %{_mandir}/man1/coqtop.byte.1*
164 %{?with_ocaml_opt:%{_mandir}/man1/coqtop.opt.1*}
165 %{_mandir}/man1/coqwc.1*
166 %{_mandir}/man1/gallina.1*
167 %{_desktopdir}/coqide.desktop
168 %{_pixmapsdir}/coqide.xpm
169 %{_datadir}/%{name}
170
171 %files emacs
172 %defattr(644,root,root,755)
173 %{_datadir}/emacs/site-lisp/coq.el
174 %{_datadir}/emacs/site-lisp/coq-db.el
175 %{_datadir}/emacs/site-lisp/coq-font-lock.el
176 %{_datadir}/emacs/site-lisp/coq-inferior.el
177 %{_datadir}/emacs/site-lisp/coq-syntax.el
178
179 %files latex
180 %defattr(644,root,root,755)
181 %{_datadir}/texmf/tex/latex/misc/coqdoc.sty
This page took 0.038349 seconds and 4 git commands to generate.