]> git.pld-linux.org Git - packages/coq.git/blob - coq.spec
- up to 8.4pl5
[packages/coq.git] / coq.spec
1 #
2 # TODO:
3 #       - package and R: Csdp (https://projects.coin-or.org/Csdp)
4 #
5 # Conditional build:
6 %bcond_with     tests   # run testsuite (csdp dependant micromega tests fail badly on x86_64)
7 #
8 Summary:        The Coq Proof Assistant
9 Summary(pl.UTF-8):      Coq - narzędzie pomagające w udowadnianiu
10 Name:           coq
11 Version:        8.4pl5
12 Release:        1
13 License:        GPL
14 Group:          Applications/Math
15 Vendor:         INRIA Rocquencourt
16 Source0:        http://coq.inria.fr/distrib/V%{version}/files/%{name}-%{version}.tar.gz
17 # Source0-md5:  7839005b48527a85149da950bd2ac006
18 Source1:        coqide.desktop
19 Source2:        coqide.xpm
20 Patch0:         %{name}-lablgtk2.patch
21 URL:            http://coq.inria.fr/
22 BuildRequires:  bash
23 BuildRequires:  emacs
24 BuildRequires:  hevea
25 BuildRequires:  netpbm-progs
26 BuildRequires:  ocaml >= 3.09.0
27 BuildRequires:  camlp5 >= 5.01
28 BuildRequires:  ocaml-lablgtk2-devel >= 2.12.0
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  texlive-latex-ams
31 BuildRequires:  texlive-latex-comment
32 BuildRequires:  texlive-latex-moreverb
33 BuildRequires:  texlive-psutils
34 BuildRequires:  texlive-format-pdflatex
35 %requires_eq    ocaml-runtime
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Coq is a proof assistant which:
40  - allows to handle calculus assertions,
41  - check mechanically proofs of these assertions,
42  - helps to find formal proofs,
43  - extracts a certified program from the constructive proof of its
44    formal specification.
45
46 %description -l pl.UTF-8
47 Coq to narzędzie pomagające w udowadnianiu, które:
48 - pozwala uporać się z twierdzeniami dotyczącymi rachunku
49   różniczkowego,
50 - mechanicznie sprawdzać dowody tych twierdzeń,
51 - pomagać w znalezieniu formalnych dowodów,
52 - wyciągać program o dowiedzionej poprawności z konstruktywnego
53   dowodu jego formalnej specyfikacji.
54
55 %package emacs
56 Summary:        Emacs mode and syntax for Coq
57 Summary(pl.UTF-8):      Tryb i składnia Coq dla Emacsa
58 Group:          Development/Tools
59 Requires:       %{name} = %{version}-%{release}
60
61 %description emacs
62 Emacs mode and suyntax files for Coq.
63
64 %description emacs -l pl.UTF-8
65 Pliki trybu i składni Coq dla Emacsa.
66
67 %package latex
68 Summary:        Coq documentation style for latex
69 Summary(pl.UTF-8):      Styl dokumentacji Coq dla latexa
70 Group:          Development/Tools
71 Requires:       %{name} = %{version}-%{release}
72
73 %description latex
74 Coq documentation style for latex.
75
76 %description latex -l pl.UTF-8
77 Styl dokumentacji Coq dla latexa.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82
83 %{__sed} -i -e 's|#!/bin/sh|#!/bin/bash|' test-suite/check
84 %{__sed} -i -e 's|\(MAKE_TSOPTS=.*\) -s \(.*\)|\1 \2|' Makefile.build
85
86 %build
87 ./configure \
88         -bindir %{_bindir} \
89         -libdir %{_libdir}/coq \
90         -mandir %{_mandir} \
91         -docdir %{_docdir}/%{name}-%{version} \
92         -configdir %{_sysconfdir}/%{name} \
93         -datadir %{_datadir}/%{name} \
94         -emacs emacs \
95         -browser "xdg-open %s" \
96         -emacslib %{_datadir}/emacs/site-lisp \
97         -opt \
98         --coqdocdir %{_datadir}/texmf/tex/latex/misc \
99         --coqide opt
100
101 %{__make} -j1 world VERBOSE=1
102 %{?with_tests:%{__make} -j1 check VERBOSE=1}    # Use native coq to compile theories
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
107
108 %{__make} -e install \
109         COQINSTALLPREFIX=$RPM_BUILD_ROOT/
110 # To install only locally the binaries compiled with absolute paths
111
112 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
113 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
114
115 # pdf is enough
116 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/ps
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc %{_docdir}/%{name}-%{version}
124 %dir %{_sysconfdir}/%{name}
125 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/coqide-gtk2rc
126 %attr(755,root,root) %{_bindir}/coq_makefile
127 %attr(755,root,root) %{_bindir}/coq-tex
128 %attr(755,root,root) %{_bindir}/coqc
129 %attr(755,root,root) %{_bindir}/coqchk
130 %attr(755,root,root) %{_bindir}/coqchk.opt
131 %attr(755,root,root) %{_bindir}/coqdep
132 %attr(755,root,root) %{_bindir}/coqdoc
133 %attr(755,root,root) %{_bindir}/coqide*
134 %attr(755,root,root) %{_bindir}/coqmktop
135 %attr(755,root,root) %{_bindir}/coqtop
136 %attr(755,root,root) %{_bindir}/coqtop.byte
137 %attr(755,root,root) %{_bindir}/coqtop.opt
138 %attr(755,root,root) %{_bindir}/coqwc
139 %attr(755,root,root) %{_bindir}/gallina
140 %dir %{_libdir}/coq
141 %{_libdir}/coq/*
142 %{_mandir}/man1/coq_makefile.1*
143 %{_mandir}/man1/coq-tex.1*
144 %{_mandir}/man1/coqc.1*
145 %{_mandir}/man1/coqchk.1*
146 %{_mandir}/man1/coqdep.1*
147 %{_mandir}/man1/coqdoc.1*
148 %{_mandir}/man1/coqide.1*
149 %{_mandir}/man1/coqmktop.1*
150 %{_mandir}/man1/coqtop.1*
151 %{_mandir}/man1/coqtop.byte.1*
152 %{_mandir}/man1/coqtop.opt.1*
153 %{_mandir}/man1/coqwc.1*
154 %{_mandir}/man1/gallina.1*
155 %{_desktopdir}/coqide.desktop
156 %{_pixmapsdir}/coqide.xpm
157 %{_datadir}/%{name}
158
159 %files emacs
160 %defattr(644,root,root,755)
161 %{_datadir}/emacs/site-lisp/coq.el
162 %{_datadir}/emacs/site-lisp/coq-db.el
163 %{_datadir}/emacs/site-lisp/coq-font-lock.el
164 %{_datadir}/emacs/site-lisp/coq-inferior.el
165 %{_datadir}/emacs/site-lisp/coq-syntax.el
166
167 %files latex
168 %defattr(644,root,root,755)
169 %{_datadir}/texmf/tex/latex/misc/coqdoc.sty
This page took 0.034048 seconds and 3 git commands to generate.