]> git.pld-linux.org Git - packages/coq.git/blob - coq.spec
- rel 2
[packages/coq.git] / coq.spec
1 #
2 # TODO:
3 #       - package and R: Csdp (https://projects.coin-or.org/Csdp)
4 #
5 # Conditional build:
6 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
7 %bcond_with     tests           # run testsuite (csdp dependant micromega tests fail badly on x86_64)
8 #
9 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
10 %undefine       with_ocaml_opt
11 %endif
12
13 Summary:        The Coq Proof Assistant
14 Summary(pl.UTF-8):      Coq - narzędzie pomagające w udowadnianiu
15 Name:           coq
16 Version:        8.4pl5
17 Release:        2
18 License:        GPL
19 Group:          Applications/Math
20 Vendor:         INRIA Rocquencourt
21 Source0:        http://coq.inria.fr/distrib/V%{version}/files/%{name}-%{version}.tar.gz
22 # Source0-md5:  7839005b48527a85149da950bd2ac006
23 Source1:        coqide.desktop
24 Source2:        coqide.xpm
25 Patch0:         %{name}-lablgtk2.patch
26 URL:            http://coq.inria.fr/
27 BuildRequires:  bash
28 BuildRequires:  emacs
29 BuildRequires:  hevea
30 BuildRequires:  netpbm-progs
31 BuildRequires:  ocaml >= 3.09.0
32 BuildRequires:  camlp5 >= 5.01
33 BuildRequires:  ocaml-lablgtk2-devel >= 2.12.0
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  texlive-fonts-cmextra
36 BuildRequires:  texlive-fonts-other
37 BuildRequires:  texlive-latex-ams
38 BuildRequires:  texlive-latex-comment
39 BuildRequires:  texlive-latex-moreverb
40 BuildRequires:  texlive-psutils
41 BuildRequires:  texlive-format-pdflatex
42 %requires_eq    ocaml-runtime
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Coq is a proof assistant which:
47  - allows to handle calculus assertions,
48  - check mechanically proofs of these assertions,
49  - helps to find formal proofs,
50  - extracts a certified program from the constructive proof of its
51    formal specification.
52
53 %description -l pl.UTF-8
54 Coq to narzędzie pomagające w udowadnianiu, które:
55 - pozwala uporać się z twierdzeniami dotyczącymi rachunku
56   różniczkowego,
57 - mechanicznie sprawdzać dowody tych twierdzeń,
58 - pomagać w znalezieniu formalnych dowodów,
59 - wyciągać program o dowiedzionej poprawności z konstruktywnego
60   dowodu jego formalnej specyfikacji.
61
62 %package emacs
63 Summary:        Emacs mode and syntax for Coq
64 Summary(pl.UTF-8):      Tryb i składnia Coq dla Emacsa
65 Group:          Development/Tools
66 Requires:       %{name} = %{version}-%{release}
67
68 %description emacs
69 Emacs mode and suyntax files for Coq.
70
71 %description emacs -l pl.UTF-8
72 Pliki trybu i składni Coq dla Emacsa.
73
74 %package latex
75 Summary:        Coq documentation style for latex
76 Summary(pl.UTF-8):      Styl dokumentacji Coq dla latexa
77 Group:          Development/Tools
78 Requires:       %{name} = %{version}-%{release}
79
80 %description latex
81 Coq documentation style for latex.
82
83 %description latex -l pl.UTF-8
84 Styl dokumentacji Coq dla latexa.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %{__sed} -i -e 's|#!/bin/sh|#!/bin/bash|' test-suite/check
91 %{__sed} -i -e 's|\(MAKE_TSOPTS=.*\) -s \(.*\)|\1 \2|' Makefile.build
92
93 %build
94 ./configure \
95         -bindir %{_bindir} \
96         -libdir %{_libdir}/coq \
97         -mandir %{_mandir} \
98         -docdir %{_docdir}/%{name}-%{version} \
99         -configdir %{_sysconfdir}/%{name} \
100         -datadir %{_datadir}/%{name} \
101         -emacs emacs \
102         -browser "xdg-open %s" \
103         -emacslib %{_datadir}/emacs/site-lisp \
104         %{?with_ocaml_opt:-opt} \
105         --coqdocdir %{_datadir}/texmf/tex/latex/misc \
106         --coqide %{?with_ocaml_opt:opt}%{!?with_ocaml_opt:byte}
107
108 %{__make} -j1 world VERBOSE=1 CAML_LD_LIBRARY_PATH=kernel/byterun
109 %{?with_tests:%{__make} -j1 check VERBOSE=1 CAML_LD_LIBRARY_PATH=kernel/byterun} # Use native coq to compile theories
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
114
115 %{__make} -e install \
116         COQINSTALLPREFIX=$RPM_BUILD_ROOT/
117 # To install only locally the binaries compiled with absolute paths
118
119 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
120 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
121
122 # pdf is enough
123 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/ps
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 %doc %{_docdir}/%{name}-%{version}
131 %dir %{_sysconfdir}/%{name}
132 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/coqide-gtk2rc
133 %attr(755,root,root) %{_bindir}/coq_makefile
134 %attr(755,root,root) %{_bindir}/coq-tex
135 %attr(755,root,root) %{_bindir}/coqc
136 %attr(755,root,root) %{_bindir}/coqchk
137 %{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/coqchk.opt}
138 %attr(755,root,root) %{_bindir}/coqdep
139 %attr(755,root,root) %{_bindir}/coqdoc
140 %attr(755,root,root) %{_bindir}/coqide*
141 %attr(755,root,root) %{_bindir}/coqmktop
142 %attr(755,root,root) %{_bindir}/coqtop
143 %attr(755,root,root) %{_bindir}/coqtop.byte
144 %{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/coqtop.opt}
145 %attr(755,root,root) %{_bindir}/coqwc
146 %attr(755,root,root) %{_bindir}/gallina
147 %dir %{_libdir}/coq
148 %{_libdir}/coq/*
149 %{_mandir}/man1/coq_makefile.1*
150 %{_mandir}/man1/coq-tex.1*
151 %{_mandir}/man1/coqc.1*
152 %{_mandir}/man1/coqchk.1*
153 %{_mandir}/man1/coqdep.1*
154 %{_mandir}/man1/coqdoc.1*
155 %{_mandir}/man1/coqide.1*
156 %{_mandir}/man1/coqmktop.1*
157 %{_mandir}/man1/coqtop.1*
158 %{_mandir}/man1/coqtop.byte.1*
159 %{?with_ocaml_opt:%{_mandir}/man1/coqtop.opt.1*}
160 %{_mandir}/man1/coqwc.1*
161 %{_mandir}/man1/gallina.1*
162 %{_desktopdir}/coqide.desktop
163 %{_pixmapsdir}/coqide.xpm
164 %{_datadir}/%{name}
165
166 %files emacs
167 %defattr(644,root,root,755)
168 %{_datadir}/emacs/site-lisp/coq.el
169 %{_datadir}/emacs/site-lisp/coq-db.el
170 %{_datadir}/emacs/site-lisp/coq-font-lock.el
171 %{_datadir}/emacs/site-lisp/coq-inferior.el
172 %{_datadir}/emacs/site-lisp/coq-syntax.el
173
174 %files latex
175 %defattr(644,root,root,755)
176 %{_datadir}/texmf/tex/latex/misc/coqdoc.sty
This page took 0.063459 seconds and 3 git commands to generate.