]> git.pld-linux.org Git - packages/cool-retro-term.git/blob - cool-retro-term.spec
update BR
[packages/cool-retro-term.git] / cool-retro-term.spec
1 # TODO
2 # - create and use system package for qmltermwidget?
3
4 %define qtver   5.2
5 Summary:        A good looking terminal emulator which mimics the old cathode display
6 Name:           cool-retro-term
7 Version:        1.0.0
8 Release:        1
9 License:        GPL-3.0+
10 Group:          X11/Applications
11 Source0:        https://github.com/Swordfish90/cool-retro-term/archive/v%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  06e73fbffcb5fd55695e5ec4034e3ad1
13 Source1:        https://github.com/Swordfish90/qmltermwidget/archive/490eeaf195cd5764a3798c2a2340ced648db4526/qmltermwidget.tar.gz
14 # Source1-md5:  64d5f6ee2f8d01512209f211d2533e7d
15 URL:            https://github.com/Swordfish90/cool-retro-term
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Declarative-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= %{qtver}
19 BuildRequires:  Qt5Quick-devel >= %{qtver}
20 BuildRequires:  desktop-file-utils
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  qt5-build >= %{qtver}
23 BuildRequires:  qt5-qmake >= %{qtver}
24 Requires:       Qt5Gui-platform-xcb-egl >= %{qtver}
25 Requires:       Qt5Gui-platform-xcb-glx >= %{qtver}
26 Requires:       Qt5Quick-controls >= %{qtver}
27 Requires:       Qt5Quick-graphicaleffects >= %{qtver}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 cool-retro-term is a terminal emulator which mimics the look and feel
32 of the old cathode tube screens. It has been designed to be eye-candy,
33 customizable, and reasonably lightweight.
34
35 %prep
36 %setup -q -a1
37 mv qmltermwidget-*/* qmltermwidget
38
39 %build
40 qmake-qt5
41 %{__make} \
42         CXX="%{__cxx}"
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 %{__make} install \
47         INSTALL_ROOT=$RPM_BUILD_ROOT
48
49 desktop-file-install --dir=$RPM_BUILD_ROOT%{_desktopdir} %{name}.desktop
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README.md
57 %attr(755,root,root) %{_bindir}/%{name}
58 %{_libdir}/qt5/qml/QMLTermWidget
59 %{_desktopdir}/%{name}.desktop
60 %{_iconsdir}/hicolor/*/*/*.png
This page took 0.092264 seconds and 4 git commands to generate.