]> git.pld-linux.org Git - packages/containerd.git/blob - containerd.spec
new
[packages/containerd.git] / containerd.spec
1 Summary:        An open and reliable container runtime
2 Name:           containerd
3 Version:        1.6.0
4 Release:        1
5 License:        Apache v2.0
6 Group:          Applications
7 Source0:        https://github.com/containerd/containerd/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  aa0371db45d4e149e65ccbbddcbed8b1
9 URL:            https://containerd.io/
10 BuildRequires:  btrfs-progs-devel
11 BuildRequires:  golang >= 1.16
12 BuildRequires:  rpmbuild(macros) >= 2.009
13 Requires:       runc
14 ExclusiveArch:  %go_arches
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _debugsource_packages   0
18
19 %description
20 containerd is an industry-standard container runtime with an emphasis
21 on simplicity, robustness and portability. It is available as a daemon
22 for Linux and Windows, which can manage the complete container
23 lifecycle of its host system: image transfer and storage, container
24 execution and supervision, low-level storage and network attachments,
25 etc.
26
27 %prep
28 %setup -q
29
30 %build
31 %{__make} binaries \
32         GO="%__go" \
33         VERSION="%{version}"
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37
38 %{__make} install \
39         DESTDIR="$RPM_BUILD_ROOT" \
40         PREFIX="%{_prefix}"
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc {ADOPTERS,BUILDING,README,RELEASES,ROADMAP,SCOPE}.md
48 %attr(755,root,root) %{_bindir}/containerd
49 %attr(755,root,root) %{_bindir}/containerd-shim
50 %attr(755,root,root) %{_bindir}/containerd-shim-runc-v1
51 %attr(755,root,root) %{_bindir}/containerd-shim-runc-v2
52 %attr(755,root,root) %{_bindir}/containerd-stress
53 %attr(755,root,root) %{_bindir}/ctr
This page took 0.152456 seconds and 4 git commands to generate.