]> git.pld-linux.org Git - packages/complexity.git/blob - complexity.spec
- new
[packages/complexity.git] / complexity.spec
1 Summary:        Measure complexity of C source
2 Summary(pl.UTF-8):      Mierzenie złożoności kodu źródłowego w C
3 Name:           complexity
4 Version:        1.13
5 Release:        1
6 License:        GPL v3+
7 Group:          Development/Tools
8 Source0:        http://ftp.gnu.org/gnu/complexity/%{name}-%{version}.tar.xz
9 # Source0-md5:  93aa255c784e68edfd64d96f705ad3f3
10 Patch0:         %{name}-info.patch
11 URL:            http://www.gnu.org/software/complexity/
12 BuildRequires:  autogen-devel >= 5.18.16
13 BuildRequires:  tar >= 1:1.22
14 BuildRequires:  texinfo >= 4.8
15 BuildRequires:  xz
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Complexity is a tool designed for analyzing the complexity of C
20 program functions. It is very similar to the McCabe scoring, but
21 addresses several issues not considered in that scoring scheme.
22
23 %description -l pl.UTF-8
24 Complexity to narzędzie zaprojektowane do analizy złożoności funkcji w
25 języku C. Jest bardzo podobne do punktacji McCabe, ale bierze pod
26 uwagę kilka aspektów nie uwzględnianych w tym schemacie.
27
28 %prep
29 %setup -q
30 %patch0 -p1
31
32 %build
33 cd src
34 # need to regenerate [opts.c, opts.h] to build with autogen < 5.18.17
35 autogen opts.def
36 cd ..
37 %configure
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %post   -p /sbin/postshell
50 -/usr/sbin/fix-info-dir -c %{_infodir}
51
52 %postun -p /sbin/postshell
53 -/usr/sbin/fix-info-dir -c %{_infodir}
54
55 %files
56 %defattr(644,root,root,755)
57 %doc AUTHORS ChangeLog NEWS README
58 %attr(755,root,root) %{_bindir}/complexity
59 %attr(755,root,root) %{_bindir}/cx-vs-mc
60 %{_infodir}/complexity.info*
61 %{_mandir}/man1/complexity.1*
This page took 0.081759 seconds and 4 git commands to generate.