]> git.pld-linux.org Git - packages/colm.git/blob - colm.spec
- Group and dependency for vim-syntax-
[packages/colm.git] / colm.spec
1 Summary:        The Colm Programming Language - COmputer Language Manipulation
2 Summary(pl.UTF-8):      Język programowania Colm do operacji na językach komputerowych
3 Name:           colm
4 Version:        0.14.7
5 Release:        1
6 License:        MIT
7 Group:          Development/Tools
8 Source0:        http://www.colm.net/files/colm/%{name}-%{version}.tar.gz
9 # Source0-md5:  073b11234fe64a281874b4466c0c25ee
10 URL:            http://www.colm.net/
11 BuildRequires:  libstdc++-devel
12 BuildRequires:  rpm-build >= 4.6
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Colm (COmputer Language Manipulation) is a programming language
17 designed for the analysis and transformation of computer languages.
18 Colm is influenced primarily by TXL (<http://www.txl.ca/>). It is in
19 the family of program transformation languages.
20
21 %description -l pl.UTF-8
22 Colm (COmputer Language Manipulation - operacje na języku
23 komputerowym) to język programowania zaprojektowany do analizy i
24 przekształceń języków komputerowych. Colm jest zainspirowany głównie
25 przez TXL (<http://www.txl.ca/>). Jest to rodzina języków
26 transformacji programów.
27
28 %package devel
29 Summary:        Header files for COLM libraries
30 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek COLM
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33 Requires:       libstdc++-devel
34
35 %description devel
36 Header files for COLM libraries.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe bibliotek COLM.
40
41 %package static
42 Summary:        Static COLM libraries
43 Summary(pl.UTF-8):      Statyczne biblioteki COLM
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}-%{release}
46
47 %description static
48 Static COLM libraries.
49
50 %description static -l pl.UTF-8
51 Statyczne biblioteki COLM.
52
53 %package doc
54 Summary:        Documentation for COLM
55 Summary(pl.UTF-8):      Dokumentacja do pakietu COLM
56 Group:          Documentation
57 BuildArch:      noarch
58
59 %description doc
60 Documentation for COLM.
61
62 %description doc -l pl.UTF-8
63 Dokumentacja do pakietu COLM.
64
65 %package -n vim-syntax-colm
66 Summary:        Vim syntax file for COLM
67 Summary(pl.UTF-8):      Plik składni Vima dla pakietu COLM
68 Group:          Applications/Editors
69 Requires:       vim-rt
70 BuildArch:      noarch
71
72 %description -n vim-syntax-colm
73 Vim syntax file for COLM.
74
75 %description -n vim-syntax-colm -l pl.UTF-8
76 Plik składni Vima dla pakietu COLM.
77
78 %prep
79 %setup -q
80
81 %build
82 %configure \
83         --datadir=%{_datadir}/colm
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 # no external dependensies (beside libstdc++)
93 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
94
95 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
96 %{__mv} $RPM_BUILD_ROOT%{_docdir}/colm/colm.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc COPYING README
107 %attr(755,root,root) %{_bindir}/colm
108 %attr(755,root,root) %{_bindir}/colm-wrap
109 %attr(755,root,root) %{_libdir}/libcolm-%{version}.so
110 %attr(755,root,root) %{_libdir}/libfsm-%{version}.so
111 %{_datadir}/colm
112
113 %files devel
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_libdir}/libcolm.so
116 %attr(755,root,root) %{_libdir}/libfsm.so
117 %{_includedir}/aapl
118 %{_includedir}/colm
119 %{_includedir}/libfsm
120
121 %files static
122 %defattr(644,root,root,755)
123 %{_libdir}/libcolm.a
124 %{_libdir}/libfsm.a
125
126 %files doc
127 %defattr(644,root,root,755)
128 %{_docdir}/colm
129
130 %files -n vim-syntax-colm
131 %defattr(644,root,root,755)
132 %{_datadir}/vim/vimfiles/syntax/colm.vim
This page took 0.077503 seconds and 4 git commands to generate.