]> git.pld-linux.org Git - packages/clutter.git/blob - clutter.spec
- unconditional noarch subpackages
[packages/clutter.git] / clutter.spec
1 #
2 # Conditional build:
3 %bcond_without  egl     # EGL framebuffer backend
4 %bcond_with     mir     # Mir backend (requires cogl support for Mir, which in turn conflicts with wayland)
5 %bcond_without  wayland # Wayland backend and compositor
6 %bcond_without  evdev   # evdev support for input events
7 %bcond_with     tslib   # TSLib support for input events (outdated?)
8
9 Summary:        Library for rich GUIs
10 Summary(pl.UTF-8):      Biblioteka do bogatych graficznych interfejsów użytkownika
11 Name:           clutter
12 Version:        1.26.4
13 Release:        1
14 License:        LGPL v2+
15 Group:          Libraries
16 Source0:        http://ftp.gnome.org/pub/GNOME/sources/clutter/1.26/%{name}-%{version}.tar.xz
17 # Source0-md5:  624dd776a5159de0267587b1df6b97b2
18 Patch0:         gtkdoc.patch
19 Patch1:         missing.patch
20 URL:            http://www.clutter-project.org/
21 BuildRequires:  OpenGL-GLX-devel
22 BuildRequires:  atk-devel >= 1:2.5.3
23 BuildRequires:  autoconf >= 2.63
24 BuildRequires:  automake >= 1:1.11
25 BuildRequires:  cairo-devel >= 1.14.0
26 BuildRequires:  cairo-gobject-devel >= 1.14.0
27 BuildRequires:  cogl-devel >= 1.22.0
28 %{?with_wayland:BuildRequires:  cogl-devel(wayland) >= 1.22.0}
29 BuildRequires:  docbook-dtd412-xml
30 BuildRequires:  gdk-pixbuf2-devel >= 2.0
31 BuildRequires:  gettext-tools >= 0.17
32 BuildRequires:  glib2-devel >= 1:2.53.4
33 BuildRequires:  gobject-introspection-devel >= 1.39.0
34 BuildRequires:  gtk+3-devel >= 3.22.6
35 BuildRequires:  gtk-doc >= 1.20
36 BuildRequires:  json-glib-devel >= 0.12.0
37 %{?with_evdev:BuildRequires:    libinput-devel >= 0.19.0}
38 BuildRequires:  libtool >= 2:2.2.6
39 BuildRequires:  libxslt-progs
40 # mirclient
41 %{?with_mir:BuildRequires:      mir-devel}
42 BuildRequires:  pango-devel >= 1:1.30
43 BuildRequires:  pkgconfig >= 1:0.16
44 BuildRequires:  python-modules
45 BuildRequires:  tar >= 1:1.22
46 %{?with_tslib:BuildRequires:    tslib-devel >= 1.1}
47 %{?with_evdev:BuildRequires:    udev-devel >= 1:136}
48 %{?with_evdev:BuildRequires:    udev-glib-devel}
49 # wayland-client wayland-cursor (for client), wayland-server (for compositor)
50 %{?with_wayland:BuildRequires:  wayland-devel}
51 BuildRequires:  xorg-lib-libX11-devel
52 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
53 BuildRequires:  xorg-lib-libXdamage-devel
54 BuildRequires:  xorg-lib-libXext-devel
55 BuildRequires:  xorg-lib-libXi-devel
56 %if %{with evdev} || %{with wayland}
57 BuildRequires:  xorg-lib-libxkbcommon-devel
58 %endif
59 BuildRequires:  xz
60 Requires:       atk >= 1:2.5.3
61 Requires:       cairo-gobject >= 1.14.0
62 Requires:       cogl >= 1.22.0
63 %{?with_wayland:Requires:       cogl(wayland) >= 1.22.0}
64 Requires:       glib2 >= 1:2.53.4
65 Requires:       gtk+3 >= 3.22.6
66 Requires:       json-glib >= 0.12.0
67 %{?with_evdev:Requires: libinput >= 0.19.0}
68 Requires:       pango >= 1:1.30
69 %{?with_evdev:Requires: udev-libs >= 1:136}
70 %{?with_evdev:Provides: clutter(evdev) = %{version}-%{release}}
71 Obsoletes:      clutter-cairo < 1.0
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %description
75 Clutter is an open source software library for creating fast, visually
76 rich graphical user interfaces. The most obvious example of potential
77 usage is in media center type applications. We hope however it can be
78 used for a lot more.
79
80 Clutter uses OpenGL (and soon optionally OpenGL ES) for rendering but
81 with an API which hides the underlying GL complexity from the
82 developer. The Clutter API is intended to be easy to use, efficient
83 and flexible.
84
85 %description -l pl.UTF-8
86 Clutter to biblioteka o otwartych źródłach do tworzenia szybkich,
87 bogatych wizualnie graficznych interfejsów użytkownika. Najbardziej
88 oczywistym przykładem potencjalnego zastosowania są aplikacje typu
89 centrum multimedialne. Jednak autorzy mają nadzieję, że znajdzie się
90 więcej zastosowań.
91
92 Clutter wykorzystuje OpenGL (i wkrótce opcjonalnie OpenGL ES) do
93 renderowania, ale API ukrywa złożoność warstwy GL przed programistami.
94 API biblioteki Clutter ma być łatwe w użyciu, wydajne i elastyczne.
95
96 %package devel
97 Summary:        Header files for clutter library
98 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki clutter
99 Group:          Development/Libraries
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       OpenGL-GLX-devel
102 Requires:       atk-devel >= 1:2.5.3
103 Requires:       cairo-gobject-devel >= 1.14.0
104 Requires:       cogl-devel >= 1.22.0
105 %{?with_wayland:Requires:       cogl-devel(wayland) >= 1.22.0}
106 Requires:       gdk-pixbuf2-devel >= 2.0
107 Requires:       glib2-devel >= 1:2.53.4
108 Requires:       gtk+3-devel >= 3.22.6
109 Requires:       json-glib-devel >= 0.12.0
110 %{?with_evdev:Requires: libinput-devel >= 0.19.0}
111 Requires:       pango-devel >= 1:1.30
112 %{?with_evdev:Requires: udev-devel >= 1:136}
113 %{?with_wayland:Requires: wayland-devel}
114 Requires:       xorg-lib-libX11-devel
115 Requires:       xorg-lib-libXcomposite-devel >= 0.4
116 Requires:       xorg-lib-libXdamage-devel
117 Requires:       xorg-lib-libXext-devel
118 %if %{with evdev} || %{with wayland}
119 Requires:       xorg-lib-libxkbcommon-devel
120 %endif
121 %{?with_evdev:Provides: clutter-devel(evdev) = %{version}-%{release}}
122 Obsoletes:      clutter-cairo-devel < 1.0
123
124 %description devel
125 Header files for clutter library.
126
127 %description devel -l pl.UTF-8
128 Pliki nagłówkowe biblioteki clutter.
129
130 %package static
131 Summary:        Static clutter library
132 Summary(pl.UTF-8):      Statyczna biblioteka clutter
133 Group:          Development/Libraries
134 Requires:       %{name}-devel = %{version}-%{release}
135 %{?with_evdev:Provides: clutter-static(evdev) = %{version}-%{release}}
136 Obsoletes:      clutter-cairo-static < 1.0
137
138 %description static
139 Static clutter library.
140
141 %description static -l pl.UTF-8
142 Statyczna biblioteka clutter.
143
144 %package apidocs
145 Summary:        clutter API documentation
146 Summary(pl.UTF-8):      Dokumentacja API clutter
147 Group:          Documentation
148 Requires:       gtk-doc-common
149 BuildArch:      noarch
150
151 %description apidocs
152 clutter API documentation.
153
154 %description apidocs -l pl.UTF-8
155 Dokumentacja API clutter.
156
157 %prep
158 %setup -q
159 %patch0 -p1
160 %patch1 -p1
161
162 %build
163 %{__gtkdocize}
164 %{__libtoolize}
165 %{__aclocal} -I build/autotools
166 %{__autoconf}
167 %{__autoheader}
168 %{__automake}
169 %configure \
170         --disable-silent-rules \
171         --enable-docs \
172         %{?with_egl:--enable-egl-backend} \
173         %{?with_evdev:--enable-evdev-input} \
174         --enable-gdk-backend \
175         --enable-gtk-doc \
176         %{?with_mir:--enable-mir-backend} \
177         --enable-static \
178         %{?with_tslib:--enable-tslib-input} \
179 %if %{with wayland}
180         --enable-wayland-backend \
181         --enable-wayland-compositor \
182 %endif
183         --enable-xinput \
184         --with-html-dir=%{_gtkdocdir}
185 %{__make}
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189
190 %{__make} install \
191         DESTDIR=$RPM_BUILD_ROOT
192
193 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libclutter-1.0.la
194
195 # move to %{_examplesdir} and package in -examples?
196 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/clutter-1.0/cookbook/examples
197
198 %find_lang clutter-1.0
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %post   -p /sbin/ldconfig
204 %postun -p /sbin/ldconfig
205
206 %files -f clutter-1.0.lang
207 %defattr(644,root,root,755)
208 %doc ChangeLog NEWS README.md
209 %attr(755,root,root) %{_libdir}/libclutter-1.0.so.*.*.*
210 %attr(755,root,root) %ghost %{_libdir}/libclutter-1.0.so.0
211 %attr(755,root,root) %{_libdir}/libclutter-glx-1.0.so.0
212 %{_libdir}/girepository-1.0/Cally-1.0.typelib
213 %{_libdir}/girepository-1.0/Clutter-1.0.typelib
214 %{_libdir}/girepository-1.0/ClutterGdk-1.0.typelib
215 %{_libdir}/girepository-1.0/ClutterX11-1.0.typelib
216
217 %files devel
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/libclutter-1.0.so
220 %attr(755,root,root) %{_libdir}/libclutter-glx-1.0.so
221 %{_includedir}/clutter-1.0
222 %{_datadir}/gir-1.0/Cally-1.0.gir
223 %{_datadir}/gir-1.0/Clutter-1.0.gir
224 %{_datadir}/gir-1.0/ClutterGdk-1.0.gir
225 %{_datadir}/gir-1.0/ClutterX11-1.0.gir
226 %{_pkgconfigdir}/cally-1.0.pc
227 %{_pkgconfigdir}/clutter-1.0.pc
228 %{_pkgconfigdir}/clutter-cogl-1.0.pc
229 %{_pkgconfigdir}/clutter-gdk-1.0.pc
230 %{_pkgconfigdir}/clutter-glx-1.0.pc
231 %{_pkgconfigdir}/clutter-x11-1.0.pc
232 %{_pkgconfigdir}/clutter-egl-1.0.pc
233 %{?with_mir:%{_pkgconfigdir}/clutter-mir-1.0.pc}
234 %{_pkgconfigdir}/clutter-wayland-1.0.pc
235 %{_pkgconfigdir}/clutter-wayland-compositor-1.0.pc
236 # valgrind support (TODO: better place?)
237 %dir %{_datadir}/clutter-1.0
238 %{_datadir}/clutter-1.0/valgrind
239
240 %files static
241 %defattr(644,root,root,755)
242 %{_libdir}/libclutter-1.0.a
243
244 %files apidocs
245 %defattr(644,root,root,755)
246 %{_gtkdocdir}/clutter
247 %{_gtkdocdir}/clutter-cookbook
This page took 0.105844 seconds and 4 git commands to generate.