]> git.pld-linux.org Git - packages/clearsilver.git/blob - clearsilver.spec
perl 5.38.0 rebuild
[packages/clearsilver.git] / clearsilver.spec
1 Summary:        ClearSilver HTML template system
2 Summary(pl.UTF-8):      ClearSilver - system szablonów HTML
3 Name:           clearsilver
4 Version:        0.10.5
5 Release:        24
6 License:        Apache License style
7 Group:          Development/Libraries
8 Source0:        http://www.clearsilver.net/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  b8c0c7fbe0ef5e06e0c935f134304d44
10 Patch0:         %{name}-pic.patch
11 Patch1:         format-security.patch
12 Patch2:         variadic-macros.patch
13 URL:            http://www.clearsilver.net/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  perl-ExtUtils-MakeMaker
17 BuildRequires:  perl-devel
18 BuildRequires:  python-devel
19 BuildRequires:  python-modules
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  zlib-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 ClearSilver is a fast, powerful, and language-neutral HTML template
26 system. In both static content sites and dynamic HTML applications, it
27 provides a separation between presentation code and application logic
28 which makes working with your project easier.
29
30 %description -l pl.UTF-8
31 ClearSilver to szybki, potężny i niezależny od języka system szablonów
32 HTML. Zarówno w statycznych stronach HTML jak i dynamicznych
33 aplikacjach pomaga oddzielić kod prezentacyjny od logiki aplikacji, co
34 ułatwia pracę nad projektem.
35
36 %package devel
37 Summary:        ClearSilver development package
38 Summary(pl.UTF-8):      Pakiet programistyczny ClearSilver
39 Group:          Development/Libraries
40
41 %description devel
42 This package provides needed files to develop extension to
43 ClearSilver.
44
45 %description devel -l pl.UTF-8
46 Ten pakiet dostarcza pliki potrzebne do tworzenia rozszerzeń dla
47 ClearSilver.
48
49 %package -n python-clearsilver
50 Summary:        Neotonic ClearSilver Python Module
51 Summary(pl.UTF-8):      Moduł Pythona Neotonic ClearSilver
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54
55 %description -n python-clearsilver
56 This package provides a Python interface to the ClearSilver CGI kit
57 and templating system.
58
59 %description -n python-clearsilver -l pl.UTF-8
60 Ten pakiet dostarcza interfejs Pythona do zestawu CGI i systemu
61 szablonów ClearSilver.
62
63 %package -n perl-ClearSilver
64 Summary:        Neotonic ClearSilver Perl Module
65 Summary(pl.UTF-8):      Moduł Perla Neotonic ClearSilver
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description -n perl-ClearSilver
70 This package provides a Perl interface to the ClearSilver templating
71 system.
72
73 %description -n perl-ClearSilver -l pl.UTF-8
74 Ten pakiet dostarcza interfejs Perla do systemu szablonów ClearSilver.
75
76 %package -n ruby-clearsilver
77 Summary:        Neotonic ClearSilver Ruby Module
78 Summary(pl.UTF-8):      Moduł Ruby'ego Neotonic ClearSilver
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81
82 %description -n ruby-clearsilver
83 This package provides a ruby interface to the ClearSilver templating
84 system.
85
86 %description -n ruby-clearsilver -l pl.UTF-8
87 Ten pakiet dostarcza interfejs języka Ruby do systemu szablonów
88 ClearSilver.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95
96 find . -type f -print0 | xargs -0 perl -pi -e "s!/usr/local/bin!/usr/bin!g" 
97
98 %build
99 install /usr/share/automake/config.* .
100 %{__aclocal}
101 %{__autoconf}
102 %configure \
103         --disable-csharp \
104         --disable-java \
105         --disable-ruby \
106         --enable-apache \
107         --enable-perl \
108         --with-python=%{__python}
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT \
117         INSTALLDIRS=vendor
118
119 %{__make} install -C python \
120         PYTHON_SITE=%{py_sitedir} \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %{__make} install -C perl \
124         DESTDIR=$RPM_BUILD_ROOT \
125         INSTALLDIRS=vendor
126
127 rm -rf $RPM_BUILD_ROOT%{perl_archlib} \
128         $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*{,/*{,/*}}/.packlist
129
130 # what an ass putting it to lib32 dir
131 %if "%{_lib}" != "lib"
132 rm $RPM_BUILD_ROOT%{_prefix}/lib/python%{py_ver}/site-packages/neo_cgi.so
133 %endif
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %doc CS_LICENSE INSTALL LICENSE README scripts/cs_lint.py contrib/cs-mode.el
141 %attr(755,root,root) %{_bindir}/*
142
143 %files devel
144 %defattr(644,root,root,755)
145 %{_libdir}/libneo_*.a
146 %{_includedir}/ClearSilver
147 %{_mandir}/man3/[!C]*.3*
148
149 %files -n python-clearsilver
150 %defattr(644,root,root,755)
151 %doc README.python
152 %attr(755,root,root) %{py_sitedir}/neo_cgi.so
153
154 %files -n perl-ClearSilver
155 %defattr(644,root,root,755)
156 %{perl_vendorarch}/ClearSilver.pm
157 %dir %{perl_vendorarch}/auto/ClearSilver
158 %attr(755,root,root) %{perl_vendorarch}/auto/ClearSilver/ClearSilver.so
159 %{_mandir}/man3/ClearSilver.3pm*
160
161 %if 0
162 %files -n ruby-clearsilver
163 %defattr(644,root,root,755)
164 %{ruby_sitepath}/%{ruby_version}/neo.rb
165 %attr(755,root,root) %{ruby_sitepath}/%{ruby_version}/%{ruby_arch}/hdf.so
166
167 %files -n apache-mod_ecs
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{apache_libexec}/mod_ecs.so
170 %endif
This page took 0.057892 seconds and 4 git commands to generate.