]> git.pld-linux.org Git - packages/cjson.git/blob - cjson.spec
- updated to 1.7.17 (fixes CVE-2023-50471 CVE-2023-50472)
[packages/cjson.git] / cjson.spec
1 Summary:        Ultralightweight JSON parser in ANSI C
2 Summary(pl.UTF-8):      Ultralekki parser formatu JSON napisany w ANSI C
3 Name:           cjson
4 Version:        1.7.17
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 #Source0Download: https://github.com/DaveGamble/cJSON/releases
9 Source0:        https://github.com/DaveGamble/cJSON/archive/v%{version}/cJSON-%{version}.tar.gz
10 # Source0-md5:  344409fa865ca3440be94089d1cc37ac
11 URL:            https://github.com/DaveGamble/cJSON
12 BuildRequires:  cmake >= 3.0
13 BuildRequires:  rpmbuild(macros) >= 1.605
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 cJSON aims to be the dumbest possible parser that you can get your job
18 done with. It's a single file of C, and a single header file.
19
20 %description -l pl.UTF-8
21 cJSON jest tworzony jako możliwie najprostszy parser wykonujący swoje
22 zadanie. Jest to pojedynczy plik w C i pojedynczy plik nagłówkowy.
23
24 %package devel
25 Summary:        Header files for cJSON library
26 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cJSON
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}-%{release}
29
30 %description devel
31 Header files for cJSON library.
32
33 %description devel -l pl.UTF-8
34 Pliki nagłówkowe biblioteki cJSON.
35
36 %prep
37 %setup -q -n cJSON-%{version}
38
39 %build
40 install -d build
41 cd build
42 %cmake .. \
43         -DENABLE_CJSON_TEST:BOOL=OFF \
44         -DENABLE_CJSON_UTILS:BOOL=ON
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} -C build install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post   -p /sbin/ldconfig
56 %postun -p /sbin/ldconfig
57
58 %files
59 %defattr(644,root,root,755)
60 %doc CHANGELOG.md CONTRIBUTORS.md LICENSE README.md
61 %attr(755,root,root) %{_libdir}/libcjson.so.*.*.*
62 %attr(755,root,root) %ghost %{_libdir}/libcjson.so.1
63 %attr(755,root,root) %{_libdir}/libcjson_utils.so.*.*.*
64 %attr(755,root,root) %ghost %{_libdir}/libcjson_utils.so.1
65
66 %files devel
67 %defattr(644,root,root,755)
68 %attr(755,root,root) %{_libdir}/libcjson.so
69 %attr(755,root,root) %{_libdir}/libcjson_utils.so
70 %{_includedir}/cjson
71 %{_pkgconfigdir}/libcjson.pc
72 %{_pkgconfigdir}/libcjson_utils.pc
73 %{_libdir}/cmake/cJSON
This page took 0.14798 seconds and 4 git commands to generate.