]> git.pld-linux.org Git - packages/cjose.git/blob - cjose.spec
- disable Werror to build with openssl 3.0.0, rel 2
[packages/cjose.git] / cjose.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        JOSE implementation for C
7 Summary(pl.UTF-8):      Implementacja JOSE dla C
8 Name:           cjose
9 Version:        0.6.1
10 Release:        2
11 License:        MIT
12 Group:          Libraries
13 #Source0Download: https://github.com/cisco/cjose/releases
14 Source0:        https://github.com/cisco/cjose/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  7618e839ea0ecfa38355fa7f58391f88
16 Patch0:         openssl3.patch
17 URL:            https://github.com/cisco/cjose
18 BuildRequires:  autoconf >= 2.69
19 BuildRequires:  automake >= 1:1.14
20 BuildRequires:  check-devel >= 0.9.4
21 %{?with_apidocs:BuildRequires:  doxygen >= 1.8}
22 BuildRequires:  gcc >= 6:4.5
23 BuildRequires:  jansson-devel >= 2.3
24 BuildRequires:  libtool >= 2:2.2
25 BuildRequires:  make >= 3.81
26 BuildRequires:  openssl-devel >= 1.0.1
27 BuildRequires:  pkgconfig >= 1:0.20
28 Requires:       jansson >= 2.3
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Implementation of JOSE (JavaScript Object Signing and Encryption) for
33 C/C++.
34
35 %description -l pl.UTF-8
36 Implementacja JOSE (JavaScript Object Signing and Encryption) dla
37 C/C++.
38
39 %package devel
40 Summary:        Header files for cjose library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cjose
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       jansson-devel >= 2.3
45 Requires:       openssl-devel >= 1.0.1
46
47 %description devel
48 Header files for cjose library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki cjose.
52
53 %package static
54 Summary:        Static cjose library
55 Summary(pl.UTF-8):      Statyczna biblioteka cjose
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static cjose library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka cjose.
64
65 %package apidocs
66 Summary:        API documentation for cjose library
67 Summary(pl.UTF-8):      Dokumentacja API biblioteki cjose
68 Group:          Documentation
69 BuildArch:      noarch
70
71 %description apidocs
72 API documentation for cjose library.
73
74 %description apidocs -l pl.UTF-8
75 Dokumentacja API biblioteki cjose.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I m4
84 %{__autoconf}
85 %{__automake}
86 %configure \
87         %{!?with_apidocs:--disable-doxygen-doc} \
88         %{!?with_static_libs:--disable-static}
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 # obsoleted by pkg-config
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcjose.la
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AUTHORS CHANGELOG.md LICENSE README.md
109 %attr(755,root,root) %{_libdir}/libcjose.so.*.*.*
110 %attr(755,root,root) %ghost %{_libdir}/libcjose.so.0
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/libcjose.so
115 %{_includedir}/cjose
116 %{_pkgconfigdir}/cjose.pc
117
118 %if %{with static_libs}
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/libcjose.a
122 %endif
123
124 %if %{with apidocs}
125 %files apidocs
126 %defattr(644,root,root,755)
127 %doc doc/html/{search,*.css,*.html,*.png}
128 %endif
This page took 0.132813 seconds and 4 git commands to generate.