]> git.pld-linux.org Git - packages/chromaprint.git/blob - chromaprint.spec
- upstream fixes for ffmpeg 5+, rel 2
[packages/chromaprint.git] / chromaprint.spec
1 #
2 # Conditional build:
3 %bcond_without  ffmpeg  # fpcalc build + libchromaprint using avfft
4 %bcond_with     fftw3   # libchromaprint using fftw3 instead of avfft
5 #
6 %if %{without ffmpeg}
7 %define with_fftw3      1
8 %endif
9 Summary:        Library implementing the AcoustID fingerprinting
10 Summary(pl.UTF-8):      Biblioteka implementująca odciski AcoustID
11 Name:           chromaprint
12 Version:        1.5.1
13 Release:        2
14 License:        LGPL v2.1+
15 Group:          Libraries
16 #Source0Download: https://github.com/acoustid/chromaprint/releases
17 Source0:        https://github.com/acoustid/chromaprint/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  54e71f86bcf1d34989db639044ba9628
19 Patch0:         ffmpeg5.patch
20 Patch1:         ffmpeg5-decode-retry.patch
21 URL:            https://acoustid.org/chromaprint
22 BuildRequires:  cmake >= 3.3
23 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.6}
24 %{?with_fftw3:BuildRequires:    fftw3-devel >= 3}
25 BuildRequires:  libstdc++-devel >= 6:4.7
26 BuildRequires:  taglib-devel
27 Requires:       libchromaprint = %{version}-%{release}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Chromaprint library is the core component of the AcoustID project.
32 It's a client-side library that implements a custom algorithm for
33 extracting fingerprints from raw audio sources.
34
35 The library exposes a simple C API and the Python language binding is
36 also available. The documentation for the C API can be found in the
37 main header file.
38
39 %description -l pl.UTF-8
40 Biblioteka Chromaprint to główny element projektu AcoustID. Jest to
41 biblioteka kliencka implementująca własny algorytm wydobywania
42 odcisków identyfikacyjnych z surowych strumieni dźwiękowych.
43
44 Biblioteka udostępnia proste API C. Dostępne są także wiązania dla
45 Pythona. Dokumentację dla API C można znaleźć w głównym pliku
46 nagłówkowym.
47
48 %package -n libchromaprint
49 Summary:        Library implementing the AcoustID fingerprinting
50 Summary(pl.UTF-8):      Biblioteka implementująca odciski AcoustID
51 Group:          Libraries
52
53 %description -n libchromaprint
54 Chromaprint library is the core component of the AcoustID project.
55 It's a client-side library that implements a custom algorithm for
56 extracting fingerprints from raw audio sources.
57
58 The library exposes a simple C API and the Python language binding
59 is also available. The documentation for the C API can be found in the
60 main header file.
61
62 %description -n libchromaprint -l pl.UTF-8
63 Biblioteka Chromaprint to główny element projektu AcoustID. Jest to
64 biblioteka kliencka implementująca własny algorytm wydobywania
65 odcisków identyfikacyjnych z surowych strumieni dźwiękowych.
66
67 Biblioteka udostępnia proste API C. Dostępne są także wiązania dla
68 Pythona. Dokumentację dla API C można znaleźć w głównym pliku
69 nagłówkowym.
70
71 %package -n libchromaprint-devel
72 Summary:        Headers for developing programs that will use libchromaprint
73 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów wykorzystujących libchromaprint
74 Group:          Development/Libraries
75 Requires:       libchromaprint = %{version}-%{release}
76
77 %description -n libchromaprint-devel
78 This package contains the headers that programmers will need to
79 develop applications which will use libchromaprint.
80
81 %description -n libchromaprint-devel -l pl.UTF-8
82 Ten pakiet zawiera pliki nagłówkowe potrzebne programistom do
83 tworzenia aplikacji wykorzystujących bibliotekę libchromaprint.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89
90 %build
91 install -d build
92 cd build
93 %cmake .. \
94         %{?with_ffmpeg:-DBUILD_TOOLS=ON} \
95         %{!?with_fftw3:-DWITH_AVFFT=ON} \
96         %{?with_fftw3:-DWITH_FFTW3=ON}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} -C build install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %clean
107 rm  -rf $RPM_BUILD_ROOT
108
109 %post   -n libchromaprint -p /sbin/ldconfig
110 %postun -n libchromaprint -p /sbin/ldconfig
111
112 %if %{with ffmpeg}
113 %files
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_bindir}/fpcalc
116 %endif
117
118 %files -n libchromaprint
119 %defattr(644,root,root,755)
120 %doc NEWS.txt README.md
121 %attr(755,root,root) %{_libdir}/libchromaprint.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libchromaprint.so.1
123
124 %files -n libchromaprint-devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libchromaprint.so
127 %{_includedir}/chromaprint.h
128 %{_pkgconfigdir}/libchromaprint.pc
This page took 0.083683 seconds and 4 git commands to generate.